Change VM Serial number not working (Windows 11)

Discussion in 'Windows Guest OS Discussion' started by FelixP4, May 2, 2022.

  1. FelixP4

    FelixP4 Bit Poster

    Messages:
    3
    I followed the following guide to change the system serial number of my Parallels Windows 11 install (on Macbook M1).
    https://kb.parallels.com/123455
    Unfortunately it still returns the original serial (Parallels-6A CF DF etc)
    I tried both option, edition the configuration file and adding the boot flag. Is that guide still applicable for Windows 11 or do I need to do something else?

    Thanks
     
  2. GampaA@Parallels

    GampaA@Parallels Staff Member

    Messages:
    437
    Hello FelixP4, Please follow the steps mentioned below.
    1. macOS\OS X virtual machine. Open Terminal on macOS\OS X virtual machine > execute the command: ioreg -l | grep IOPlatformSerialNumber.
    2. Windows virtual machine. Open Command Prompt on Windows virtual machine > execute the command: wmic bios get the serial number. Thanks.
     
  3. FelixP4

    FelixP4 Bit Poster

    Messages:
    3
    Hi, thanks for your reply.
    I've run these commands before, still they return the same result.
    On macOS ioreg -l | grep IOPlatformSerialNumber returns "IOPlatformSerialNumber" = "K7PQXXXXXX" (The same as in System Information)
    On Windows I run wmic bios get serialnumber wich returns Parallels-6A CF XX XX XX XX XX XX XX XX XX XX XX XX X XX (wmic bios get the serial number doesn't work)

    I've changed <SerialNumber></SerialNumber> to <SerialNumber>K7PQXXXXXX</SerialNumber> in config.pvs and I have changed the boot flag to devices.smbios.serial="K7PQXXXXXX" (I also tried without quotationmarks).

    Unfortunately I see no changes when I execute the command after booting windows again.
     
  4. FelixP4

    FelixP4 Bit Poster

    Messages:
    3
    Nevermind. I just realised I am running Parallels Standard Edition, this function I only available on Pro or Business edition :(
     
  5. PeterC408

    PeterC408

    Messages:
    2
    Dear all. I am trying to do this. I am in the 14 day trial of version 17 and using a Mac OS Guest. According to the support document it should be possible.

    However the config is greyed out. How do you add the config file or the boot flag?
     

Share This Page