Chrome browser graphics issue on OS X guests with OS X El Capitan host, Parallels 11 and 10

Discussion in 'Mac OS X Guest OS Discussion' started by RyanC6, Oct 17, 2015.

  1. RyanC6

    RyanC6 Bit Poster

    Messages:
    4
    Symptoms: Any web page that is loaded in Chrome browser on the OS X guest appears distorted (see attached screen shot).
    Host OS: OS X El Capitan 10.11
    Guest OS: OS X Yosemite 10.10.5, OS X Mavericks 10.9.5
    Parallels software: 11.0.2 (31348), 10.3.0 (29227)
    Chrome version: 46.0.2490.71 (latest version)
    Hardware: MacBook Pro (Retina, 15-inch, Late 2013), Model: MacBookPro11,3

    Troubleshooting performed:
    - Installed a clean copy of El Capitan on my Mac Book Pro, and installed the latest version of Parallels 11. Created new guest OS using DMG of Mavericks installer, and installed all OS updates. Downloaded and installed latest version of Chrome web browser. Attempted to browse to several different web sites, with all appearing distorted. Created new guest OS using DMG of Yosemite installer, but experienced the same issue. Unable to change any Chrome settings since this loads in the browser window and is also distorted.

    - Uninstalled Parallels 11 using the PDRemove script posted on Parallels website. Installed the latest version of Parallels 10, and created new Mavericks and Yosemite guest OS's, but experienced the same issue.

    - Turned off Automatic graphics switching on the Host OS in System Preferences > Energy Saver, but experienced the same issue.


    Is there anything I can do to resolve this? Is this a known issue, and is there a fix being worked on? I did a search of the Parallels forums, but did not find any information.
    I will just re-install Yosemite as the host OS on my laptop if there is no workaround or fix being worked on yet. That's not too difficult for me. However, it is still disappointing that I've paid for a 12 month subscription, and am not able to utilize Parallels in the same way I was able to with Yosemite as my host OS.
     

    Attached Files:

  2. thicke

    thicke Bit Poster

    Messages:
    4
    I have the same problem on two different host machines.
    Machine 1: MBP (Retina, 15-inch, Mid 2015) Yosimite - Parallels 11.0.2 (31348)
    Machine 2: MBP (15-inch, Mid 2012) El Capitan - Parallels 11.0.2 (31348)
    Both VMs are Yosimite.
     
  3. RyanC6

    RyanC6 Bit Poster

    Messages:
    4
    Thank you for contributing to this thread - I'm glad to have confirmation that this is affecting at least one other Parallels user. Also interesting to hear that Parallels 11 is causing the same issue on a Yosemite host. I had an untested theory that this issue was related to the move from OpenGL to Metal as the graphics API on El Capitan, but your post shows this is false.

    It also deepens my disappointment that Parallels development did not even properly QA version 11 on Yosemite. I can somewhat understand the uncertainty of preparing for El Capitan, but not an available host OS such as Yosemite. They really seemed to have rushed their new release to market to win the "we're first to support El Capitan and Windows 10" race. I could be missing some information on this, and I would welcome a correction, but have not seen or heard otherwise.
     
    thicke likes this.
  4. thicke

    thicke Bit Poster

    Messages:
    4
    I think I'll try upgrading the VM I have on El Capitan to El Capitan and see if what happens.
     
  5. SThumb

    SThumb Bit Poster

    Messages:
    1
    Hi Ryan, this is happening to me too. Any page I view in Chrome looks totally out of whack. Do you know a fix for this? Many thanks.
     
    Last edited: May 31, 2016
  6. RonnieM1

    RonnieM1 Bit Poster

    Messages:
    1
    Unchecking the "Use hardware acceleration when available" option in Google Chrome > Settings > Show advanced settings > System appears to have resolved this issue for me.
     
    Maria@Parallels likes this.
  7. ThomasB11

    ThomasB11

    Messages:
    1
    Thanks so much for this! Spent hours messing with reinstalling the host and client OS, then playing with snapshots (maddeningly, it seemed like Chrome would work fine 'out of the box' when first installed, but once the system was restarted or restored from a snapshot, things went wonky), and on and on until I found this thread and your comment. Problem solved - you're a hero!
     
    Maria@Parallels and RonnieM1 like this.
  8. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    2,898
    Thank you for your help!
     
  9. BenoitO

    BenoitO Bit Poster

    Messages:
    1
    Hi,

    The same workaround (uncheck "Use hardware acceleration when available" still has to be used on High Sierra here :'(

    host & guest mac os + paralells ully uptodate.

    Is there going to be a fix for this? :/
     

Share This Page