Clicking and popping audio in Windows 11 ARM on M1

Discussion in 'Windows Guest OS Discussion' started by MichielS, Dec 30, 2021.

  1. MichielS

    MichielS Bit Poster

    Messages:
    1
    Hi everyone. I'm officially back to Team Parallels after having used VMware Fusion for years. The reason is that Parallels actually runs Windows 11 ARM on M1 machines, while VMware is stuck making excuses for why they can't do it.

    Years ago, like maybe around 2012 or something, I switched from Parallels to VMware because I like to use audio applications on my guest system and Parallels had a weird audio stuttering issue, where if the host system was very busy there would be these minuscule clicks and pops in the audio, even with full VM tools support and everything working correctly. It seemed as though maybe Parallels didn't implement an audio buffer at that time, so any slight delay would immediately cause micro gaps. VMware never had this issue, so instead of trying to fix it I just switched over at the time.

    Today I can only use Parallels, but surprisingly this is still an issue even in almost-2022. When I play audio inside a guest application, it works fine until I go back to the host system application and start doing stuff. Then I get clicks and pops. They're very faint, probably because these M1 machines are so fast, but it's still noticeable.

    I'm on an Apple M1 2020 Macbook Air 13", 16 GB RAM, 8 core GPU model. I'm running the Parallels recommended Windows 11 install, activated and fully up to date. My Parallels Desktop version is 17.1.1 (51537). VM tools are active.

    I have to believe that this is fixable, because it feels to me like with even a 5ms audio buffer (in the VM, not in the guest) you'd never get this problem. I'd be fine with slightly delayed audio if it means I get clean audio. However, I can't find anything in the way of an option for setting this. I'm perfectly fine with editing files outside of the main UI if this is required.

    Appreciate any help you might have to offer!
     
  2. MattP9

    MattP9 Bit Poster

    Messages:
    2
    Same problem here. The remedies suggested in other posts do not help.
     
  3. StefanS36

    StefanS36 Bit Poster

    Messages:
    1
    I have the same problem. Did you already find any solution?
     
  4. RyanJ8

    RyanJ8 Bit Poster

    Messages:
    1
    I also am having this issue. Any solutions available?
     
  5. TiagoC5

    TiagoC5 Bit Poster

    Messages:
    1
    I have the same problem
    M1 Max 14ยด with windows 11 Arm
    Any solution please
     
  6. GrahamB4

    GrahamB4 Bit Poster

    Messages:
    5
    Me too with a Mac Pro 16" with Windows 11 Arm. I have tried re-installing Parallels Toolbox as apparently the audio driver is contained within it, but no joy. The only way to stop audio crackling is to stop Win11 which rather defeats the object of having Parallels. Even with no additional Win11 program running the audio is compromised.
    I haven't contacted Support yet as my last experience was far from satisfactory.
    If anybody has found a solution since the last post in April I would be most pleased to read it.
     
  7. DominicM4

    DominicM4

    Messages:
    1
    Same here. Does anybody even bother testing software these days?
     
  8. GrahamB4

    GrahamB4 Bit Poster

    Messages:
    5
    I have contacted support but other than a hopeless "boiler plate" response I have received no further replies. A great product but the worse support I have ever known.
     
  9. MikhailU@Parallels

    MikhailU@Parallels Parallels Support

    Messages:
    102
    Hi All,
    The root cause of the issue is that the virtual machine locks too much memory which results in a lack of memory required for the appropriate functioning of the audio subsystem of the Mac. Possible fixes are outlined at KB https://kb.parallels.com/en/128969 .
     
  10. GrahamB4

    GrahamB4 Bit Poster

    Messages:
    5
    Strangely enough I have just been in contact with your Support team and they eventually came up with similar solution. I have just made the change to 4GB and testing.
    Hello Graham,
    Thank you for sharing your feedback with us.
    The outlined issue is quite complicated and the root cause of the issue is that the virtual machine locks too much memory which results in a lack of memory required for the appropriate functioning of the audio subsystem of the Mac.
    I'd advise you to perform the steps below:
    0. Shut down Windows (Actions > Shut down).
    1. Open the configuration settings of the virtual machine (VM) > Hardware > CPU & Memory > switch to Manual > change the Memory value to 4 GB.
    2. Start Windows - the issue is supposed to be addressed.
    If it's not, kindly reply to this email.

    So far so good :)
     
  11. GrahamB4

    GrahamB4 Bit Poster

    Messages:
    5
    I see that it was you that replied to me Mikhail, sorry didn't realise that initially.
     
  12. GrahamB4

    GrahamB4 Bit Poster

    Messages:
    5
    Unfortunately it hasn't resolved the problem :-(
     

Share This Page