Client Installation Errors - ERR_EMPTY_RESPONSE

Discussion in 'Parallels Client for Mac' started by ScottM22, Jun 5, 2020.

Tags:
  1. ScottM22

    ScottM22 Bit Poster

    Messages:
    3
    Recently a small number of remote customers attempting to install the RAS Client on OSX are experiencing 2 issues:
    1. They click the configure link from their invite email, it redirects to their browser, and it eventually displays an ERR_EMPTY_RESPONSE
    2. Clicking the configure link may launch the Parallels Client but they the error popup "The specified remote RAS Connection could not be found"
    If we have them attempt to manually configure the connection then they will see the same error as #2 above.

    If they attempt to directly access the URL in the browser they see the error "RAS SecureClientGateway HTTP forwarding is disabled" which we expect, we have disabled the HTML5 client and expect them to use the installed client. However this shows they can access the URL of the RAS server.

    Since most customers have no issues and this is limited to a small number of customers, it's not a systemic issue.

    My questions:
    • Is this a known issue? It seems to be a recent development.
    • Are there steps we can have them take to address the issue?
    • Can we enable verbose logging on the client in OSX? The option appears greyed out and the logs at "~/Library/Containers/com.2X.Client.Mac/Data/ParallelsClient.log" don't contain anything that appears useful for diagnosing this.
     
  2. Eugene. K.

    Eugene. K. Parallels Team

    Messages:
    81
    Hi ScottM22,
    Do you have other customers who can use the invitation link to get the client configuration? If yes, then this is not something easy to guess and I advise you to contact support.

    Regarding the greyed out log button it could be a policy delivered from one of the registered RAS connections:
    upload_2020-6-8_10-23-28.png
     
  3. ScottM22

    ScottM22 Bit Poster

    Messages:
    3
    Most customers can use the link without issue, I'd estimate this affects 1-3% of our customers.

    I didn't know the logging level could be controlled via the RAS server. I'll look into that to see if it helps give us more information about the root cause.

    Thanks!
     
  4. ScottM22

    ScottM22 Bit Poster

    Messages:
    3
    Actually, in thinking about it - the logging level being determined server side won't help us here since the root issue is they can't successfully configure a connection to our RAS server. So any server driven policies won't be applied to the affected clients.
     

Share This Page