client sees desktop, not application

Discussion in 'Parallels Remote Application Server' started by tthkbw, Jan 20, 2007.

  1. tthkbw

    tthkbw Guest

    I have installed 2x application server and published an application.

    However, when I connect to the server via the 2xclient, I don't get the application I published, but the desktop of the server instead.

    Any ideas what I am doing wrong?

    Terry Brown
  2. tthkbw

    tthkbw Guest

    OK, I figured it out

    It turns out that if the terminal server machine is logged in, you get the desktop, not the application.

  3. nixu

    nixu Guest

    Hi there,

    Can you us give more details regarding the terminal server and the application you are publishing.

  4. visik7

    visik7 Guest

    same problem here
    when I run
    ./appserverclient -s -u <username> -p <password> -a "Network Connections" -o 3
    I got a full screen windows session

    Windows XP SP2

    the output on the console is:
  5. visik7

    visik7 Guest


    keeping the account logged of all works
  6. nixu

    nixu Guest

    Please Note that Windows XP SP2 is not a terminal server.

    Thus it will not allow the execution of a single application. Windows XP allows remote assistance, so only the full screen will be available.

    2X Application Server works with terminal servers.


  7. kilou

    kilou Guest

    I run Ubuntu 6.10 as host and XP pro SP2 as guest with VirtualBox and 2x Application Server. I have published both windows media player and internet explorer to test if this works but get the exact same issue: when I run ./appserverclient -s192.168.112.202 -a"wmplayer" -uusername -ppassword I can see the desktop in fullscreen but the application is not launched. I tried to log out of the XP guest and retype the command in linux but again this brings me to the XP desktop :(

    Do you know how I should proceed to launch the application? Also I can see the desktop only if remote desktop is enabled in XP guest but not otherwise. Is this normal?

  8. baklaonoy

    baklaonoy Guest

  9. kilou

    kilou Guest

    Thanks for the link. I installed it but I still get to the XP desktop when launching a published application from Linux. I get to the desktop no matter if I'm logged in or not in Windows..... If I uncheck "allow remote desktop in XP", nothing happens at all. Any clue?
  10. baklaonoy

    baklaonoy Guest

    Very strange, it works perfectly for me (Server win xp pro sp2 with the patch and i tested with Win 2k & xp pro Client)
  11. kilou

    kilou Guest

    My client is Ubuntu (Linux). Is that what may cause the issue?????
  12. baklaonoy

    baklaonoy Guest

    I don't know, test it with a Windows client
  13. kilou

    kilou Guest

    Anybody got this woring on a Ubuntu client?? I'm running XP SP2 as a virtual machine in Ubuntu and would like to publish applications to Ubuntu. I always get to the XP desktop even with the terminal server patch and leaving the XP logged off...
  14. rafelbev

    rafelbev Guest

    I repeat that Windows XP is NOT a terminal server. This platform is not supported. Maybe you missed the Nixu's post .
  15. kilou

    kilou Guest

    Why are then people here like baklaonoy using XP able to publish an application to other operating systems without sending the whole desktop???? Look at the following for instance: ... 29,00.html

    it is XP installed in a virtual machine publishing Excel2003 and some other applications to Ubuntu (exactly what I'd like to achieve). The guy can have Excel2003 running on Ubuntu without seing the whole XP XP is maybe not supported but it sounds like it works least for some people...and I'd like to know how to achieve the same on my system.

    Here is what the guy said:
    "Also, the 2X Application Server product is meant for Terminal Servers running Windows 2000 Server or Windows Server 2003 and is not officially supported with Windows XP Professional Remote Desktop. Both Windows Server 2003 and Windows XP Professional use the same version of RDP, so it would stand to reason that the 2X Application Server product could work on a Windows XP Professional machine. Perhaps if enough people find this solution useful, 2X software might consider officially supporting it in a future product."
  16. kilou

    kilou Guest

    OK finally got it partially working: I had to enable fast user switching in XP to be able to launch the published applications from Ubuntu :) So baklaonoy patch + fast user switching enabled and it definitely works in XP!

    ...not prefectly though if applications are not launched in fullscreen.

    EDIT: SOLVED AGAIN!!! You can launch windowed applications with XP if you use the option -m2X in the command of applicationserver!! I was able to play freecell in Ubuntu in windowsed mode. I don't know if this applies to Windows clients too but at least in Ubuntu it works. However for some reasons this doesn't work with Internet Explorer.


    The next thing to solve now is how to launch more than 1 published application. This should be possible as this is what had been achieved on the link in my previous post but in Ubuntu when I launch one application from the terminal, the terminal seems locked until the current published application is relased.... However the guy on the link had freecell, command prompt and excel all running at the same time on Ubuntu and the applications were published with XP. Also it is quite slow to quit a published application.
  17. rimtech

    rimtech Guest


    kilou is correct
    I ran into this problem with Windows XP Professional aswell.

    For maximum sucess... leave the operating system logged out on the physical machine/vm.

    Keep fast user switching enabled.

    Use the -m2X to correct the issue of moving windows that are not full screen.

    Linux rimtech-desktop 2.6.17-11-generic #2 SMP Thu Feb 1 19:52:28 UTC 2007 i686 GNU/Linux (Ubuntu 6.10 Edgy Eft)

    my command...

    ./appserverclient -s -u Rimtech -p vmware -a IEXPLORE -e0x00 -m2X

    where -s is the ip address of your server
    where -u is the username of the user on the server
    where -p is the password of the server
    where -a is the name of the application you wish to load
    where -e is the features you want to disable (0x00 leaves the pretty blue borders intact...)
    and -m2X is VITAL... at least on my ubuntu installation
  18. sherikrot

    sherikrot Guest

    I had the same problem from ubuntu to Windows XP.
    Try to reboot the XP and leave the operating system logged out.
    Do not log in!
    then, try to launch an application from ubuntu.

Share This Page