Clipboard sharing, anyone?

Discussion in 'Linux Guest OS Discussion' started by RainerS1, Nov 27, 2022.

  1. RainerS1

    RainerS1 Bit Poster


    for me on Ventura, Parallels 18.1 Clipboard sharing does not work on Ubuntu 22.10 and Raspberry Pi OS using Debian Bullseye. It does work with Windows 11. I have checked for clipboard tools, none that I could identify. So is my impression correct, that it just doesn't work, or is there anything I can do?

  2. RichardM16

    RichardM16 Bit Poster

    I'm having the same problem - Ubuntu 22.04 LTS ARM, Parallels 18.1 on ARM MBP. The copy-and-paste is intermittent.
    I did notice that usually there is an icon of a program running with no name on the Fav bar on the right. When copy-and-paste is not working (mac to ubuntu), I don't see that icon anymore.
    Perhaps the copy-and-paste is dependent on a daemon that is not running?
  3. JimC22

    JimC22 Bit Poster

    I'm running Ubuntu 20.04 LTS with Parallels Desktop Pro 18.1.1 on an Intel iMac. It seems that 18.1.1 is when I started having problems. Copy-Paste often works fine just after starting up the VM and then copy-paste stops working at some point. The "daemon stopped running" theory makes sense. I hope this gets fixed soon as it's very annoying.
  4. (GalaxyMaster)

    (GalaxyMaster) Kilo Poster

    My copy-n-paste works Intel Macbook Pro with Ventura running Arch Linux in a VM. However, I do have a slight issue -- inside VM I can select stuff with the mouse and paste it using the middle mouse buttom (Cmd+tap), but if I want to copy-n-paste between macOS and Linux I need to use Ctrl-Shift-C (for copy) and Ctrl-Shift-V (for paste) inside the guest while in macOS Cmd-C and Cmd-V are working as expected. Previously, the clipboard was shared, so if I copied something on macOS using Cmd-C I could paste it with Cmd+tap inside the guest, now I cannot. Well, I kind of got used to two clipboards over the time, though.
  5. JimC22

    JimC22 Bit Poster

    I upgraded from Catalina to Monterey over the weekend and, so far, the clipboard sharing has been working. I did get a warning (when I first booted up in Monterey) that there was a Parallels "Legacy Extension" that might not work in future versions of macOS.

    (GalaxyMaster) - In my experience, the middle mouse button paste has always been like what you describe in Linux. I've always had to use CTRL-C to get text to the shared clipboard.
  6. SergeiE

    SergeiE Bit Poster

    Same issue here. The copy-and-paste clipboard is intermittent. Works well on guest os start, stops working at some point. Very frustrating!

    Anyone tried maybe another linux distro to avoid this?

    Tried reinstalling Parallels Tools with no success.

    PS: Config: Parallels Desktop 18, Macbook Pro 14" M1 Pro / 16gb RAM.
    Guest OS: Ubuntu 22.04 LTS.

    Need help!

Share This Page