Components Won't Install on High Sierra Host

Discussion in 'Installation and Configuration' started by BarryI, Dec 17, 2017.

  1. BarryI

    BarryI Bit Poster

    Parallels 13.2.0-43213
    macOS 10.31.1 High Sierra Server (host OS)

    After getting the prompt to allow components to be loaded, clicking the Allow button in System Preferences>General> where it says "System software from developer "Parallels International GmbH" was blocked from loading" does nothing with System Preferences locked or unlocked. How can I get this installed? Will booting with extensions off allow the extension to be installed and then loaded?
  2. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Hi @BarryI, follow these steps to disable SIP:
    Restart your Mac.
    Before OS X starts up, hold down Command-R and keep it held down until you see an Apple icon and a progress bar. Release. This boots you into Recovery.
    From the Utilities menu, select Terminal.
    At the prompt type exactly the following and then press Return: csrutil disable
    Terminal should display a message that SIP was disabled.
    From the menu, select Restart.
    You can re-enable SIP by following the above steps, but using csrutil enable instead.
  3. RobertK19

    RobertK19 Bit Poster

    The same problem can also occur when accessing the machine via remote desktop or using a 3rd party mouse emulation software. Clicking the "Allow" button on the machine itself worked for me after having the same problem.


  4. Sathiya@Parallels

    Sathiya@Parallels Staff Member

    Hello RobertK19. Nice to know that you were able to sort out the issue and thanks for sharing the feedback. Please post again for any additional queries.
  5. LarryG2

    LarryG2 Bit Poster

    This problem as described by Barryl can be solved by tabbing through the controls on the Mac System Preferences window.
  6. Ajith@Parallels

    Ajith@Parallels Parallels Support

    Yes, it can be but sometimes disabling S.I.P also helps.

Share This Page