Connect CD/DVD or Image File freezes VM

Discussion in 'Parallels Desktop for Mac' started by sdavissm, Mar 17, 2007.

  1. sdavissm


    In 3186 and 3188 both I cannot connect CD/DVD or Image file. When I do the whole XP PRO SP2 VM freezes. I've turned auto connect on and off, tried two different DVD drives (one built in, one USB). I got parallels tools to install by copying the files out of the .iso onto my desktop and running the install through shared folders. That didn't help either.

    Any suggestions?
  2. mmika

    mmika Kilo Poster

    Please, provide us more information about your guest OS configuration and installed software.
    Boot with disconnected CDROM, and look at Windows Device Manager (Right click in my computer-> manage->device manager->dvd/cd-rom drives) What is drive you see?
    Try to uninstall cdrom drive, after that reboot your windows.
    Also try to boot with parallels tools.iso connected (for example)at startup. Will windows freeze?
  3. sdavissm


    It's a very generic XP Pro SP2 install, with whatever updates that Windows Update loaded. I have Family Tree Maker, & Garmin Mapsource, Microsoft Publisher installed for applications. I have Bonjour Printer Wizard, Zone Alarm & AVG antivirus installed also. I've tried booting without Zone Alarm & AVG antivirus. It didn't help.

    The DVD/CD that shows up in Device Manger is PRL Virtual CD-ROM. I've already tried removing it and re-installing it. That didn't work.

    Windows does indeed freeze if I boot with tools.iso connected at startup. It takes about a minute after boot for it to freeze.

    I also noticed I can connect a drive with no disk in it and it doesn't freeze until I insert a disk.
    Last edited: Mar 17, 2007
  4. mmika

    mmika Kilo Poster

    hmm... Please boot your windows with real drive connected (with disk or without it doesn't matter) and look at device name into device manager again. If it will not your real device drive, uninstal it form windows and reboot. If name shown correctly , go to drive properties ->driver. And update your atapy.sys or uninstall it and reboot. You are the first with such problem, and it's very strange. Have you tried another builds between 1970 and 3186?
  5. sdavissm


    Yes, I had 3170 working fine, I think. Although I cannot remember if I ever used the DVD/CD drive while on 3170. I know it worked on 1970.

    If I boot without a disk in and the CD auto connect then it does correctly show the right drive. However, when I insert a disk the VM feezes. I then tried removing the drive and re-booting. I saw the "new hardware found" bubble in the lower right corner, but inserting a disk still freezes the VM. I don't think it's the driver as this problem happens with virtual disks too, wouldn't that be a different driver? The driver for the DVD/CD rom doesn't have atapy.sys as a component. Is that somewhere else?

    Last edited: Mar 18, 2007
  6. Gregory McNamee

    Gregory McNamee

    I'm having exactly the same problem, and removing and rebooting doesn't do a thing. I'm on a 20-inch iMac with a Pioneer DVD drive.
  7. mmika

    mmika Kilo Poster

    Sorry, there was a mistake. Of couse driver name is atapi.sys
    Very strange, but CDROM was not changing since 3094, as I remember. I'll check it.
    And the most interesting thing that image emulation doesn't work... I suppose that some errors depending from specific hardware may occur, but image emulation stays same for all users. Where did you get SP2 for XP? Try to download another one from
    And, please, tell me the transfer mode of IDE channel. Is channel with CDROM drive working in PIO or DMA mode? You can find it into IDE controller preferences: Device manager->IDE/ATAPI controllers ->Primary IDE channel-> Advanced Settings->Device 1)
    This is generic path for default configuration, i.e into VM configuration CDROM is 0:1
    where 0 - primary IDE channel 1 - device 1.
    For example, if your CDROM into VM configuration is 1:0, so path to device into guest windows device manager is IDE/ATAPI controllers ->Secondary IDE channel-> Advanced Settings->Device 0.

    If mode of IDE channel is PIO, set transfer mode to "DMA if available" and reboot.
    Thank you for you help!
    Last edited: Mar 18, 2007
  8. sdavissm


    It is already set to DMA if available.

    I got SP2 from Microsoft, but I'll try downloading and installing again.

  9. mmika

    mmika Kilo Poster

    Ok. It is set to "DMA if available" but what about current transfer mode? If it is DMA also, try to set it to PIO.
    I think, there is not need to download SP2 from microsoft again. You can update your atapi.sys to driver that comes with XP.
    Last edited: Mar 18, 2007
  10. mmika

    mmika Kilo Poster

    And one more question, what is type of guest OS you have selected on VM configuration?
  11. sdavissm


    I tried PIO, still freezes on insert of disk.

    OS is set to Windows, Windows XP.

    Re-install of SP2 didn't help.

    I'm going to roll back to 1970 and see what happens.

    Update: I did go back to 1970 and the DVD/CD works.

    Update 2: upgraded directly from 1970 to 3188 and DVD/CD insert freezes VM.
    Last edited: Mar 18, 2007
  12. mmika

    mmika Kilo Poster

    That is bad. I can't even reproduce your situation. Please, provide us your *.pvs file.
    Have you another virtual machines?
  13. sdavissm


    I do not have any other VMs. Well, I did. I had a Virtual PC VM, but when I used Tansporter to move it over, it needed to be activated again, since hardware (virtual) changed. However, I'm out of activations and have to call India each time. So, I got the stuff I wanted out of the VM during the 3 day activation window and then deleted it. I could use transporter again and get another 3 days. I also have an old Windows 98 Virtual PC that I could transport over. They both are on backup so I have to restore first.

    Are you part of the Parallels development team? If so, where should I send the pvs file? Or should I post the contents here. I opened it with BBEdit and it looks like just text.
    Last edited: Mar 19, 2007
  14. mmika

    mmika Kilo Poster

    Yes, I am from Parallels development team.
    Am I right undertand that your VM you've get by converting virtual PC's VM?
    Do you have Window distributive? I want to recommend you install fresh windows to another VM, but do not activate, just for test. You VM configutration may consist only from one HDD and one CD/DVD-ROM drive. I't very fast process on the MAC.
    And of couse, I want to see your pvs and bugreport text file at the moment when VM freezes. it's a single text file like windows INI file. To create bugreport file choose menu item "Report a problem"
  15. sdavissm


    No. My VM was created with 1970 with my legal copy of XP Pro that I then took and slip streamed in SP2 so that I could install it to Bootcamp prior to owning Parallels. Bootcamp required SP2. I will try a fresh install into a new VM. Below are the two files you requested.

    Boot = d
    Parallels VM Name = Microsoft Windows XP
    VM Id = {d34c3968-7ec4-4490-bfb4-ac75d0001b55}
    VM Description =
    OS Type = 135
    Memory = 512
    Video Memory = 16
    Memory block size = 10
    Acceleration level = 2
    Enable write-back disk cache = 1
    VT-x support = 1
    Start auto = 0
    AutoShutdown = 0
    Start full screen = 21
    Start dashmode = 0
    Start full screen warning = 1
    PC Speaker enable = 1
    Window Mode = 1
    Multi frame = -1
    Guest Tools Status = 2
    [Shared folders]
    Shared folders enabled = 1
    Sharing enabled = 2
    Shared folders count = 2
    Folder0 enabled = 1
    Folder0 readonly = 0
    Folder0 name = All Disks
    Folder0 path = /Volumes
    Folder0 descr =
    Folder1 enabled = 1
    Folder1 readonly = 0
    Folder1 name = scott on mac
    Folder1 path = /Users/scottrdavis
    Folder1 descr =
    Video resolutions enabled = 1
    Video resolutions count = 0
    Show taskbar = 0
    Relocate taskbar = 0
    Exclude Dock = 1
    Multiple displays = 0
    [IDE devices]
    Disk 0:0 enabled = 1
    Disk 0:0 = 1
    Disk 0:0 media = 0
    Disk 0:0 connected = 1
    Disk 0:0 image = winxp.1.hdd
    Disk 0:0 cylinders = 16254
    Disk 0:0 heads = 16
    Disk 0:0 sectors = 63
    Disk 0:1 enabled = 1
    Disk 0:1 = 2
    Disk 0:1 media = 1
    Disk 0:1 connected = 1
    Disk 0:1 image = MATSHITA DVD-R UJ-857
    Disk 1:0 enabled = 0
    Disk 1:0 = 0
    Disk 1:1 enabled = 0
    Disk 1:1 = 0
    [Floppy disks]
    Floppy 0 enabled = 1
    Floppy 0 = 1
    Floppy 0 image = /Library/Parallels/Tools/vmtools.fdd
    Floppy 0 connected = 0
    [Serial ports]
    COM1 enabled = 0
    COM1 = 0
    COM2 enabled = 0
    COM2 = 0
    COM3 enabled = 0
    COM3 = 0
    COM4 enabled = 0
    COM4 = 0
    [Parallel ports]
    LPT1 enabled = 0
    LPT1 = 0
    LPT2 enabled = 0
    LPT2 = 0
    LPT3 enabled = 0
    LPT3 = 0
    Sound enabled = 1
    Sound = 1
    Sound connected = 1
    Sound device = Default Audio
    Mixer device = Default Audio
    Network enabled = 1
    Network = 1
    Network connected = 1
    Adapter No = 0
    Adapter name = Default Adapter
    Adapter type = 4
    Port = 0x00000300
    IRQ = 3
    MAC address = 00fb37eaf342
    Network2 enabled = 0
    Network2 = 0
    Network3 enabled = 0
    Network3 = 0
    Network4 enabled = 0
    Network4 = 0
    Network5 enabled = 0
    Network5 = 0
    USB enabled = 1
    USB = 1
    USB autoconnect = 0

    ----------------- Activation Data ----------------
    Status: Valid
    User Name: Scott Davis
    Company Name:
    Product ID: 6-3221441106-131076
    Validity period: Not limited
    Product Name: Parallels® Desktop for Mac
    Product Version: Build 3188 (March 7, 2007)
    -------------- End of Activation Data ------------
    --------------- Host PC information ------------
    ---Primary OS version:
    Darwin Kernel Version 8.9.1: Thu Feb 22 20:55:00 PST 2007; root:xnu-792.18.15~1/RELEASE_I386---End of Primary OS version
    ---Processor(s) info:
    Number of CPU: 2
    ---End of Processor(s) info
    ---Memory info:
    User memory: 1867149312
    ---End of Memory info
    Home directory: /Users/scottrdavis
    Session: local
    Memory size: 2048
    ----------- End of Host PC information ---------
    ------------ Guest system configuration ------------
    Current configuration (8b0b6b):
    OS type: Windows XP (135)
    Boot: d
    Memory: 512 Mb
    Memory block size: 2^10
    Overall memory limit: 1628
    Monitor base: 0xec000000
    Memory working set : current=0x20000, maximum=0x20000
    Monitor host speed: 1996
    Timer resolution: 1
    Refresh rate: 40
    Use opt cmos: 1
    Time schema: 1
    Timer adjusting schema: 0
    Time period scale: 10000
    Minamal timer tsc ticks: 500000
    Halt tsc ticks ignore: 1
    Portion slow timer: 4
    Portion plan timer: 1
    Acceleration level: 2
    Smart application acceleration: 1
    Smart kernel acceleration: enable=1, state=777
    Smart kernel mode #2: 1
    Fast stub parameter: 0xffffffff
    Fast system call: 0
    Fast system call #2: 1
    Multi frame parameter: 4
    Hack parameter: 4
    Bit D remap: 1
    Ignore interrupts parameter: 0
    Minimal async time: 0
    Enable write-back disk cache: 1
    Strong checks: 0
    Full LDT map: 1
    VM was resumed: 0
    PC speaker: 1
    Screen resolution: 1152x864x32 (stretch: 1x1)
    Vesa mode: 0x168
    FDD0: type=12, insert=0, path=/Library/Parallels/Tools/vmtools.fdd
    IDE0: HDD, type=1DE, cyl=16254, head=16, spt=63, path=/Users/scottrdavis/Documents/Windows/winxp.1.hdd
    IDE1: CD-ROM, type=CD, insert=1 path=MATSHITA DVD-R UJ-857
    Network: type=RTL8029(AS), mem=0, port=0x300, irq=3 mac=00fb37eaf342
    Sound: 1
    PCI: devices=0x61
    -------- End of guest system configuration ---------
    ------------------- Print buffer -------------------
    [Time elapsed from VM start : 5.143 second(s)]
    [Time elapsed from VM start : 5.143 second(s)]
    [Time elapsed from VM start : 5.143 second(s)]
    [Time elapsed from VM start : 5.143 second(s)]
    [Time elapsed from VM start : 5.143 second(s)]
    [Time elapsed from VM start : 5.143 second(s)]
    ---------------- End of print buffer ---------------
    -------------- Guest processor state ---------------
    Inhibit Mask=0

    CS=0008 [0000FFFF 00CF9B00] V=1
    SS=0010 [0000FFFF 00CF9300] V=1
    DS=0023 [0000FFFF 00CFF300] V=1
    ES=0023 [0000FFFF 00CFF300] V=1
    FS=0030 [F0000001 FFC093DF] V=1
    GS=0000 [0000FFFF 00009300] V=1

    EAX=00002E48 EBX=FFDFF000 ECX=FFDFFC50 EDX=80010031
    ESI=80558E20 EDI=80559080 EBP=FFDFF980 ESP=805502F8
    EIP=806F372A EFLAGS=00000213

    LDTR=0000 [00000FFF FFD0FFFF] V=0
    TR=0028 [200020AB 80008B04] V=1


    0008.806F372A C3 ret

    0010.805502F8 EF88 8235 11A8 8232 0100 0000 0324 8055 4A48 821E
    ----------- End of guest processor state -----------
  16. sdavissm


    A fresh install of XP, the CD does work.
  17. mmika

    mmika Kilo Poster

    Thank you for your help. I hope you will work without problems later on :)
  18. mmika

    mmika Kilo Poster

    I think that you can try to get old VM work.
    1. Go to IDE/ATAPI controllers and delete it from VM
    2. Reboot.
    3. Go to CD/DVD-ROM preferenses and update your atapi.sys, but point to windows to get new driver from CDROM.....mmm... that aviable through shared forlders, for example.
    4. Reboot. The main goal of this actions is to intall drivers to IDE controller and CDROM from working windows distributive.
    If it doesn't help, I don't know what is a problem. May be some antivirus software has installed its own drivers...
  19. sdavissm


    I still don't know where to go to load atapi.sys from the XP CD. Where is CD/DVD ROM Preferences?
  20. mmika

    mmika Kilo Poster

    Sorry, I confused you. Atapi.sys is a driver of IDE controller. So you may delete Intel
    82801BA Ultra ATA Storage Controller from your Windows configuration. Reboot windows. After booting windows will find new CDROM drive and IDE controller.
    You can not get driver right from distributive, because it is compressed there.
    I don't know the easiest way to solve you problem.. And I can not advise you another methods, because they are difficult. Solution I gave is for NON-BOOTCAMP VMs only!
    Last edited: Mar 20, 2007

Share This Page