Connecting to Windows remote desktop, on virtual machine.

Discussion in 'Windows Guest OS Discussion' started by Casey C, Oct 8, 2009.

  1. Casey C

    Casey C

    Messages:
    2
    I'm running snow leopard on my imac. I also have parallels desktop, with windows XP Pro installed. I'm also using a Time capsule for my internet access.
    I cannot figure out how to access windows remote desktop from an external computer.
    I have port mapped the Time capsule to send port 3389 to the parallels network adapter IP address. and I have the
    Parallels network adapter(bridged) port mapped to send 3389 to the local address of the virtual machine.
    I still cannot access it from an external source. I have also tried putting the virtual machine and adpater on a different subnet and still nothing.
    Can anyone help with this????
     
  2. Elric

    Elric Parallels Developers

    Messages:
    1,713
    I have questions,

    It is a bit unclear what is assumed here under parallels network adapter

    And.. this one also requires more details - this statement - "Parallels network adapter(bridged) port mapped to send 3389" is unclear, how it was confugured?

    Are you able to access RemoteDesktop from local subnet?
    How many subnets you have?
    which one you have tried?
     
  3. Casey C

    Casey C

    Messages:
    2
    I am not able to access the REmote desktop from the local subnet,
    As Of now I am back down to just one subnet.
    When I had (2) subnets I tried them both and still could not access the program.

    As well i should mention, I have open the firewall, on the Mac, of the Virtual machine, and in Parallels Internet Security. All of these are set to allow the remote application.
     
  4. Elric

    Elric Parallels Developers

    Messages:
    1,713
    Actually, it is still unclear:

    So, you have Virtual Machine adapter bridged to the Default Adapter (or built-in ethernet)?

    This one is unclear: "The parallels network adapter is configured to send DHCP to the virtual machine" - how it was configured?

    If you went to the Preferences -> Network and changed DHCP-ranges for SharedNetworking, then these settings affects only SharedNetworking.... I'd recommend to press "Restore Defaults" in these preferences and forget about them....

    After that, restart the VM and try to connect to the VM from the same subnet again.

    If this won't help, please send a problem report from menu Help->Report a problem (it is not a problem, but problem-report contains your configuration and it will be possible to check whether all settings are ok).

    Post also output of command ipconfig /all from the VM and from the machine from which you are connecting. If you are trying to connect to the VM using its IP, post here the IP
     
  5. sriramh

    sriramh

    Messages:
    1
    A possible solution

    Its a very late now. But in order for the newbies or the next generation to get the answer from this forum itself i am adding a possible solution.

    Configure networking mode to Bridged Networking by going to Virtual Machine -> Hardware -> Network Adapter -> and choose Bridged Networking. Now from the external computer if u try to connect using Remote Desktop connection. It should be working !

    Hope it helps someone :)
     
  6. AmeedJ

    AmeedJ

    Messages:
    3
    By default parallels uses NAT option for networking which assignes 10.x.x.x IP-Address to the virtual machine , thats why you cannot access it from the local subnet. you can change this option to be bridged and it will get an IP-Address same like your IMac or any other device on the network from your router, then you have to find out what is your XP ip-adress and access it remotley via RDP.

    Make sure that RDP is allowed in your XP firewall or any other third party app.

    BTW if you're using an IPad or IPhone you can use parallels mobile to get into the VM even if its not using bridge mode , i highly recommend Parallels 7 its worth the upgrade and parallels mobile is amazing and very stable.
     
  7. AmeedJ

    AmeedJ

    Messages:
    3
    Welcome.

    Hello,

    Your welcome, you can follow me on twitter if you need any quick help @joodtelecom .

    Ofcourse i do not work for parallels but if there is something i can help you with i'll.

    Cheers.
     
  8. Craig1

    Craig1 Bit Poster

    Messages:
    1
    Hi there,

    I am running Parallels version 10.1.2 with a Windows 8.1 virtual machine. I am trying to access the VM from another computer. I have set the network connection to bridged default. This does not seem to assign the VM with any IP accept 10.0.1.199 This is not accessable from my local network. I have tried shared network settings, which supplies a different IP than the mac os, but is still not accessible.

    I have double checked that the Remote connection settings are set to allow of remote desktop sessions. Are there any other settings that you would recommend changing?
     
  9. easy4tutoring

    easy4tutoring Bit Poster

    Messages:
    7
    As a matter of course parallels utilizes NAT choice for systems administration which assignes 10.x.x.x IP-Address to the virtual machine , thats why you can't get to it from the neighborhood subnet. you can change this alternative to be crossed over and it will get an IP-Address same like your Imac or whatever other gadget on the system from your switch, then you need to figure out what is your XP ip-adress and access it remotley by means of RDP.

    Verify that RDP is permitted in your XP firewall or whatever other outsider application.

    BTW in case you're utilizing an Ipad or Iphone you can utilize parallels versatile to get into the VM regardless of the possibility that its not utilizing scaffold mode , i very prescribe Parallels 7 its justified even despite the overhaul and parallels portable is astounding and extremely steady.;)
     

Share This Page