control-alt makes mouse pointer/keyboard focus go back to macos

Discussion in 'Linux Guest OS Discussion' started by KostasK1, Oct 8, 2020.

  1. KostasK1

    KostasK1 Bit Poster

    Messages:
    9
    Hi,
    I have a virtual box of ubuntu 20 using parallels desktop. I am using intellij and frequently have to press ctrl-alt. But that looses focus (keyboard+mouse) from the virtual box. The mouse pointer becomes the pointer of macos and I have to click into the virtual box to gain keyboard focus again. This happens frequently as I use intellij and ctrl-alt is a key combination that I need to press frequently.

    I've configured all keyboard input to go to the virtual box (don't remember now where that setting was!)

    Any advice to fix this?

    Thanks
     
  2. KostasK1

    KostasK1 Bit Poster

    Messages:
    9
    any advice on the above?
     
  3. (GalaxyMaster)

    (GalaxyMaster) Kilo Poster

    Messages:
    62
    This is expected behaviour since Ctrl-Alt is the default hot key for "Release Input" (under the "Parallels Desktop" > "Preferences ..." > "Shortcuts" > "Application Shortcuts"). I think it is the _only_ shortcut you cannot disable in that list.
     
  4. (GalaxyMaster)

    (GalaxyMaster) Kilo Poster

    Messages:
    62
    I just looked around and I think I found a way to fix this :). There is a file that stores all the shortcuts:
    Code:
    galaxy@galaxy ~ % ls -ld ~/Library/Preferences/Parallels/shortcuts.dat
    -rw-r--r--  1 galaxy  staff  2476 18 Oct 18:41 /Volumes/Home/galaxy/Library/Preferences/Parallels/shortcuts.dat
    galaxy@galaxy ~ 
    [CODE]
    
    To disable the "Release Input" one needs to open the file in the hex editor, locate the Unicode string "Release Input" and change the 4th byte after that string from `\0xA` to `\0x0`, then restart you Parallels Desktop GUI.
    
    I understand that if you are not that technical it may be hard, so I am attaching my "shortcuts.dat" file with the "Release Input" hotkey disabled.  All you need to do is to put it into your ~/Library/Preferences/Parallels/ (replacing your version).  Please note, this forum is crazy strict with extensions, hence once you download the attachment you need to ensure that you rename it to be "shortcuts.dat".
     

    Attached Files:

    KostasK1 likes this.
  5. KostasK1

    KostasK1 Bit Poster

    Messages:
    9
    Thanks , I downloaded your dat file and replaced mine. A quick test and it seems to work :)
     
    (GalaxyMaster) likes this.

Share This Page