Copy and Paste keeps stopping mac host to mac VM

Discussion in 'macOS Virtual Machine' started by jonasg4, Mar 9, 2024.

  1. jonasg4

    jonasg4 Bit poster

    Messages:
    2
    Hi guys, had this problem for a while so I thought I'd ask aorund:

    I am using an Apple M1 Pro as the host running MacOS 14.2.1. The VM is also a MacOS 14.2.1, but the problem has been around before this version.
    When I start the VM I can copy and paste between host and VM. Then I suspend and resume or otherwise let time pass (I am not sure what the exact trigger is) and copy and paste is no longer synchronised between the host and the VM. I never have this problem with any Windows VMs. It only happens with Mac VMs and the only way I have found to fix it is via a VM restart.
    Anyone encountered this? Is there a fix or workaround?

    Thanks for your time...
     
  2. jonasg4

    jonasg4 Bit poster

    Messages:
    2
    nobody has seen this behaviour before?
     
  3. AlexanderG17

    AlexanderG17 Bit poster

    Messages:
    5
    I'm seeing this as well, but I'm having issues with Parallels Tools no installing correctly.
    They could be related.
     
  4. JoeyF2

    JoeyF2

    Messages:
    1
    I am having this problem as well and it's really annoying.
    I am trying to copy from my host to my VM. I just figured out that if I copy from the VM and paste into my host, it starts working again. Can't say it will work for everything, but worth a mention.
     
  5. AlbertM14

    AlbertM14

    Messages:
    1
    I''m also having this problem. I've just updated to Parallels 19 Pro for mac and copy paste (bidireccionally from Mac to Windows) stopped working. It worked perfectly in the previous Parallels version. I'm running on a Macbook Air M2.
     

Share This Page