Copy-Paste Suddenly doesn't Work

Discussion in 'General Questions' started by RCBOOKS, Dec 17, 2007.

  1. michelangelo

    michelangelo Bit poster


    Dear Parallels Team,
    I was using an older Parallels version when the security update busted my copy&paste/ drag&drop functions. Since I hadn't upgraded to 3.0 - and hadn't been planning to do so any time soon - I don't have the needed activation key for the upgrade version provided by the above link. How can you help me?
  2. John@Parallels

    John@Parallels Forum Maven

    If you have version starting from 4xxx, you can upgrade to this version
  3. Doug Pieper

    Doug Pieper Bit poster

    I am running Windows XP sp2 in Parallels 4.0.3810 on OS 10.5.6. Despite reports in the forums that the copy paste problem has been resolved I still am having issues. Most of the time (but not always) on start up of XP I am able to perform Copy and Paste from XP to Mac, Mac to XP and XP to XP. However after using XP for a period of time (10 minutes to 4 hours), all copy and paste stops working (except mac to mac). This extremely frustrating and I inevevitably am forced into restarting XP. Help!! I do not want to roll back to Parallels 3 but I am at my wits end!
  4. James Drew

    James Drew Bit poster

    Solution: 1: Create restore point and take registry backup.
    2: Delete all temp files.
    3: Delete all unwanted software's and security software's from add/remove program.
    4: Disable all unwanted services from startup and then remove from registry.
    5: Scan with spyware removal,hijackthis and trojon removal.
    6: Check windows update if found and then download and install.
    7: Restart the computer, and then check it.
  5. JasonA

    JasonA Bit poster

    Copy-Paste Problem Remains

    As far as I can tell, it happens because of Microsoft Office trying to manage the clipboard. I keep getting the not-yet-solved issue of "Cannot clear clipboard". ( or --> I haven't found a solution yet, despite the second link)

    It totally disables copy-paste from VM to Mac and VM to VM. Mac to Mac was unaffected as was Mac to VM. To that point, I was able to open the document in Excel for Mac and copy the rows into the VM.

    I fixed it once by reinstalling tools, but I'm guessing the reboot is what was needed. But, seriously? I have to reboot every time I open Office in the VM?

    The solution offered here is not going to help.

    Please advise.

  6. Toxie

    Toxie Bit poster

    If the issue hasn't been resolved in version 4, why do we think things will go smoothly in 5? I'd love to hear from someone at Parallels... I'm not buying another upgrade just to get rid of bugs.
  7. JasonA

    JasonA Bit poster

    Easy to Reproduce

    (Running Parallels for Mac 4.0.3848 and MS Office 2000 on WinXP; guessing it works for other combinations, too.)

    All you have to do is create a few cells in Excel (I put "one", "two", "three", "four" into four different cells).

    Choose two cells and do a copy. Paste them some where on the sheet. Now repeat the copy process. (In both cases I used Command-C and Command-V, which are converted to Control-C and -V in the VM.)

    At this point, I'm guessing Office wants to use it's rarely-useful feature of having a clipboard history. But because the clipboard is being managed partially by Parallels, it can't clear it and likely leaves it in some weird, half-locked state. Once it gives you the "Cannot Clear Clipboard" error, you have now disabled C&P in your VM. Open up Notepad or something and confirm that you can't copy and paste text around (don't use Word for this exercise as we KNOW we just broke Office).

    To fix this isn't so bad. Go back to the Mac. Open up something like TextEdit. Copy and paste some text. Now you've cleared the partially borked stated of the clipboard. And now the VM can once again C&P.

    It's frustrating. But it's not as noticeable because it only happens when you do TWO or more copy operations in a row, in Office, without doing any C&P on your Mac. That's why it seems random or whatever. I did this on a fresh Mac restart and fresh VM start, with no screen savers and nothing had fallen asleep.

  8. RonaldD

    RonaldD Bit poster

    It is 2010 October 28, and I have a problem copy and pasting between OS. It worked at first. It seems some MAC update is the problem. . What should I do. When I tried Parallels 6.0 update copy and paste worked a few times, then it stopped again. Please advise.
  9. KrP

    KrP Member

    I have not yet upgraded to the 6th version.

    I have not had this problem for quite some time. In the past when copy and paste failed, a complete reload of parallel tools would work. This may mean you will have to go into the windows control panel and use the software delete to remove parallel tools then restart parallels and follow the prompts to install parallel tools again.

    Let me know what you find out.

    (edited? really?)
    Last edited: Nov 1, 2010
  10. redwolf

    redwolf Bit poster

    I'd lost copypaste with the update and a reload of Parallels Tools sorted it.
  11. Peter Linsener

    Peter Linsener Junior Member

    Same here ...

    It stopped working a few days ago, I thought of a temporary problem, but it persists.
    Differently from others I cant copy paste in either direction, none working anymore.

    I'm on a Mid 2010 Macbook, Mac OS X 10.6.5 (10H574), Parallels 5.0.9344

Share This Page