Copy-Paste Suddenly doesn't Work

Discussion in 'General Questions' started by RCBOOKS, Dec 17, 2007.

  1. bowbot

    bowbot

    Messages:
    12
    i just tried the shadowridgehope solution and no luck
     
  2. rackerby

    rackerby

    Messages:
    11
    This does work, but it certainly isn't recommended.
    _
     
  3. shadowriderhope

    shadowriderhope

    Messages:
    8
    Mine's been spotty today - it seems it's mostly working again, though. Very odd.
     
  4. espostor

    espostor

    Messages:
    2
    Xenos, can you verify that you've installed the 2007-009 update?

    I am using Tiger 10.4.11 and PD 5582 and neither Apple+C or Apple+V work, nor does copy/pasting via right-click. I've attempted the re-install of ParallelsTools and the other recommended workarounds.

    I can also tell you that when I copy some text from Windows, it immediately appears in the "Current clipboard content" box in the Parallels Tools Center. When I copy some text from OSX, the "Current clipboard content" box stays blank. IIRC, when this was working, any text that was on the clipboard would appear in this box, whether it was copied from Windows or from the Mac.

    Also, interestingly, when I copy text from Windows (and it appears as expected in the clipboard content box) and then copy text from the Mac, the clipboard content box goes blank.

    I understand that the Parallels dev folks are somewhat at the mercy of what changes are made in a Apple security update, so I understand an issue like this can't be fixed overnight. That being said, I'm hoping for some additional engagement by the Parallels folks -- maybe in the form of additional messages in this topic that detail the steps Parallels has taken to reproduce the problem. Something -- anything -- to let us know that you've read the details others have provided in this topic and are acting on them.
     
    Last edited: Dec 21, 2007
  5. rackerby

    rackerby

    Messages:
    11
    Security Update 2007-009 v1.1

    Apple has released an update to the 2007-009 Security Update, v 1.1:

    http://docs.info.apple.com/article.html?artnum=307224

    "Security Update 2007-009 v1.1 addresses an issue introduced in Security Update 2007-009 that may cause Safari to unexpectedly quit when browsing to certain websites."

    Alas, it does not appear to fix the PD copy-paste problems introduced with 2007-009.
    _
     
  6. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    Dear all,

    Thank you for the reports. Parallels engineers are investigating the issue. I will be able to give you an answer in three days.

    All of you have Tiger as Host OS and Parallels Desktop build 5582 - am I right? If not, please let me know.

    Best regards,
    Xenos
     
  7. cybertubby

    cybertubby

    Messages:
    27
    I am on 5160 (and i think several others too).

    I think all of us with the problem are on Tiger post-update.
     
  8. GlennG

    GlennG

    Messages:
    25
    Hey, that's dedication; working on Christmas day:)

    10.4.11 + update
    Parallels 5582
     
  9. jkant

    jkant

    Messages:
    1
    +1

    10.4.11 + update
    Parallels 5582
     
  10. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    Thanks for adjusting!

    Merry Christmas! :)

    Best regards,
    Xenos
     
  11. peterlemer

    peterlemer Kilo Poster

    Messages:
    111
    Mac Pro Intel 2.66
    Mac OS 10.4.11
    Parallels 5160
    Installed "Security Update 2007-009 (Universal)" (1.0)

    Can't copy from Mac to XP

    peter
     
  12. gegervision

    gegervision

    Messages:
    185
    Run Apple Update again: Apple has released an update to the 2007-009 Security Update, v 1.1
     
  13. khennes

    khennes

    Messages:
    10
    Still doesn't work after Security Update 2007-009 v1.1
     
  14. GlennG

    GlennG

    Messages:
    25
    Moi aussi:-(

    So that's
    Mac OS 10.4.11 + Security Update 2007-009 v1.1
    Parallels 5582
     
  15. peterlemer

    peterlemer Kilo Poster

    Messages:
    111
    gegervision, you recommend running Apple Update, yet 2 participants have done so and report no improvement.

    Does it work for you?

    peter
     
  16. mweholt

    mweholt

    Messages:
    8
    Getting the Word...

    This is such a huge problem, can we ask that a new thread be started once a genuine solution has been found? I need the fix ASAP and I don't want to have to keep searching various "clipboard" threads to find the fix when it shows up. Or will all Parallels users get an email?

    Thanks.

    (Or maybe the "Thread Subscription: Instant email notification" option below will let me know it has been fixed??)

    =======
    MacBook
    10.4.11
    Windows 2000 Professional
    All security updates.
    =======
     
  17. jowenjowen

    jowenjowen

    Messages:
    1
    Temporary workaround using scripts

    I wrote a couple of scripts to write and read the Mac clipboard to and from a file. This is clearly inferior the permanent fix needed, but it reduces copy and pasting to a few clicks .
    I've included 1 applescript script and 2 windows macros (one better onerequires MS Word).

    AppleScript:
    set clipfile to open for access file "Macintosh HD:Users:Shared:clipfile.txt" with write permission
    set eof of the clipfile to 0
    write (the clipboard as text) to clipfile
    close access the clipfile

    Windows Script file (put this into a a file with an .wsf extension):
    <job id="Job1">
    <script language="VBScript">
    Set objFSO = CreateObject("Scripting.FileSystemObject")
    Set objFile = objFSO.OpenTextFile("\\.PSF\.Mac\Users\Shared\clipfile.txt", 1)
    aaa = objFile.Readall
    objFile.Close
    Set objIE = CreateObject("InternetExplorer.Application")
    objIE.Navigate ("about:blank")
    objIE.Document.parentwindow.clipboardData.SetData "text", aaa
    objIE.Quit
    </script>
    </job>

    When you run this .wsf file, you get a couple of warnings from Internet explorer. I wrote the following word macro that doesn't put up warnings:

    Sub copyClipFileToClipboard()
    Set objFSO = CreateObject("Scripting.FileSystemObject")
    Set objFile = objFSO.OpenTextFile("\\.PSF\.Mac\Users\Shared\clipfile.txt", 1)
    aaa = objFile.Readall
    objFile.Close
    Application.ActiveWindow.Activate
    Selection.TypeParagraph
    Application.ActiveWindow.Selection.Text = aaa
    Application.ActiveWindow.Selection.Copy
    End Sub

    I have attached the word doc with this macro. I zipped it to make sure the macro makes it through.

    I hope this helps.

    James
     

    Attached Files:

  18. Bigdaddyborder

    Bigdaddyborder

    Messages:
    2
    A Solution for those with Update already installed.

    If security update is already installed , download 10.4.11 Combo update ( may get away with the standard update from 10.4.10(but I didn’t try that)) then once down loaded , delete /System/Library/Frameworks/CoreFoundation.framework then install the combo update, DO NOT RESTART TILL THE UPDATE IS INSTALLED. once rebooted all worked for me.
     
  19. jqj@uoregon.edu

    jqj@uoregon.edu

    Messages:
    2
    I'm in the same situation. No mac->xp copy. 10.4.11 with Security Update 2007-009 (Universal) -- 1.0 installed 12-17, and 1.1 installed 12-22. Three questions:

    1/ shadowriderhope reports intermittent ability to paste, which isn't consistent with other reports. Anyone have any followup or theories?

    2/ Xenos reports that everything works fine with 10.5.1. Has anyone who installed the 10.4.1. security update upgraded to 10.5? Can we verify that that performing the 10.5 upgrade fixes the problems?

    3/ If Parallels (Xenos?) gets info from Apple on this, could you post that fact here? Best that the rest of us not hound Apple till you guys do so.
     
  20. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    Hello all,

    Thank you for proposing the workarounds.

    Parallels engineers are investigating the issue which is really of a high priority for us.
    I hope tomorrow I will be able to let you know if the workarounds proposed above could be recommended for everybody and if upgrading to Leopard fixes the bug.

    We are sorry for the inconvenience caused.

    Best regards,
    Xenos
     

Share This Page