Corrupting my Boot Camp with Parallels

Discussion in 'Mac OS X Guest OS Discussion' started by creedda, Dec 4, 2008.

  1. creedda


    Hi. I just switched over to a new macbook pro and thought I would try the trial version of parallels to see if it is for me. I installed windows via apple's bootcamp and then installed parallels 4.0.

    I created a virtual Machine based on my boot camp partition and used it for a bit, but after restarting into bootcamp and installing service pack 3, everytime I used parallels it would corrupt my bootcamp partition.

    The partition is a ntfs partition and I do have ntfs-3g installed, but I dont believe that that is the problem.

    Whats going on here?
  2. Eight_Quarter_Bit


    same here

    I'm also having a corruption issue. Like you I am using my bootcamp partition as my VM and am using ntfs-3g (with macfuse 2.0, as well as the previous stable version in the past). This was not an issue till parallels 4.0. Do you get a message in windows complaining about corrupt files?
  3. Eight_Quarter_Bit


    a lead

    OK, I think what is happening is parallels isn't cleanly un-mounting the bootcamp volume when you have NTFS-3G installed. I noticed that prior to parallels 4.0 the bootcamp volume would disappear when you started the VM, but now it stays.

    I'm going to reformat my bootcamp partition and re-install windows. I'll try manually un-mounting the windows volume prior to launching parallels to see if that fixes the problem. If the problem is solved it should be a simple matter to create a script that unmounts the bootcamp volume and then launches parallels. Not an ideal solution, but I think it should work.
  4. John@Parallels


    Also please remove NTFS-3g, we cannot guarantee that it will work correctly with Parallels Desktop version 4, as we provide our drivers
  5. Eight_Quarter_Bit


    So far un-mounting (ejecting for those not familial with the *nix lingo) the bootcamp volume prior to launching parallels has not turned up any file corruption. I made sure that I am using the latest version of MacFUSE by downloading version 2.0.3 ( ) and then going to System Preferences>MacFUSE>Check for updates.

    I also downloaded the latest version of NTFS-3G ( there was an update just yesterday) and installed it.

    Now whenever I want to parallel-ize my bootcamp I un-mount (eject) the bootcamp volume in finder and then launch parallels.

    If anyone else here isn't satisfied with the official parallels "solution" of un-installing NTFS-3G, I would greatly appreciate some assistance in testing my hypothesis. Basically just eject the bootcamp volume in finder before starting parallels and we'll see if any more file corruption turns up.

    If all that the corruption issue turns out to be is parallels not un-mounting the boot camp volume properly then I can craft a simple applescript that manually un-mounts the bootcamp volume and then launches parallels.

    If you're not keen on risking your bootcamp to the horrors of file corruption then I suggest you follow John's solution and remove NTFS-3G and wait for parallels or NTFS-3G to issue a fix.
  6. John@Parallels


  7. Eight_Quarter_Bit


    Ah yes, I had almost forgotten about that. It is indeed worth pointing out to anyone not familiar with NTFS-3G.

    For anyone not familiar with the lingo in the aforementioned knowledge base article, basically if Windows crashes (or is improperly shutdown) it doesn't leave an "all clear" signal on the hard drive. When Windows doesn't see the "all clear" Windows knows that it crashed and that the disks need to be checked to make sure nothing is wrong.

    In Windows a disk check is merely a suggestion (one you should probably follow), but NTFS-3G makes disk checks mandatory. It is a safety precaution if I understand it correctly, and can be easily addressed by running a check-disk in Windows. Or, if you're the person who likes to throw caution to the wind, I believe you can disable the mandatory disk checks in NTFS-3G.

    Either way, It's not a huge issue to me personally. Others may find that such behavior is too much to live with and then they can decide for themselves. Good to have information one way or the other.

    The only other problem that I can see on a cursory glance through the knowledge base is KB4756 . KB4756 says that "Parallels Desktop SmartSelect won't open Windows files in Mac OS applications" with NTFS-3G installed. This apparently applied to parallels 3.0 (and was supposed to be addressed) and MacFUSE 0.4 . The issue appears to still be present in Parallels 4.0 and MacFUSE 2.0.

    Basically what this means is that if you try to execute "windows_program.exe" on an NTFS volume from Finder nothing will happen. Doing the same thing from a mac volume (even with NTFS-3G/MacFUSE installed) runs the program in Windows.

    Again, if this is a deal-breaker for you, then uninstall NTFS-3G. Personally I don't run that many programs from NTFS volumes, and those that I do I can still execute by browsing to the disk in Windows Explorer rather than in Finder.
  8. Jkirk3279


    I have to wonder if I'm having a similar problem.

    I have used both Boot Camp and Parallels 4.0; Parallels is convenient, but Boot Camp is solid by comparison.

    I need to be able to run a Windows .icm color correction profile that isn't compatible with Mac OS X at work.

    Ideally I'd be able to set up CorelDraw on XP, do my design on the Mac side, and dip into Parallels to run the print job.

    There's one deal-breaker.

    When I use Parallels (I've re-installed four times now) it starts just fine, but over a couple of days it slows down. Eventually it even slows down my Mac, to the nail-biting extreme.

    Did I say nail biting? I should have said knuckle biting ! I literally have calluses on my knuckles.

    I use the FAT formatting, since I read that was more compatible. So I obviously don't need an NTFS driver.

    I was able to correct the slowdown last time, when I tried defragging the windows files. That worked, but only for one day.

    So I suspect there is corruption going on, where somehow having both Parallels 4.0 and Boot Camp is damaging the Boot Camp file structure on shutdowns.

    I have just finished my fourth re-install of XP2 and I hope it will be my last. I'm going to back up the Boot Camp partition and the virtual machine so I can just replace them: all my real files will be on the Mac side.

    BTW, I could have sworn Parallels already had the ability to run off the Boot Camp partition directly: is that still on the wish list?

Share This Page