"Could not apply the stored configuration for monitors"

Discussion in 'Linux Guest OS Discussion' started by JoshuaE, Apr 10, 2012.

  1. JoshuaE

    JoshuaE

    Messages:
    2
    Today I upgraded Parallels to 7.0.15094. I upgraded Parallels Tools on all of my VMs as well.

    Since the upgrade, both of my Linux VMs (Ubuntu 11.10 64-bit and Fedora 15 64-bit) give this message on startup, in an alert box:

    Could not apply the stored configuration for monitors
    none of the selected modes were compatible with the possible modes:
    Trying modes for CRTC 80
    ....


    Also, the VM boots at 1024 x 768 resolution, no matter where it was set on the previous shutdown.

    I've never had an issue with this when upgrading Parallels versions before. Anyone know a fix, or at least is anyone else having the same issue?
     
  2. mudge

    mudge

    Messages:
    3
    Same here on 11.10 and 12.04 beta 2.
     
  3. UlrichM

    UlrichM

    Messages:
    3
    +1 here with 11.10.

    Quite annoying ...
     
  4. mobilehavoc

    mobilehavoc

    Messages:
    13
    I'm having the same exact problem. I tried editing the /etc/X11/xorg.conf file but that doesn't do anything and I compared that file with previous files and they're identical so I think the issue is with the Parallels video driver not any config. What seems to work as a workaround is to start the VM at 1024x768 and then go full screen. If you try starting in a non 1024x768 resolution apart form the pop-up you get other weirdness and slowdown.
     
  5. mercy

    mercy Parallels Developers

    Messages:
    15
    Hello everyone

    The problem "Could not apply the stored configuration for monitors none of the selected modes were compatible with the possible modes: Trying modes for CRTC 80 ...." is a known issue for some desktop environments.
    Workaround is described here: http://ubuntuforums.org/showthread.php?t=1917220 : remove ~/.config/monitors.xml and then log out, log in again to the desktop.
     
  6. mudge

    mudge

    Messages:
    3
    Deleted ~/.config/monitors.xml and restarted. The "could not apply the stored configuration for monitors" message box no longer occurs on X11 startup, but the underlying cause of the problem is still there, and for me started with the latest update to Parallels / Parallels tools.

    Using "Displays" to select a resolution of 1280x1024 and clicking "Apply" doesn't change the resolution and results in a message box:


    "The selected configuration for displays could not be applied

    required virtual size does not fit available size: requested=(1280, 1024), minimum=(640, 400), maximum=(1024, 768)"


    If you resize the "screen" by resizing the Parallels window then the resolution does indeed change. It's only temporary, logging out and back in again causes the resolution to revert back to 1024x768.

    This is under Parallels 7.0.15094, Ubuntu 11.10 with latest Parallels tools, MacPro with dual 1920x1200 monitors.
     
  7. uselpa

    uselpa

    Messages:
    1
    Same here on Ubuntu 11.10, Macbook Air. Max resolution = 1024x768, desired resolution 1440x900. Parallels tools have been updated.
    It worked fine until the last Parallels upgrade.
     
  8. JoshuaE

    JoshuaE

    Messages:
    2
    Solution

    I was able to fix this problem on Ubuntu by editing the video resolutions I wanted back into /etc/X11/xorg.conf .
    Don't know why the latest Parallels update wiped all the usual default choices out of this file...

    Fedora is still screwed though; it seems to have other video-related issues...
     
  9. mercy

    mercy Parallels Developers

    Messages:
    15
    Hello all
    Thank you for your reviews

    mudge, uselpa,
    Could you please say, what is your Mac OS X screen resolution?
    Also check, please, what's the amount of video memory for your Linux VM? To find that out open Configure for your VM >> Hardware >> Video.


    Thank you for help
     
  10. Mystic

    Mystic

    Messages:
    3
    A "me too", with details

    I've experienced the same thing after installing Parallel Tools on my brand new Ubuntu 12.04 VM. Prior to installing Parallel Tools I was running the VM at 1440x900 resolution without any difficulties.

    My Macbook Pro is running Lion 10.7.4, and its native resolution is 1680x1050. I have the VM video memory set to 64MB with no 3D acceleration, but I get the same messages with the same 1024x768 maximum limit when I have it set to 128MB. Note that I had to disable 3D after installing Parallel Tools because, for some reason, the Ubuntu UI (menu bar, launcher) wouldn't display anymore as soon as I installed Parallel Tools unless I disabled 3D. (I've tried this on two different freshly created Ubuntu VMs in the last day, and the same thing happened both times, both with respect to the UI problems with 3D enabled and the limited maximum resolution, both occurring immediately after I install Parallel Tools.)
     
  11. mercy

    mercy Parallels Developers

    Messages:
    15
    Mystic, thank you for reply
    We could reproduce the bug thanks to you. And we started to fix it

    We can offer a workaround for you:
    - Open /etc/X11/xorg.conf
    - Find string with startup resolution modes, it looks like
    Modes "1024x768" "800x600" "640x480"
    - Add your work resolution into this string, now it must be like this
    Modes "1440x900" "1024x768" "800x600" "640x480"
    - Reboot
     
  12. Ken R

    Ken R

    Messages:
    2
    Ubuntu 12.04 screen Res

    The fix described above didn't work for me. It seems that only 1024 x768 and 640 x 480 are supported in the Parallels Tools video driver with Ubuntu 12.04. This is a fresh Ubuntu install with the latest patches applied. Parallels tools installs without error, and re-installs without error using the upgrade option. Turning 3D off makes no difference. The error message is:

    Required virtual size does not fit available size:requested (1344 x 1066), minimum = (640 x 480), maximum = (1024 x 768)
     
  13. mercy

    mercy Parallels Developers

    Messages:
    15
    Ken R, thank you for reply

    You're using non-standard screen resolution for your VM (1344x1066).
    Please, select some of the following resolutions (they are standard): 640x400 ; 640x480 ; 720x480 ; 800x500 ; 800x600 ; 1024x640 ; 1024x768 ; 1152x720 ; 1280x800 ; 1280x960 ; 1280x1024 ; 1440x900 ; 1400x1050 ; 1600x1200 ; 1680x1050 ; 1920x1200 ; 2048x1536 ; 2560x1600

    Configure xorg.conf with one of selected resolutions:
    1) Open /etc/X11/xorg.conf
    2) Find string with startup resolution modes, it looks like:
    # Parallels Screen section
    Section "Screen"
    Identifier "Parallels Screen"
    Device "Parallels Video"
    Monitor "Parallels Monitor"
    Option "NoMTRR"
    SubSection "Display"
    Depth 24
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection
    3) Add your custom resolution into this string, now it should be like this:
    Modes "1440x900" "1024x768" "800x600" "640x480"
    4) Reboot
     
  14. Ken R

    Ken R

    Messages:
    2
    Picking one of your "standard" resolutions worked. The one I picked (1344 x 1066) was from the list that Ubuntu 12.04 offers. It seems that for some reason it can't discover what screen resolutions are actually available.
     
  15. Same problem with 12.4. Editing /home/user/.config/monitors.xml and /etc/X11/xorg.conf as described, adding your desired resolutions, seems to fix the issues.
    Ubuntu 12.04 LTS
    993.9 MiB
    Processor Intel Core i5 CPU 750 @ 2.67GHz
    Graphics VESA: Parallels Video Adaptor
    OS Type 64-bit
    Disk 65.7 GB
     

Share This Page