critical error caused by smartguard

Discussion in 'General Questions' started by CarolaH, Jun 15, 2022.

  1. CarolaH

    CarolaH Bit Poster

    Messages:
    8
    hi there,

    first my system info: i'm runnung windows 10 pro with all current patches within parallels desktop pro edition 17.1.4 on an intel macbook pro 15" mid 2014 with macos big sur 11.6.6

    since upgrading parallels desktop from flawless v16 to v17 a recurring problem with smartguard emerged: while smartguard is erasing an older snapshot before doing the new one, a critical error happens.

    the story goes like this:
    some weeks ago i upgraded parallels desktop from v16 to v17, and after that i also resized the disk size of the virtual disk of my windows 10 vm. it all worked fine - it seemed.
    after some consecutive days of fine working with the windows vm i suddenly got an error message while being logged in my running windows vm and just normally working with it:
    it's the error "A critical error has occurred while reading/ writing to Hard Disk 0" documented in https://kb.parallels.com/120940

    the first time i thought of some weird system "hickup", ignored it, rebooted the vm, did a manual snapshot and didn't think about it any more as the vm was working fine again afterwards.

    but some days later it happened again and persists to happen every some days, and i realized
    this _only_ happens while smartguard is trying to erase an older smartguard snapshot before creating the current smartguard snapshot; please see screenshot:
    screenshot_1750.png

    but not always: sometimes smartguard is working fine erasing an older snapshot and creating a new one, and sometimes the error happens.

    so I tried the troubleshooting guide from the KB, but it didn't help:
    - macos first aid via the disk utility in recovery mode showed no problems.
    - no problem detected in the dmesg log.
    - trying to restore virtual machine file permissions didn't work as the command "chmod -RN ..." ended up with an error message stating something about an ACL issue.
    - S.M.A.R.T. status in macos disk utility is not available any more.

    i don't think the problem has anything to do with the resizing of the vm's disk size.
    somehow i have the "feeling" that it has something to do with permissions, because:

    we have two intel macbook pros running with identical macos version big sur 11.6.6 and now both parallels desktop v. 17.1.4
    BUT
    after upgrading macbook pro 1 (intel macbook pro 13" mid 2014) from parallels v16 to v17 macos always (for every subsequent upate as well) wants granting permission(s) for parallels via "system settings"/"security & privacy"/"general" > "allow", then you even have to reboot macos, and then parallels works fine without any critical error issues concerning smartguard.
    while after upgrading macbook pro 2 (intel macbook pro 15" mid 2014; the one having the smartguard issue) no granting permission(s) for parallels was claimed. same for the most current may update of parallels v17.

    so i tried to uninstall parallels desktop (moving app to trash, then empty trash) and reinstall it to force the granting permission claim, but it didn't pop up.
    so i uninstalled again incl. deleting parallels files from
    ~/Library/Application Support/
    ~/Library/Caches/
    ~/Library/Cookies/
    ~/Library/Preferences/
    ~/Library/Saved Application State/
    then emptied the trash, even rebooted macos and installed again, but somehow parallels still hides some settings somewhere as again no granting permission claim came up, and the account and license informations of the subscription were in there already as well.

    sooo, does anybody have any idea how we might get rid of the problem, because it is utterly annoying.

    thanks a lot :)
    carola
     
  2. CarolaH

    CarolaH Bit Poster

    Messages:
    8
    nobody any idea - a parallels staff member maybe?
     
  3. CarolaH

    CarolaH Bit Poster

    Messages:
    8
    it just happened again still nobody any idea?
     

Share This Page