Critical Graphics error with Windows Suspend/Application crash in Parallels Desktop 18.1.0

Discussion in 'Windows Virtual Machine' started by TV4Fun, Nov 22, 2022.

  1. TV4Fun

    TV4Fun Bit poster

    I have found multiple threads describing this issue. Some claiming it has been fixed in the latest version of parallels and others with responses saying it has very much not been fixed and is still an issue and no further responses from Parallels after that. It has not been fixed. It is still an issue for me running the latest version, Parallels Desktop 18.1.0 (53311) on an M1 Macbook Pro running macOS Ventura Version 13.0.1 (22A400) with a Windows 11 Pro 22H2 guest. For me it seems to happen at certain spots in certain UE4 games. Right now, it is happening very consistently in a particular cutscene near the end of The Artful Escape, which means I cannot progress past that point. I have sent multiple crash reports to Parallels support on this, the most recent being #412572568. In brief this is what happens:
    1. I am playing a UE4 game.
    2. I briefly see some graphical glitching, and then Windows starts to suspend.
    3. I get an error message from Parallels that it has encountered a critical graphics error and offers to send a crash report to Parallels Tech Support
    4. Concurrently with 3, Windows immediately comes back from suspension and I see an error message from the game that it has lost the graphics device and will close.
    5. The game does not actually close, but just shows me a black screen. If I force close it through the task manager (just asking it to close does not work), and re-open it, I still get a black screen.
    6. I have to reboot the guest before I get any 3D graphics back.
    Is there anything like a fix to this anywhere on the horizon?
    KeenB and mark55 like this.
  2. mark55

    mark55 Bit poster

    Same issue here. The only difference is that I can start games again without a restart. Parallels still suspends or crashes completely (Windows 11 window vanishes from MacOS). Happens during games, not when starting games up. Sometimes with (audio)visual glitching just before suspending, sometimes without.

    M1 Max and Parallels 18.1.0.
  3. KeenB

    KeenB Bit poster

    Running on M1 Max and Parallels 18.1.0.

    Exact same playing out of issue as described by TV4FUN. Playing Atomic Heart and at start of chapter cut scene it happens. Also stuck and cannot progress in game because of it. Verrrry frustrating especially when the game is good!!
  4. KeenB

    KeenB Bit poster

    Adding to my text, tried installing Parallels 17 and game still crashed with Critical Graphics Error at the same place. Please please please fix this! Thank you!
  5. KeenB

    KeenB Bit poster

    Has been fixed by dedicating more memory to the virtual machine. Through testing, graphics error and subsequent game crash was triggered either by 80% and above CPU or GPU within the virtual machine

Share This Page