CTRL and ALT keydown events do not get passed to Guest

Discussion in 'Parallels Workstation Extreme Discussion' started by RobSzabo, Feb 6, 2012.

  1. RobSzabo

    RobSzabo

    Messages:
    2
    Dear Forum Members/Parallels Experts

    We are evaluating Parallels Workstation Extreme for Linux to be a single machine solution for our artists who need both Linux and Windows machines.

    I have come across a problem which makes Photoshop CS5 and ZBrush unusable on a guest Widows 7 virtual machine and is therefore quite a show-stopper.
    These programs have secondary functions for when users press and hold either the CTRL or the ALT keys. The issue is that Parallels Workstation doesn't pass the keydown event for CTRL or ALT to the Windows when key is pressed, but only generates (retrospectively) the keydown event right before a keyup event, just after the key is released.
    On other words, if I press and hold the CTRL or ALT keys, the keydown event doesn't get passed to Windows.
    Only after I have released the key, does a keydown and a few msecs later a keyup event get generated.

    I've browsed through the forum and knowledge base articles for suggestions but the Linux build (13950) of Parallels Workstation Extreme doesn't seem to have the 'Optimize keyboard for games' option which other threads suggest to be enabled and claim to fix the problem. I've also tried having the devices.kbd.delay=2000 option in the bootflags field without any success.

    The hardware is a DellT5500 with 24Gig of RAM, Centos5 host OS and isolated NVidia Quadro4000.
    The virtual machine is Windows 7 with dedicated NVidia Quadro2000 card and 16Gig RAM allocated.

    Would anyone know how to enable this feature in the Linux build? I've tried to hack the Generic.kbd file but the setting gets reset to 0 when the Parallels Workstation starts.

    Any suggestions are welcome!

    Thanks!
    Robert
    MPC
     
  2. RobSzabo

    RobSzabo

    Messages:
    2
    In the meantime I've found that if I change the OptimizeModifiers in config.pvs to 1 then it starts working fine. Is there an option in the GUI to change that?

    Robert
     
  3. Artyom

    Artyom Bit Poster

    Messages:
    1
    I've faced the same problem with Parallels 13. It still hasn't been fixed. Thank you Robert for workaround! Your solution helped me.
     
  4. zıəs uɐɟəʇs

    zıəs uɐɟəʇs Bit Poster

    Messages:
    1
    Thank you so much. This was driving me nuts and your Workaround even works on Parallels for Mac (Open Package Contents [of the VM] and then edit the config.pvs file).
     

Share This Page