Debian 10.1 cannot boot into X11, cannot install Parallels Tools.

Discussion in 'Linux Guest OS Discussion' started by pDavid, Sep 8, 2019.

  1. pDavid

    pDavid Bit Poster

    Messages:
    19
    Guest OS is Debian 10.1. This VM has been working reasonably well for several years now. Today I ran into a series of problems.
    1. Log in hung while activating video. Repeatedly.
    2. Re-installing Parallels Tools from command line crashes and hangs the VM.

    About all I can do now is boot the VM into command line (level 3).

    I just submitted technical report ID 321598867 .
     
  2. Alexander Haltman

    Alexander Haltman Parallels Developers

    Messages:
    108
    Could you please create problem report once more and manually attach to problem report log files from guest OS:
    /var/log/parallels*
    journalctl -n 1000 --no-pager > ./guest.log

    This is needed due to our problem report system can collect this logs only if Parallels Tools properly installed in guest OS.

    ps: To copy log from guest to host you could use this commands, for example:
    journalctl -n 1000 --no-pager > ./guest.log
    scp ./guest.log <your user name>@10.211.55.2:./
    scp /var/log/parallels* <your user name>@10.211.55.2:./
     
  3. pDavid

    pDavid Bit Poster

    Messages:
    19
    Hello Alexander,
    I attached the files that you asked for.
    D.A.
     

    Attached Files:

    • par.zip
      File size:
      817.1 KB
      Views:
      1
  4. Alexander Haltman

    Alexander Haltman Parallels Developers

    Messages:
    108
    It is looks like Parallels Tools was not installed properly. Your parallels-tools-install.log finished with:
    2: /lib/modules/4.19.0-6-686-pae/build
    3: /usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_drm
    Start checking drm core on kernel /lib/modules/4.19.0-6-686-pae/build...​

    But this means that only kernel space drivers was installed but user space and ddx drivers not installed.
    Success Parallels Tools installation will be indicated by such content of parallels-tools-install.log at the bottom:
    Perform initramfs update.
    '/home/alexkod/cdrom0/installer/parallels_tools.initramfs-hook' -> '/usr/share/initramfs-tools/hooks/parallels_tools'
    update-initramfs: Generating /boot/initrd.img-4.19.0-6-686-pae
    Send installed Parallels Tools version to dispatcher.
    >>> Postinstall
    Writing OS version and Xorg version
    Enabling PRL_GL
    Starting prltoolsd service:
    Parallels Guest Tools were installed successfully!
    Please, reboot your OS to finish installation of Parallels Guest Tools.
    You need to reinstall Parallels Tools:
    1) Uninstall Parallels Tools first:
    Connect Parallels Tools image "/Applications/Parallels Desktop.app/Contents//Resources/Tools/prl-tools-lin.iso" to VM.
    Mount it inside VM if not automatically mounted.
    Run /media/cdrom0/install -r
    Reboot VM.

    2) Install Parallels Tools as usually.
     
    salvomic likes this.
  5. pDavid

    pDavid Bit Poster

    Messages:
    19
    Thanks Alexander, that worked. Now I just need a way to remember that install -r performs uninstallation.
     
  6. Alexander Haltman

    Alexander Haltman Parallels Developers

    Messages:
    108
    Parallels Tools installer automatically uninstall previous version of tools and then do installation of newer version.
    In 99% cases it is works without any help.
     
    salvomic likes this.
  7. salvomic

    salvomic Bit Poster

    Messages:
    95
    thank you, but, please, help: I upgraded to 10.1, reinstalled Parallels Tools, but now I cannot access Coherence. How to do?
    Salvo
     

Share This Page