Debian Buster based - Raspbian (Raspberry Pi Desktop for PC and Mac) - with poll

Discussion in 'Linux Guest OS Discussion' started by AndrewB29, Nov 9, 2019.

?

Should Buster be supported in the current version (v15) of Parallels - 9 day poll (two Sundays)

Poll closed Nov 18, 2019.
  1. Yes in its native ISO 'Stable' image only

    0 vote(s)
    0.0%
  2. Yes in its native ISO 'Stable' image and support the Raspbian Desktop version as well

    0 vote(s)
    0.0%
  3. Yes in its native ISO 'Stable' image + official 'blends' only

    0 vote(s)
    0.0%
  4. Yes in its native ISO 'Stable' image + blends + Raspbian Desktop version as well

    100.0%
  5. No stick with the current Stretch support only

    0 vote(s)
    0.0%
  6. No drop Debian support

    0 vote(s)
    0.0%
  7. No drop Linux support from all version of Parallels

    0 vote(s)
    0.0%
  8. No just drop Linux support from the home version of Parallels

    0 vote(s)
    0.0%
  1. AndrewB29

    AndrewB29 Bit Poster

    Messages:
    1
    I've been trying to get the Parallel Tools installed on Debian Buster released by the Raspberry Pi foundation but constantly failing with file or object not found.

    The Stretch version of the install worked first time so I am not sure if its a Buster or Desktop vs Tools issue :confused:

    All missing object are present on the ISO and have rights for execute and read for root or local user - ownership is root:root
    Shell is the Raspbian Bash shell
    Tried using sudo
    Set password for root and tried su
    I've tried copying the files locally (both under PI home, root home and /tmp)
    Tried running the x86_64 installed directly.
    Tried mounting the actual iso file from the Mac container rather than the ISO mounted by the prompt to install the tools

    All of the above (and combinations) failed with one or more object not found errors using sudo, su or sh to start the jobs
    Running the initial script under su did start but failed to run the x86_64 installer
    Running the script as user Pi did report I was not root

    Until the latest version of Raspbian (https://www.raspberrypi.org/downloads/raspberry-pi-desktop/ 2019-09-30) and Parallels (15.1.1 47117) I was not even able to get to a boot screen so compatibility is getting better:). Limited testing (i.e. 10 mins playing around) showed up some ACPI errors in the dmesg output but that was all.

    Note the Arm version of Debian has been an odd 64/32bit mix between the kernel and userland but I am not sure how this applies to the x86 builds (and cannot find a release not for this build).

    It would be great to have proper support for Raspbian as it is used in the education and home maker spaces a great deal and this version allows some development on a PC so core HATs and Foundation specific software.

    If Im well enough next week I'll try a clean Debian build with the Pi desktop and other software to see if that has more success
    Please note - I do not use the Pi Forums due to poor and inconsistent moderation so cannot post on there (and not this is really a Parallels tools / Buster issue)
     
    FloydM1 likes this.
  2. tvBilly

    tvBilly Bit Poster

    Messages:
    1
    I can't get the tools installed either. As root, with exec enabled in a remount. Same problem. I can install via the install-cli.sh file in the installer folder, but then I can never get back to the gui (even with raspi-config tool).
     
  3. Alexander Haltman

    Alexander Haltman Parallels Developers

    Messages:
    116
    Problem with Parallels Tools installation due to RPD use 64bit kernel and 32bit userspace.
    Some workaround:
    1. Install RPD, connect Parallels Tools installation CD to guest and open terminal
    cd /media/cdrom0
    sudo su​
    2. Install Parallels Tools manually in command line:
    uname() { [ $1 == "-m" ] && echo x86 || /bin/uname $@ ; }
    export -f uname
    ./install -i​
    3. Edit /etc/default/grub - add "prl_vid.usedrm=0" to GRUB_CMDLINE_LINUX_DEFAULT and then:
    update-grub
    reboot​
     
    FloydM1 likes this.

Share This Page