Dialux Evo doesn't run on Parallels and Mac ARM

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by JuanV6, Sep 1, 2021.

Tags:
  1. JuanV6

    JuanV6 Bit poster

    Messages:
    1
    Hello,
    I'm a new Parallels desktop user and this is my very first time here.
    I don't know if this issue has already been treated but I wonder if other people are also concerned about it.
    This is the message I received from Dialux when I asked them if their software was compatible with Parallels on Mac M1:

    "We can't really do anything regarding this problem. The problem is not our DIALux evo software. Parallels needs to improve its CPU support for the M1 (Mac). DIALux evo runs normally under Windows. It did by the way in the past under Parallels with x64 CPU's.
    DIALux does not access the x64 processor architecture differently than usual. The mapping from x64 to M1 in Parallels is up to the vendor. I guess you'll have to wait for an update".

    I asked the Parallels staff via chat, but I didn't have any answer or explanation.

    Does anybody know anything about it?

    Thank you.

     
  2. Yekrallum

    Yekrallum Bit poster

    Messages:
    1
    Hi,

    I can confirm that Parallels does now work on M1. However, as of today, the latest version 10.1 does not work but version 10.0 and earlier versions work fine.

    Hope this helps
     
  3. ArturK4

    ArturK4 Bit poster

    Messages:
    1
    In Parallels 18, nothing has changed with regard to Dialux 10.1. Dialux 11 is coming out in the near future, but at the moment I'm without hope. So if Dialux 10.0 works, what is this all about?
     
  4. Dmitry@Parallels

    Dmitry@Parallels Parallels Team

    Messages:
    705
    Hello, Dialux 10.1 fails with an error that is not related to virtualization, so I recommend contacting Dialux support and reporting this error to them, especially considering that version 10 worked. You can also note that Parallels is happy to work together towards the resolution if the error is somehow related to Windows emulation.

    The error from Windows Event Viewer:
     
  5. RachelL1

    RachelL1 Member

    Messages:
    34
    Hi, I just wonder if there is any progress? I'm also on Parallels 18 with Mac Book Pro M1 and wanted to use Dialux 11 but it is not working, if someone has a solution this would be great !!!
     
  6. EdyG

    EdyG Bit poster

    Messages:
    1
    hy, can you tell me if when Dialux 11 will be compatible on parallel?
    because I just use dialux and having 2 PCs just for one application is boring...

    Thk.
     
  7. RachelL1

    RachelL1 Member

    Messages:
    34
    Hi, as per above Information from Yekrallum (thank you very much) Dialux 10.0 is working on M1, all later versions don't work and Dialux is not supporting the software running on parallels what is really st.... if you want avoid to run two Pcs I can recommend to install Dialux 10.0
    I have asked them to send me the link for download see here.
    DIALux evo 10.0 Patch 1: https://b2b.dial.de/index.php/s/fII5iKlIRzpgYCs
    this is working fine.
    I hope that Parallels and Dialux will find a way so that this will work again, we would really appreciate it!
    Kind Regards, Rachel
     

Share This Page