Disable right click via CTRL+click in Parallels Desktop 13?

Discussion in 'Installation and Configuration' started by ChristianT2, Oct 25, 2017.

  1. ChristianT2

    ChristianT2 Bit Poster

    Messages:
    2
    I often select multiple files in my Linux VMs by clicking on them while holding down CTRL. Similarly, I often open links in new tabs in Firefox by holding down CTRL while clicking on them. I am sure there are many more scenarios in which a user is required to hold down CTRL while clicking in order to do something.

    Unfortunately, I couldn't find a way to prevent Parallels Desktop from treating CTRL+click as a right click in a VM. I was able to disable the other macOS system shortcuts (like CTRL+arrow keys for Mission Control, etc.) by setting "send macOS system shortcuts" to "Always".
    So, is there a way to prevent Parallels Desktop from treating CTRL+click as a right click within a VM?

    Please note that I'm not looking for some dirty hacks like disabling my CTRL key or remapping it via some third party tools on macOS. I never had this problem with other virtualization solutions like VMware Fusion and even VirtualBox - therefore I obviously expect Parallels Desktop to also not have any problems with it.

    Summary (File Browser - Multiple Selection Scenario):
    • What happens:
    1. Open file browser on Linux VM (e.g. Nautilus in Ubuntu)
    2. Select file or folder so it gets highlighted
    3. Hold down CTRL while clicking on another file or folder
    4. A context menu appears because CTRL+click is treated as a right click
    • What should happen: After 3.: The other file also gets selected and therefore highlighted (no context menu appears because the user's action is NOT a right click!)
     
  2. TonyC2

    TonyC2 Bit Poster

    Messages:
    11
    you have to go into parallels preferences (not in the vm configuration). select shortcuts and open the mouse shortcuts item.

    there you'll see a "Secondary Click" option. uncheck it and PD will just pass control+click along as a regular control+click instead of a right-click.

    note: this affects all your PD VMs... there's no way i know of to do it on a per-VM basis.
     

    Attached Files:

  3. ChristianT2

    ChristianT2 Bit Poster

    Messages:
    2
    Thank you for your help. Unfortunately, this solution doesn't work for me - neither in Linux nor in Windows.
    Does it work for you? Are you already on High Sierra? Using PD 13?
     
  4. TorstenB4

    TorstenB4

    Messages:
    1
    Also not working here - annoying bug??

    System: macbook pro 2016, High Sierra, Parallels Desktop 13 latest update, Windows 10
     
  5. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,140
    Hi @TorstenB4, have you tried with Shift or Functions + Ctrl + click? If the issue persists, please make a report about the problem and send it to Parallels.
    Go to Menu->Help->Send Technical Data and if it possible, write the report number here.
     
  6. TanD

    TanD Bit Poster

    Messages:
    1
    I was experiencing this same problem, and I finally tracked it down to BetterTouchTool and Karabiner-Elements. Disabling these 3rd party utilities enabled me to use Ctrl-Click in the guest OS. I'm not planning to quit using Parallels or BTT so it would be nice to figure out a work-around that allowed both to play well together.
     
  7. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,140
    Hi @TanD, thanks for the workaround to enable right click via CTRL+click in Parallels Desktop 13 for Mac. It's very much helpful for us to report this to our engineering team!
     
  8. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,140
    Hi, have you installed BetterTouchTool and Karabiner-Elements applications in the Windows virtual machine environment? You may take a snapshot and then try uninstall those applications to check if you are able to enable right click via CTRL+click in Parallels Desktop 13?
     
  9. GeorgeW6

    GeorgeW6

    Messages:
    1
    This discovery was really helpful to me. I would add that you have an option to disable BTT for a specific application. You add Parallels as an application to the BTT app list and then there is a drop down with options including disable BTT. Once I did that, the Parallels right click now works. HTH.

    *edit* The above fix (disabling in BTT) is not working reliably for me. I have added the Parallels Win 10 dock helper and also the specific app involved in hopes it works better but not yet sure. May not be as useful a workaround as I had hoped.
     
    Last edited: Aug 20, 2018
  10. D.G

    D.G Bit Poster

    Messages:
    1
    Thank you for your insights. A slight change in BTT's configuration - different from the one which George described - solved the problem for me:
    BTT > Advanced Settings > General > General Stuff > Disable Better Touch Tool while holding: [x] ^ (ctrl)
     
  11. Ajith@Parallels

    Ajith@Parallels Parallels Support

    Messages:
    1,837
    We are happy to hear that the issue is resolved. Let us know if you have any questions.
     

Share This Page