Disable time sync

Discussion in 'Parallels Provider for Vagrant' started by Pulkit, Sep 3, 2014.

  1. Pulkit

    Pulkit

    Messages:
    1
    Hi,

    Is there a way to disable the time syncing with the host.

    My host is set to Europe/London timezone, however the vm needs to be set to UTC timezone. The issue i am having is that parallels sets the time on the vm to match the host time with is actually 1 hr ahead of UTC.

    Any way of stopping the time syncing and using something like ntpd on the vm to manage time instead?
    Is parallels not detecting the different timezones on the host and vm properly?
    Is there something I can set on the vm to avoid this?
     
  2. Mikhail Zholobov

    Mikhail Zholobov Parallels Developers

    Messages:
    49
    As I've already answered on GitHub, Time Sync can only be disabled via GUI.
    This feature does not allows to use different timezones on the host and guest machines (in Linux guest, at least).
    Being enabled, "Time Sync" will forcibly set the guest's time exactly the same as the host's time, including the timezone.

    In your case you should do the following:
    1) Shutdown your VM and then disable Time Syncing manually in the VM configuration: "Configure -> Options -> Advanced". Set "Time" to "Do not sync".
    2) Boot your VM and customize it's timezone, like so (input commands to the guest's console):
    3) Install and configure ntpd, which will be taking care about time correctness in your guest VM.

    P.s. Seems like this topic is not related to Vagrant Parallels provider directly, so that It would be better to move it to the "Generic Questions" forum
     
    Last edited: Sep 4, 2014
  3. Mikhail Zholobov

    Mikhail Zholobov Parallels Developers

    Messages:
    49
    It has been implemented in Parallels Desktop 10.1.2:
    Code:
    prlctl set <vm_uuid> --time-sync <on|off>
    So, you can use it with Vagrant:
    Code:
    config.vm.provider "parallels" do |v|
      v.customize ["set", :id, "--time-sync", "off"]
    end
    
    P.s. Be careful - it will cause a failure with all previous versions of Parallels Desktop (< 10.1.2).
    You can update PD by clicking on the top menu "Parallels Desktop -> Check for Updates...", either download and install the latest build by this link: http://www.parallels.com/directdownload/pd10/
     

Share This Page