"Do not back up virtual machine" checkbox checks itself

Discussion in 'General Questions' started by pDavid, Oct 14, 2013.

  1. pDavid

    pDavid Bit Poster

    Messages:
    21
    I have the latest Parallels desktop and OSX versions installed.

    My issue occurs in guest operating systems "Windows 7" and "Debian Linux."

    The virtual machine configuration page "Security" includes a checkbox "Do not back up virtual machine". I CLEAR this checkbox. However, after virtual machine is shut down and restarted, the checkbox becomes SET.

    I would like to keep the checkbox CLEARED so that my virtual machines ARE backed up by Time Machine.

    Any suggestions?
     
  2. RobertGeo

    RobertGeo

    Messages:
    2
    Ok, try this:

    Step #1. Uninstall Parallels Desktop using Terminal

    1. If you are unable to uninstall Parallels Desktop by dragging it to Trash you may use these commands:
    Launch Terminal application from Applications/Utilities
    Paste the commands into Terminal (one by one; hit return after pasting each command):
    sudo su

    (type your Mac user password (your Mac user should have Administrator's privileges) and hit return. You will not see characters while typing)

    for pid in $(ps aux | grep "Parallels Desktop.app" | awk '{print $2}'); do echo kill -KILL $pid; done

    for kext in $(kextstat | grep parallels | awk '{print $6}'); do kextunload $kext; done

    rm /System/Library/Extensions/prl*

    rm -rf "Parallels Desktop.app"

    Step #2. Run Repair Disk permission to ensure that Mac grants enough permission to Parallels Desktop to access resources needed for its full funtionality.
    Open Application Folder
    Run Disk Utility
    Click Mac HD and click on Run Repair Disk Permission
    Restart Mac

    Step #3. Install Parallels Desktop
     
    Last edited: Oct 16, 2013
  3. RobertGeo

    RobertGeo

    Messages:
    2
    Actually, I have also been told to try this, it seems simpler than the above, so I would try this first:

    Do not backup with Time Machine option does not work: http://kb.parallels.com/en/112152
     

Share This Page