Double Cursor in Windows Mode

Discussion in 'Parallels Desktop for Mac' started by PeterO, Jun 13, 2007.

  1. PeterO

    PeterO Bit Poster

    Messages:
    16
    Hi - I'm evaluating the 4124/4128 upgrade and am experiencing mouse synchronization problems on a MacBook Pro CD2. Even though the mouse synchronization box is checked when I start in XP in windows mode, the mouse is trapped in the window and I need to press keys to release it. If I uncheck and recheck the mouse synchronization box, I can then move seemlessly between Windows and OS X, but when in the XP window I have get the OS X cursor superimposed on the Windows XP cursor (the cursors aren't quite synchronized so its annoying). I've tried uninstalling and reinstalling Tools (twice) and reinstalling Parallels (upgraded from 4124 to 4128) and am still having the problem. The problem didn't occur on the same hardware prior to the upgrade.
    Any suggestions would be appreciated...
    Cheers,
    Peter O.
     
  2. Rachel Faith

    Rachel Faith

    Messages:
    234
    This is the 13th post on this subject in the last 2 weeks. It seems we get 1 every day.

    Parallels will suggest you reinstall parallels on the mac, then remove and reinstall the tools.

    Most likely this will not work. It has not for anyone else yet.

    Parallels has NOT RESPONDED TO ANYONE with a legit answer.

    Sorry to say, yer screwed like the rest of us...

    But please post SOME INFO about your system, and perhaps we can at least see what comonalities we have.

    So far NADA on are different systems.

    Mine is a Transported system that has worked FINE on all upgrades until the BETA 3.0 and SINCE.
     
  3. sergek9

    sergek9

    Messages:
    2
    For what its worth:

    I ran into the same problem while beta testing. During the subsequent beta releases, the Paralles team instructed anyone who was upgrading from a previous version to do the following:

    1. Install Parallels as normal, but don't start the VM.
    2. While holding down the commnd key, click on the parallels icon to open the VM (which
    opens the VM, but does not launch the guest os).
    3. Make sure all previous Snapshots are deleted (-Actions -Run Snatshot Manager).
    4. Under Actions click on Prepare Parallel Tools For Upgrade.
    5. Start the VM and tools should start up automatically.

    Since then I haven't had this issue and I have been following the same procedure for every beta release afterward. This is also the same way I installed 3.0 form the last beta build, but I didn't see these instruction included in the release notes for 3.0.

    Once the tools are installed, however, the Prepare Parallels Tools For Upgrade (step 4) dissapears. You might try re-running the dmg file and see if the option becomes available again, though I'm not sure if you will lose any data.

    Don't know if this helps or not.
     
  4. brkirch

    brkirch Kilo Poster

    Messages:
    415
    In Windows try going to Control Panel>Display, select the Settings tab, press the Advanced button, select the Troubleshoot tab, and set Hardware Acceleration to full. If it is already set to full, try turning off hardware acceleration and then setting it back to full to see if it has any effect.
     
  5. Rachel Faith

    Rachel Faith

    Messages:
    234
    Tools did NOT start up automatically. Maybe I missed a step. I have 7 VMs listed and I have to use the SELECT option to choose. None of them star unless I tell them to start. I held the CMD button while selecting... which, even if I had not held it, it would not have auto started. But I did choose the "Prepare Tools"... but nothing happened. It booted as normal and lost mouse cursor upon boot.
     
  6. Rachel Faith

    Rachel Faith

    Messages:
    234

    No change. Either setting. Sorry.
     
  7. brkirch

    brkirch Kilo Poster

    Messages:
    415
    It sounds like Parallels video driver either isn't installed or is out of date. Go to Control Panel>System, select the Hardware tab, press the Device Manager button, and press the + button next to Display adapters. If it says "Video Controller (VGA Compatible)" then Parallels Tools probably simply needs to be uninstalled and reinstalled because part of its installation is missing. If it says anything other than that, right click on it and select uninstall. After it has finished uninstalling, uninstall Parallels Tools and reinstall Parallels Tools. And it is important that hardware acceleration be set to full, so if you left it turned off set it back to full. If the double cursor is still showing, try changing your directx support setting.
     
  8. Rachel Faith

    Rachel Faith

    Messages:
    234
    I did leave it on Low after several switches, since it was on High when I was having the problem originally. I am now trying your double uninstall trick. FYI It said "Parallels Video" and I uninstalled it just now.
     
  9. Rachel Faith

    Rachel Faith

    Messages:
    234
    The unnatural thing is... the cursor works FINE before I log in... after I put in my password and it goes from the blue windows log in to the desk top is when and where it locks up and does not release.
     
  10. Rachel Faith

    Rachel Faith

    Messages:
    234
    Well, here we have a daisy....

    I uninstalled JUST the driver.... not the whole of tools.

    And it works !!

    Well, the MOUSE CURSOR problem is gone.

    I can drag, drop, cut, paste and NO key strokes are needed.

    BUT... None of the OTHER functions work.

    I cannot resize the screen, etc etc.

    No driver just fixed the drag and drop locking issue.

    So we KNOW it is in fact a video driver issue.

    I now have the VGA driver and the Yellow ! marker next to it.

    Before I remove tools totally, I am going to try and just manually install the driver itself.

    I can always go back and do it all over yet AGAIN...

    But this clue was an interesting test.

    Thanks
     
  11. Rachel Faith

    Rachel Faith

    Messages:
    234
    OK looks like I will have to take the LONG WAY home...

    The driver I downloaded may be corrupt.... somehow... maybe... so I am going to incorporate your steps into the whole shebang and re-download parallels from scratch and see how it goes.

    PS: I have done this, minues the individual driver uninstal step before... so that is the ONLY new variable we are introducing.

    Here is hoping.
     
  12. Rachel Faith

    Rachel Faith

    Messages:
    234
    It failed. Thanks for the hint. I believe you are on to something with the drivers, but I fear it is more complex than the standard windows diver issue. it is for sure something with the coding in Parallels.

    There is one additional thing of note.

    When I disabled the driver... the LAGS vanished and the system was much more responsive.

    Hmmmmm...
     
  13. Rachel Faith

    Rachel Faith

    Messages:
    234
    More...

    I have again, disabled the driver and manually installed it.... and the release function works, but the syncronization of the mouse does not. Meaning to say that when I take the black cursor over windows it does not turn white and pick up the windows mouse until I click.

    This is the same problem as when the video driver IS installed after reboot, except that it will release and stop at the windows border and do so without any keystrokes.

    Therefore my half solution is to boot the VM, wait for the long boot and lags to subside, remove the video driver, reinstall the driver manually, and then proceed to work in windows normally... or semi normally.

    The lags are gone and the drag and drop follows with the exception of having to click to capture the mouse before being able to click into anything on windows.

    It is not working perfectly, but at least I can drag items back and forth without too much of an extra problem.

    Obviously this is still a serious bug that needs serious attention.
     
  14. jmaluso

    jmaluso

    Messages:
    11
    I had this same issue when I first upgraded to 3.0 I tried to install tha tools multiple times from within the guest OS (Vista Business.) This did not work...actually the install program never even launched...I shutdown my guest OS and then set the option "Prepare Parallel Tools" and the next time I booted into Vista Parallel tools finally started to install and my mouse pointer issue was resolved.
     
  15. brkirch

    brkirch Kilo Poster

    Messages:
    415
    I seem to remember that selecting "Prepare Parallels Tools Upgrade..." from the "Actions" menu being required for one of the betas, perhaps that is still sometimes required? It would be worth a try if you're having this problem.
     
  16. alexg

    alexg Parallels Developers

    Messages:
    536
    Hi,

    I'm sorry for giving you troubles.

    If anybody have a problem with Tools just reinstall it. It slolve 99% problems you have.

    There is complete procedure.

    1. Open your Windows VM (2k, XP or Vista)
    2. Uninstall Parallels Tools using Add/Remove applications Control Panel in Windows.
    3. Reboot Windows.
    4. Install Parallels Tools using Install Parallels Tools... menu item of Parallels Desktop application.
    5. Reboot Windows.

    That procedure takes about 10 minutes and solves major problems. Have a nice day.

    Alex
     

Share This Page