Dual Screens flickering - Mountain Lion - Windows 7 - Parallels 7

Discussion in 'Installation and Configuration' started by insaddingaround, Jul 12, 2012.

  1. costabas

    costabas Bit Poster

    Messages:
    38
    @YanaYana: the Report Problem feature collects way too much information for my taste with regards to privacy.

    Here are some bits of information:

    License info:

    <ParsedKey id="0" dyn_lists="Validity 1 Flags 1">
    <Version>5</Version>
    <Edition>0</Edition>
    <Product>PRL_PRODUCT_DESKTOP</Product>
    <Identity>715236</Identity>
    <Validity id="0" dyn_lists="">
    <Issued>29.08.20111Unlimited</Issued>
    <Unit>0</Unit>
    <Period>0</Period>
    </Validity>
    <Platform>3</Platform>
    <Language>3</Language>
    <Distributor>0</Distributor>
    <CpuLimit>8</CpuLimit>
    <MemLimit>8192</MemLimit>
    <Type>0</Type>
    <Flags id="0" dyn_lists="">
    <Value>8 (0x8)</Value>
    <VTd>NO</VTd>
    <Trial>NO</Trial>
    <Full>OFF</Full>
    <NFR>OFF</NFR>
    <Beta>OFF</Beta>
    <Upgrade>ON</Upgrade>
    </Flags>
    </ParsedKey>


    Some of the virtual machine settings:

    <Video dyn_lists="">
    <Enabled>1</Enabled>
    <VideoMemorySize>256</VideoMemorySize>
    <EnableDirectXShaders>1</EnableDirectXShaders>
    <ScreenResolutions dyn_lists="ScreenResolution 0">
    <Enabled>0</Enabled>
    </ScreenResolutions>
    <Enable3DAcceleration>0</Enable3DAcceleration>
    <EnableVSync>1</EnableVSync>
    <MaxDisplays>0</MaxDisplays>
    </Video>


    <OsResolutionInFullScreen>0</OsResolutionInFullScreen>

    <FullScreen CornerAction_patch="2" dyn_lists="CornerAction">
    <UseAllDisplays>1</UseAllDisplays>
    <UseActiveCorners>0</UseActiveCorners>
    <UseNativeFullScreen>1</UseNativeFullScreen>
    <CornerAction>1</CornerAction>
    <CornerAction>0</CornerAction>
    <CornerAction>0</CornerAction>
    <CornerAction>0</CornerAction>
    <ScaleViewMode>1</ScaleViewMode>
    </FullScreen>



    Host system:
    <ConfOsType>Windows</ConfOsType>
    <ConfOsVersion>Windows 7</ConfOsVersion>
    <RealOsType>Microsoft Windows, 64bit, 4 cpu(s), page: 4096b</RealOsType>
    <RealOsVersion>6.1.7601, Service Pack 1</RealOsVersion>
    <RealOsDetails>ServicePack: 1.0; SuiteMask: 0x100; ProductType: 1; ProductEdition: 1</RealOsDetails>

    I use an MBP 17" early 2011 with the latest version of Mountain Lion.

    I hope this helps. If you are interested in other settings let me know.
     
  2. Dr_Rob

    Dr_Rob Bit Poster

    Messages:
    13
    Here's a video of mine going berserk:

    http://www.youtube.com/watch?v=Pbi0ucY-X-4

    Hurry up and fix this issue please, turning off 3D acceleration is not an ideal solution as Windows 7 does not perform as well without it.
     
  3. YanaYana

    YanaYana

    Messages:
    1,666
    i'm afraid it's not enough. We cannot se the processes sequence an actually capture the reason of the issue

    Thanks for those who sent the report - i will forward it to the dev team straight away.
     
  4. cyclops

    cyclops Bit Poster

    Messages:
    23
    Hi YanaYana,
    How would you suggest we document this for the devs? I've got two different Macs that are both exhibiting the behavior. A standard MacBook Pro 2011 17" with Mountain Lion, and a 2009 MacPro with Mountain Lion. Both have the same issue. One thing I've noticed is that it seems like the main screen is being drawn on BOTH monitors.

    Thanks!
     
  5. YanaYana

    YanaYana

    Messages:
    1,666
    i have forwarded your PR - it should be enough so far
     
  6. costabas

    costabas Bit Poster

    Messages:
    38
    @YanaYana:

    I thought the support team has been able to reproduce this issue aleardy. According to the kb (http://kb.parallels.com/en/114452) created for this issue the flickering occurs for the ATi cards. I also assumed that you guys have a test lab. This issue can be reproduced easily. I don't understand why is taking so long to get to the bottom of this. It is a pretty bad bug and it should go to the top on the priorities list. Using two monitors is pretty much the standard these days ( or using a laptop and a display). I am also using software that needs the 3d acceleration.
     
    Last edited: Aug 8, 2012
  7. YanaYana

    YanaYana

    Messages:
    1,666
    We are working on the fix at the moment. But additional problem Reports have always been very helpful for the responsible team.
     
  8. SimonGermain

    SimonGermain Bit Poster

    Messages:
    2
    I have the same problem. Playing around with it a little bit, I think I have a clue of what's going on. It seems that Parallels and OSX are fighting for window focus. Even using my Windows 7 x64 VM on a single monitor, the VM is extremely unresponsive and there are some weird unexplained delays when Windows is working hard. Just for giggles, I turned off the "Use Mac OS X Full screen" mode in the options and you can clearly see that the last OSX window you were focused on is switching focus really quickly.

    Hope this helps finding a solution to this problem. The workarounds suggested in your knowledge base aren't exactly a solution since VM performance is still REALLY bad.
     
  9. costabas

    costabas Bit Poster

    Messages:
    38
    Did any of you try this fix? The article is about vmware but they mentioned moving the OS menu bar on the secondary panel (this is doable in OSX->Settings->Displays->Arrangement, drag to menu bar to the second display). However I don't know about making the bar visible at all times in Parallels. Right now it appears or retracts as I hover the mouse to the top or move away from the top.

    http://kb.vmware.com/selfservice/mi..._1_1&dialogID=397406586&stateId=1 0 397426146
     
  10. Sirronalot

    Sirronalot

    Messages:
    1
    Thanks Costabas

    It seems out there, but this actually worked. I have 3D Acceleration back with NO FLICKERING!!!
     
  11. Zendog

    Zendog Bit Poster

    Messages:
    19
    Same screen flicker and bleed through issues here ...

    FYI ... Having the same issue, seems to be a common issue. None of the simple suggestions above worked for me to resolve.

    To be specific, the method of turning of 3d / aero off works to create stability in the displays, but I do not consider this to be a feasible alternative and need to have a permanent fix that allows me to run full WDM functionality and Aero capabilities.

    Have sent a trouble report and opened a support request. Have a 2008 Mac Pro with ATI 5870 and 1024 MB. Problem started after Mountain Lion upgrade.

    Overview:

    Model Name: Mac Pro
    Model Identifier: MacPro3,1
    Processor Name: Quad-Core Intel Xeon
    Processor Speed: 2.8 GHz
    Number of Processors: 2
    Total Number of Cores: 8
    L2 Cache (per Processor): 12 MB
    Memory: 32 GB
    Bus Speed: 1.6 GHz
    Boot ROM Version: MP31.006C.B05
    SMC Version (system): 1.25f4
     
    Last edited: Aug 12, 2012
  12. costabas

    costabas Bit Poster

    Messages:
    38
    @Sirronalot:

    Tried this solution today and it seems to work to a certain degree, however there is still some flashing, a lot less perceptible though, when the focus moves from one display to the other (at the top of the display, I would say 1 inch or 2). One can definitely live with this if one needs the 3D acceleration.

    For those who try it the key thing is to move the OSX menu bar on the second Windows display. There something funky going though.

    After I moved the top bar to the second display (laptop) in OSX, I restarted the VM, and the Windows displays were switched as well (the laptop became the primary display and TD became the secondary display). I still got the flashing, but as soon as I changed the primary display in Windows to be the TD, the bad flashing stopped altogether.

    After all these changes, somehow Parallels created three desktops (I am not too sure this is the right term, I mean full screens or windows), one for each display plus one more. I don't know what the third one is supposed to do.
     
    Last edited: Aug 13, 2012
  13. harpend

    harpend

    Messages:
    1
    On my imac with ubuntu in a pvm running full screen on dual monitors I was able to get rid of the flicker by unchecking (i.e. disabling) "use mac full screen" in the configuration.
     
  14. insaddingaround

    insaddingaround

    Messages:
    5
    Turning off 3D acceleration worked for me. Not as pretty, but at least I'm working on two screens again.
     
  15. CrankyCoder

    CrankyCoder

    Messages:
    3
    17302434 is my report ID. Turning off 3D acceleration helped, but definitely made it more difficult to work.
     
  16. Perkof

    Perkof

    Messages:
    5
    I am also experiencing this problem in a variety of windows VM's. Disabling 3D acceleration and moving my osx menu bar to the appropriate screen fixes the issue somewhat, how some of the VM's are completely unusable without 3d acceleration.
     
    Last edited: Aug 19, 2012
  17. YanaYana

    YanaYana

    Messages:
    1,666
    Thanks for Problem Reports
     
  18. cyclops

    cyclops Bit Poster

    Messages:
    23
    Will this be fixed with Parallels 8?
     
  19. costabas

    costabas Bit Poster

    Messages:
    38
    FYI, the OSX 10.8.1 update doesn't fix this.

    @YanaYana: any updates on the issue?
     
    Last edited: Aug 23, 2012
  20. Zendog

    Zendog Bit Poster

    Messages:
    19
    Tried the suggested update released today with no joy :-(

    The suggested OSX update recommended on the thread does not resolve the issues for me either. It seems to have made things a little more stable (hard to tell). But certainly can still create this issue by moving an active window to one of the auxiliary screens and when changes are made to the window they still randomly bleed over and overlay where the window was on the original screen.

    The OSX update is NOT a FIX for this issue.
     

Share This Page