eCS install, world's easiest question

Discussion in 'Other Virtual machines' started by dandrake, Jan 23, 2012.

  1. dandrake

    dandrake Junior Member

    Would like to run eCS 1.2 under Parallels in Mac OSX 10.6 Snow Leopard. The first steps are marvellously easy: Start Parallels, shove the release DVD into the drive, make obvious menu selections to start a new virtual machine loading eCS 1.2; a little 800x600 window opens up, and in it the whole familiar eCS install sequence appears, up to the point where you identify the keyboard and accept the license agreement. Amazing! And if you think I don't mean it, you haven't tried to do the same with Virtual Box. (But hey, VB is FREE, what a bargain.)

    Then I just have to enter my eCS license id, 72 digits of it. Two choices here:
    1. (Just for laughs, because it's so utterly crazy, so ignore this: Enter all of that manually and perfectly. This is much worse than it sounds, since certain characters that are in the license cannot be typed in. Like Ohh and Zee (Zed also fails :). I don't remember this from my many previous eCS installations, but then I have probably never tried typing the stuff in. Clearly, I could try with 0 and 2 in place of those, but when I get to the + in the middle of the string, I don't feel like playing guessing games.)

    2. Enter it directly from the text file that eCS supplies, as I've always done with physical OS/2 installations.

    Pray tell, how do I do that? I can plug in my thumb drive, FAT-16 formatted, and Mac is happy to read it, but that doesn't get the data to the eCS installer. I have the suspicion that maybe if I knew anything whatever about .hdd or .fdd files, such as how to get data files into one and tell eCS about it, it might be cool. But alas, all I find is the Parallels Help stuff on Sharing, which according to the Configuration program is not available on the Mac. Not obviously useful.

    Please, anyone have an answer? I mean, at least it *looked* like an easy question.
  2. Bit poster

    eComStation USERNAME and REGKEY entries

    I solved the problem by copying all of the eComStation installation CD to a empty subdirectory on my Mac, created a TXT file containing my USERNAME and REGKEY, copied that file into the same subdirectory, and created a new DVD of the entire subdirectory (the size is slightly larger than a CD will hold so it was necessary to use a DVD), then tried installing from that DVD. Although I was able to load the USERNAME and REGKEY from the file on the DVD, the rest of the installation failed because Parallels would not create a C: partition to install the operating system. Has anyone else encountered that problem and, if so, how did they solve it? I'm totally baffled and have been unsuccessful so far at completing the installation.
  3. dandrake

    dandrake Junior Member

    Real floppies, failing virtual disks, and does Parallels 7 work

    I guess it wasn't so easy a question as I thought.
    However, I found a workaround like yours, only even easier -- embarrassingly so. I had an old UBS floppy drive in my Miscellaneous Box, and it works with the Mac, and it's easy to configure the VM so that it reads the actual floppy drive. Wrote the license file on a floppy, plugged in to the Mac, and it all went well. (NB: There are problems with the floppy support, so that changing disks seems to be impossible once you've read anything, requiring a reboot of the VM or something.)

    So, with that, I got through just fine -- to the point that you got stuck at. The installation OS/2 will not detect the virtual hard disk at all. I tried a couple of things, like prepping the VHD with FDISK and FORMAT in a DOS guest machine -- works fine for DOS, and would work fine in a real disk presented to OS/2, but the OS/2 install still can't see it on the VM.

    I put a query in another thread, whether anyone has ever tried this installation under Parallels 7. There are notes in the forum about success in this installation, but they all seem to be years old, using Parallels 4 and the like. No replies yet. I wouldn't be surprised if this got broken along the way to version 7.

    Now I have a support ticket open with Parallels to look into this problem. After some mixups, I'm hoping to have some kind of real info soon. Maybe they'd provide an old Parallels 4 release for comparison??
  4. Bit poster

    How is eComStation installed as a virtual operating system under Parallels for Mac?

    I tried using a USB floppy drive containing the USERNAME and REGKEY, too, but when I tried to read the text file from the floppy, the eComStation (eCS) installer showed no files on the floppy, even though I had associated the floppy to eCS rather than OS X. I also tried associating the floppy with OS X and that didn't work either.

    There are several files on the floppy and I've verified that those files show up on my Windows machine as well as on my OS X machine under Finder using the very same USB floppy drive. However, the eCS installation program still reports that no files exist on the floppy, even though it recognizes the floppy drive and doesn't report any errors with the drive.

    It would appear that since we're both seeing the same problem, it's not likely something that I'm doing wrong, but, rather, a problem with Parallels for Mac. I have been discussing this issue with the Parallels support team but, so far, no answers. They suggested that I take all of the eCS installation files and put them into an ISO file and burn that to a DVD, then install from there. However, I couldn't figure out how to make an ISO file, and the instructions provided by the support team did not work.
  5. dandrake

    dandrake Junior Member

    Go no further if you like networks

    Good news: I got it to go through installation, which I hardly could have done without direct and diligent support from the organization.

    Less good: Though I can post clear instructions for this, while it's still semi-fresh in my head and my notes, I don't know if it's worth the effort; and it definitely isn't possible just now, when I'm recovering from my recent bout of trying to make it do something useful.

    Bad: Nobody tells you this, but connecting this to a *network*, which you can do with more popular Guests, is not possible. No Drivers. If Support tells you to load the Parallels Tools, tell Support that there are no tools for eCS or OS/2. This is in the user manual Parallels Desktop User's Guide.pdf -- sort of in it, by implication, but nowhere stated.

    It may be possible to run some kind of pseudo-network to the host Mac itself, by putting the network connection in Host-Only mode. Whether that's for real, the guy on the Chat line didn't know, and some kind of further support call is to be arranged.

    Meanwhile, it clearly appears that there is *NO* way of exchanging info between your eCS VM and anything else, apart from floppy disks. Well, to be fair, also CD-ROMs, maybe. And writing on a virtual hard drive, but you know, there's no way that can communicate with anything else in the world apart from another Parallels eCS VM. AFAIK.

    So, I could write up the basic install procedure, but I doubt whether anyone would be interested in making a machine hermetically sealed from the corrupting influences of the outside world.
  6. Bit poster

    I had a Parallels serice engineer help me install eComStation and he got it working, although I had to enter the USERNAME and REGKEY manually (what a job that is!) Now, the only remaining problem is getting eCS to communicate across my LAN to talk to my other machines. With that problem, the Parallels engineer had no advice or offered any help. He did get the TCP/IP part working so I now have internet access, but the Net BIOS over TCP/IP does not yet work. I can't tel you exactly how he made it work because he took control over my machine using a third party communication program and made his moves too quickly for me to understand what he was doing.

    Getting ecS to talk to y other ocmputers may prove to be a formidable job, so I don't look forward to that process, which I'll have to figure out on my own. The eCS manual offer little help in this regard. He first tried using an Intel 1000 GB/s network adapter which didn't work, but then changed to another network interface device, which did seem to work, or at least gave me internet access. I guess I'll have to keep trying different combinations to get LAN communications running successfully. eCS is difficult to set up for netorking because of the arcane names they've given to the various networking names, so that only adds to the difficulty of making things work. I want this virtual eCS machine to talk to at least my other ecS system, but that machine is down right now so I can't try to get the two to talk until I figure out the problems with the first machine.

    I warn people, however, that installing the eCS V2.1 upgrade has the propensity of deleting all existing partitions on other drives when it is installed. I lost all of my files on all my other drives and partitions because of this upgrade, so I advise others to back up to an outside devide, either DVDs or over a LAN to other machines before trying to upgrade eCS to Version 2.1. The manufacturer, Mensys, insists it isn't their problem but it has to be since I didn't do anything besides telling eCS to overwrite my old version of eCS V1.2 with the new version. It did that but also deleted all of my JFS-formatted drives. So, watch out before making this upgrade. Frankly, I'm sorry I made the upgrade because the benefits of whatever is new in V2.1 was not worth losing all of my files over. My last DVD backup was in 2003 so that sets me back by many years of hard work on software improvements, etc., that should never had happened had I not upgraded.
  7. dandrake

    dandrake Junior Member

    Making network work

    Sorry to be slow replying, because I have an answer that I believe will work nicely. It just required struggling with a bunch of very unclear documentation till I caught on to what the support people were talking about. Anway, here it is:

    You go into the Hardware section of the Configuration of your VM. You can do this BTW in the very first part of doing the eCS installation, before even starting starting the reading of the installation disk. Pick the Network item. It gives you a drop-down list (called Type) with three sections , which are Shared Network on top (which is checked) and Host-Only Network at that bottom; and in between, a bunch of lines headed by "Bridged:" which is grayed out like an invalid option is really meant as a header for that section. Click on Default Adapter, the first choice there.

    That's half the job.

    Now execute your VM. Get the Adapters and Protocols thing, which I assume you have used before. On the v1.2 release you already have the right adapter listed, which is RTL8029 PCI adapter. Select it, hit the Change button, and that's all you really need to do. It figures out the other options for itself. When you've saved and rebooted, it will have direct access to your LAN; assuming there's a DHCP server on the LAN, the booting process should pick it up, and you'll have an IP address already assigned when the system finishes booting. Ping something and rejoice!

    Oh, and if you don't have that adapter in your installable list, there is one in the Parallels Utility thing, and you can read it into your system and proceed. I don't have time right now to describe that, but it's not hard.

    Sorry this is so sketchy. No time to write up the details.
  8. MrDon

    MrDon Bit poster

    An old thread, maybe worth chiming for others.
    eCS installs very nicely as long as you put your registration file on a cd and attach the host drive during install. I am at v2.1 and the base install as an iso file. When I installed v1.2, I had a usb cd drive attached.

  9. PeterEB

    PeterEB Bit poster

    There is a utility that called RE2ISO on Mensys site for registered ECS users.
    This adds the Username and password in a file to the ISO in a REG in the root of the install disk.

    This will not put the reg and user information in the box for you but at least it is on the CD/DVD.

    you can also use various tools to remove certain files from the image prior to burning to give space.
    Not every one needs all the programs or language packs.

    ECS does fill a need and is the better Windows than Windblows. IMHO.

    Happy motoring.

Share This Page