en1, 802.1x and DHCP

Discussion in 'Parallels Desktop for Mac' started by steve3, Apr 14, 2006.

  1. steve3

    steve3

    Messages:
    32
    Setup: MBP 1.83 with Parallels Beta 3, Win2K VM.

    Networking the VM over en1 works just fine at home, using WPA encrypted WiFi. The VM grabs it's own IP address via DHCP, and just works.

    At the office, we use RADIUS authentication to an Elektron server by Corriente (www.corriente.net). While the MBP authenticates seamlessly, the VM ends up self-assigning a 169.254.x.x address if set to DHCP.

    If I manually assign an address, the VM can get online.
     
  2. steve3

    steve3

    Messages:
    32
    I've done some more troubleshooting, and have found that the DHCP server sees the DHCPDISCOVER, and replies with a DHCPOFFER, but my VM never gives back a DHCPACK.

    Anyone else having this experience?
     
  3. mikesax

    mikesax

    Messages:
    10
    RE: Wifi DHCP fails

    I have a similar experience: The VM's DHCP doesn't work over Wifi, networking works fine if I assign an IP address and DNS server in the VM manually. Same experience with multiple WiFi routers.
     
  4. steve3

    steve3

    Messages:
    32
    My results aren't consistent across routers. I have Linksys WRT-54G at home and work, though configured differently. I can do DHCP over WiFi with the router as the DHCP server, and WPA encryption.

    At work, where the DHCP server is a separate router and the connection is RADIUS authenticated, the connect fails.

    Mike- are you using the DHCP server in your wifi router, or an separate device?
     
  5. steve3

    steve3

    Messages:
    32
    I'm still seeing the same behavior in Beta 4.
     
  6. serv

    serv Parallels Developers

    Messages:
    809
    steve3,

    When bridged to wireless adapter a VM send packets to the network
    specifying host MAC address as the source, i.e. as if the Mac OS X sent that
    packet. This is to circumvent the limitation of 802.11. At the same time DHCP
    payload carries actual VM MAC as if Mac OS X simply relayed DHCP packet.
    If your DHCP server is picky about source MAC addresses, disallows more
    than one IP for MAC or do not allow relayed requests, DHCP won't work for VM.
    Unfortunately it's hard to make it work in all possible configurations.

    Since you've already done some DHCP sniffing (I guess), could you please
    take a closer look at DHCP negotiation to find out what IP address is being
    offered to VM (that it's not the same that Mac OS X has), that VM sends request
    after an offer, and that DHCP does ACKnowledge (or deny) the request. This
    require sniffing network traffic on your DHCP server.

    Thanks
     
  7. jblackburn

    jblackburn

    Messages:
    1
    same problem

    I am seeing the same problem. This worked correctly in beta 3 I believe and then has been broken since. I'll try to do more troubleshooting and provide some traces. For some background:

    Wireless is 802.1x
    DHCP server Windows 2003

    The networking works correctly at home with WPA-PSK.
     

Share This Page