Enterprise linux : time out of sync = no CVS

Discussion in 'Parallels Desktop for Mac' started by moyse, Nov 10, 2006.

  1. moyse

    moyse

    Messages:
    3
    Hi all,

    I'm having problems which are making parallels very hard for me to use: I'm running Enterprise Linux (actually it's scientificlinux.org, but this is based on EL) and I cannot use CVS easily because I keep getting e.g.:
    cvs [diff aborted]: kerberos authentication failed: Time is out of bounds (krb_rd_req)

    I'm running ntpd with the correct time-server set (and in fact its the same as on my OSX desktop, where CVS works). If I keep trying 'cvs co' etc it sometimes works (usually just after I restart ntpd), but it can take 20 attempts!

    Does anyone have any tips? It's a bit of a disaster not to be able to use CVS properly.

    (Oh, and I frequently see: "set_rtc_mmss: can't update from BLAH to BLAH" - which may or may not be related)

    Thanks in advance for any help you might be able to give!

    Cheers.
     
  2. joem

    joem

    Messages:
    1,247
    The time sync problem appears relevant. Can you increase the Kerboros window? (As in do you have the authority -- it's technically possible).
     
  3. moyse

    moyse

    Messages:
    3
    If that has to be changed at the server side, no I definitely don't have authority (and I'm extremely unlikely to be able to get anyone to do it for me).
     
  4. unused_user_name

    unused_user_name

    Messages:
    495
    Try installing the network time protocol daemon in your VM.

    http://www.die.net/doc/linux/man/man1/ntpd.1.html

    I can think of two ways of configuring this:

    1) You could install and enable a network time server on your Mac, then configure ntpd on your VM to use to the Mac's time server once a minute or so. Very easy to use, but kind of a pain to setup, I don't know of any network time servers that have a GUI.

    2) Run ntpd in your VM normally. You will have to manually restart the daemon when you unsuspend your VM, which can be a pain, but it works very well.

    I use option number 2, mostly because I am too lazy to figure out how to get a ntp server running on my macbook.
     
  5. mcg

    mcg

    Messages:
    168
    Last edited: Nov 24, 2006

Share This Page