Error 15380

Discussion in 'Installation and Configuration' started by H.-UlrichG, Sep 2, 2012.

  1. H.-UlrichG

    H.-UlrichG

    Messages:
    1
    Good Morning!

    Just installing the update for Version 8.
    Unfortunately i get the "Error 15380" during the process and it stops.

    My Question:
    What does it mean?
    How can i fix this?

    Kind regards from:
    Uli
     
  2. Roman Fattakhov

    Roman Fattakhov Parallels Team

    Messages:
    64
    Hi,

    Do you have any anti-virus software on your Mac like Virtus Barrier or any other? If you do, disable it and try to install Parallels Desktop 8 again
     
  3. jrsmith

    jrsmith

    Messages:
    1
    I'm having the same issue. I disabled SEP, still got the error. Ran fix permissions in disk utility, still got the error. I uninstalled SEP completely and rebooted, still got the error. Fixed permissions again, still got the error.

    I'm at a loss for what else to try, other than uninstalling completely.
     
  4. sparker

    sparker

    Messages:
    63
    Getting same "see error 15380" during install

    I'm installing P8 over P7 (and P8 after manually deleting P7, now), on a QuadCore 2.5Ghz MBPro with 16Gb of RAM and 300Gb of free disk space.

    Parallels installer won't install properly. I get "Parallels Desktop could not be started. Please try again. If the problem persists, please contact the Parallels Support Team". Expanding the "Help me solve the problem" refers to Problem ID 15380, but the link to the "solution" just goes to the support home page. Kinda useless.

    I'll contact support.

    Steve
     
  5. Allen Eastwood

    Allen Eastwood

    Messages:
    2
    I'm getting exactly the same thing, very disappointing!
     
  6. sparker

    sparker

    Messages:
    63
    In my case, it turns out that a combination of Virus Barrier and Little Snitch were stopping some "unusual" registration/validation process from running, which led to the weird error.

    Turning off both temporarily (just during the installation) worked fine.

    Steve
     
  7. Allen Eastwood

    Allen Eastwood

    Messages:
    2
    No joy here after disabling firewall & LS & Sophos. 7 installs just fine, this kind of garbage really makes me regret upgrading. Might be time to go back to Fusion.

    No reason at all for this kind of silliness, makes me wonder if the product is worth it. I wouldn't be able to tell because it's not installing!
     
  8. sparker

    sparker

    Messages:
    63
    IMHO, the worst part is that the error messages and help (both internal and on the website) turn out to be useless. When the only place you can find an error number and description is in a users forum where others have seen the error, that's bad customer support. There should be a list of these errors somewhere that we can easily find them, and what EXACT function in the source is creating them. Many of us are smart enough to be able to intuit the answers from that kind of information.

    And Allen, it is worth pursuing. Parallels 7 was VERY slow compared to Parallels 6, and the new version seems to have resolved whatever it was that was making P7 so slow....

    Just my $0.02

    Steve
     
  9. sopa123

    sopa123

    Messages:
    1
    i got the same error today and i dont know what to do someone find a solution yet ?

    ____________________________________________________________________________________________________

    χειροποίητα κοσμήματα
     
  10. Jerry Thompson

    Jerry Thompson

    Messages:
    4
  11. ShockDoc

    ShockDoc

    Messages:
    1
    This didn't work for me to start with.
    Then tried 3rd time but had the Terminal open and put in the last command but didn't press return until clicking on the app to open it, switch back to terminal and pushed return.

    Then it worked.
     
  12. robertdbrowniii

    robertdbrowniii Bit Poster

    Messages:
    19
    Turning off Virus Barrier Real Time Scanner fixed this problem for me.
     
  13. leezhm

    leezhm

    Messages:
    2
    Got the same error


    I got the same Error and follow the KB article to try serval times.It can not work fine.

    Please pay attention to this Error, I am waiting.
     
  14. Steve Callan

    Steve Callan

    Messages:
    3
    Useless help and support

    All the 15380 link takes you to is the basic FAQ/support page. Nice, but useless for solving the problem at hand.
     
  15. goodloop

    goodloop

    Messages:
    1
    just FYI

    I suffer the problem also.
    and I found my problem finally. it is because I use replace /usr/bin/stat with gstat from macport. because I want to compile CM source code .
    When I restore the command tool. I works.
     
  16. FabioRibeiro

    FabioRibeiro

    Messages:
    1
    Same problem happening now. Spoke to support, they messed with my Mac remotely for over an hour and could not solve the problem. Got escalated. Let's see.
     
  17. SiyuanF

    SiyuanF

    Messages:
    1
    I've got the same problem. Now I solved it.
    Check the password of your root account, and change it to the same password with your user account.
    Commands should be : passwd su
    Hope it helps.
     
  18. Zhang Xiaohe

    Zhang Xiaohe

    Messages:
    1
    Install Parallels Desktop 9 for Mac need root (UID must 0)

    Some times, you 'sudo su' command can't change you to root (uid 0), it only change your group is root.
    有些时候,执行"sudo su"命令无法使你切换到root账户(uid 为 0)的root,只能够把你切换到 root 组。

    This is very important, because PD need root(uid 0) to install Mac OS X kernel extensions, .kext files.
    这是十分重要的,因为 PD 需要使用 root (uid 0) 来进行安装一些 Max OS X 中的 内核扩展, 也就是 .kext 文件

    You got Error 15380, it means PD can't change current user to root(0),
    你遇到 15380错误,就是因为PD无法切换当前用户到root(0)

    This is not a PD bugs, it is Mac OS X setting. But I hope PD friendly prompt to me, why happen 15380.
    这不是PD的Bug, 这是Mac OS X 的设置问题。但是我希望PD可以更友好的提示我,为什么出现15380.

    Fix to install.
    修复完成安装

    0. Fix Disk permission
    0. 修复磁盘权限

    Terminal command:
    命令行:

    1. 'sudo su' Change current user to root, input your current user's password
    1. 'sudo su' 切换当前用户到 root,输入的是当前用户的密码

    2. 'id -a' Check current root account information, If output 'uid=xxx(root)....' then you must fix uid to '0'
    2. 'id -a' 检查当前root 账号的信息,如果输出的内容是 'uid=xxx(root) ...' 那么就必须修复这个 root 的 uid 到 '0' 才可以

    3. "sudo -u '#0' command " force execute command with root (uid 0)
    3. "sudo -u '#0' command " 强制使用 root(0) 来执行命令

    4. 'dscl . -list /Users UniqueID' display all User in Mac OS X UniqueID information, user means unix account, include login User and some system account
    4. 'dscl . -list /Users UniqueID' 现实所有Mac OS X中账号的UniqueID 信息,账号的意思就是Unix风格的账号,包含登录用户,也包含各种系统用户

    5. find root uid in dscl list result, it will be used in next command
    5. 查找root的当前uid, 这个信息在下面的指令中用到

    6. "sudo -u '#0' dscl . -change /Users/root UniqueID xxx 0" change root uid xxx to 0 , xxx is result from prev command
    6. "sudo -u '#0' dscl . -change /Users/root UniqueID xxx 0" 将 root 的 UID xxx 调整为0, xxx 是上一个指令中找到的。

    7. exit, and quit Terminal
    7. 退出账号,退出 Terminal 程序

    8. install PD
    8. 安装
     
  19. HyeonseokS

    HyeonseokS

    Messages:
    1
    I have fixed this issue by simply disabling guest user.
     
  20. rkulikov

    rkulikov Parallels Developers

    Messages:
    269
    In most cases the reason of 15380 problem is UID duplication.

    For example, both Guest and root users have UID 0. To fix this need to assign Guest new unique UID.
    List users UID-s:
    $ dscl . -list /Users UniqueID
    . . .
    Guest 0
    Guest1 201
    . . .
    root 0

    Change Guest's UID:
    $ sudo dscl . change /Users/Guest UniqueID 0 202
     

Share This Page