Error Attempting to Access via http

Discussion in 'Parallels Remote Application Server' started by kcrbikes, Sep 29, 2006.

  1. kcrbikes

    kcrbikes Guest

    Hello all!

    I can access published apps on the LAN, or even via internal website. From the WWW (a machine with the 2x client outside our firewall, via the web) I am having trouble, getting the error "The specified remote computer cannot be found. Verify that you have typed the correct computer name or IP address and then try connecting again." I am missing something - but not sure what.

    On the 2x Application Server:

    2x Service is 20002
    TS is 3389
    Web Proxy is 80
    IIS port is 8080

    On firewall:

    80 is open
    3389 is open
    8080 is open
    20002 is open

    From the WWW, I see the published applications, and even the login screen provides the correct information.

    Can anyone give me a clue what I am missing?

  2. rafelbev

    rafelbev Guest

    Your problem is probably not the ports but rather the IP. When publishing to web, you can give the IP address of the ApplicationServer to be used in the settings published on the webserver. That IP is resolvable internally, but when used on the WWW it isn't hence the "The specified remote computer cannot be found". What you could do is publish another set of webpages which will be used for the WWW and place the external IP address of the router of your network. The port 80 which is published should be of this second webserver you have created.
  3. kcrbikes

    kcrbikes Guest


    Thanks for the reply, but no luck yet. I removed the internal website entirely (Does 2x allow apps to be published to two sites simultaneously?). The external address goes through a router that has NAT enabled, so the external address is mapping automatically to the internal. It must be working to some extent if pointing to the external address brings me to the 2x page with my web published apps.

    Since the Web Server and the 2x server are the same, could that be the problem? I have the web server running port 8080, and 2x Web setting is running port 80. Is that what you mean when you say "The port 80 which is published should be of this second webserver you have created." ?

    Thanks again!
  4. rafelbev

    rafelbev Guest

    Yes it does. Just publish two sets of static html pages to two different folders. Then publish the two different folders on two different ports on your IIS.

    Add a setting on your router to do port forwarding from an external port 8000 to the internal 8080 port of your web server and it should solve your problem.

    Then run a second website on the IIS on another port 8000. In this folder publish the internal settings.

    You can optionally add a DNS entry for the internal machine hosting the services and the same entry also on the external DNS server.

    With this scenario, whoever is within the internal network as well as the external network will always communicate with the same webserver dns address over port 8000, and communicate to the 2x proxy over port 80.
  5. kcrbikes

    kcrbikes Guest

    Still need a hand...


    I am still running into the same error/result, though I have added the port forwarding. Here is a breakdown -

    Router forwards external port 8000 to internal port 8080.
    Port 8080 is the port of the IIS website.
    2x is installed on the same machine.

    In the Advanced Proxy settings in 2x,
    Http Server is localhost:8080
    App Server is localhost:20002
    TS is localhost:3389
    Web Proxy is 80

    I have removed the internal website.

    When accessing via the external address, I do get to the published 2x web page. When I attempt to run one of the published applications, I get: a tsclient message:

    "The specified remote computer cannot be found. Verify that you have typed the correct computer name or IP address and then try connecting again."

    Thanks for your help thus far - I am eager to get this up and running and don't like being a PITA.
  6. nixu

    nixu Guest

    Hi there,

    The 2X Client Gateway is capable of proxing HTTP, RDP & 2X Protocols on port 80.

    So what you need to do is the following
      ------------------                            -------------       ---------------
      | Web Browser    |                            | Router    |       | 2x Client GW | >-----------------
      | & 2X Client    |       /\/\/\/\/\/\/\       | Forwards  |------>| PORT 80      |    |      |       |
      | Connect        | ----> | INTERNET    |----->| Public IP |       |              | 2X Prot   |       |
      | To Public IP   |       \/\/\/\/\/\/\/       | Port 80 to|       | 2X Pub Agent |    |      |       |
      | Port  80       |                            | 2x Client |       | Port 20002   | <---   RDP Prot   |
      ------------------                            |  Gateway  |       |              |           |       |
                                                    | Port 80   |       | RDP Server   | <----------       |
                                                    -------------       | Port 3389    |                HTTP Prot
                                                                        |              |                   |
                                                                        | WEB server   | <------------------
                                                                        | Port 8080    | 
    Set your Cients web browser to connect to port 80 (Default).
    Set your 2X clients to connect to Port 80 (Default).

    Set your router to foward tcp requests from public IP port 80 to 2X Client Gateway Port 80

    The 2X Client Gateway will foward http requests to the Web server on port 8080.
    This settings is found under Connection Settings, Connection, Advanced, HTTP Server.

    The 2X Client Gateway will foward 2X Protocols to port 20002.
    This settings is found under Connection Settings, Connection, Advanced, 2X Publishing Agent 20002 (default).

    The 2X Client Gateway will foward RDP Requests to port 3389.
    The RDP servers need to be configured from the Terinal Servers Tab.


  7. kcrbikes

    kcrbikes Guest


    Where do I find the 2X Client Gateway? I just re-downloaded and installed the 2X Application Server for Windows Terminal Services ver 3.7, thinking it was now bundled in there. Also downloaded the 2X Application Server Client and did not see the Client Gateway.

    Please Advise.

  8. nixu

    nixu Guest

    Hi there,

    The client gateway is bundled from version 4.1 onwards.

    I recommend that you download the latest version from:


  9. kcrbikes

    kcrbikes Guest

    Closer and closer


    I found the latest beta and installed it - I like it even better than the 3.x version.

    So it is installed, and either from a workstation on the LAN or across the intranet, I can run my published apps.

    When I run from outside the firewall, I get to the 2X Web Portal and see my published apps. When I try to run one, I can see the 2X Application Connector attempting to connect (gives the Server name), but I get an error that says:

    2X Application Client

    The client could not access the remote application. Terminal Server might be too busy to accept new connections or network problems are preventing your connection. Please try connecting again later.

    There is no Windows firewall on this workstation that is attempting to connect across the Internet. The TS has no one logged into it.

    When I check the log file, I can see the LAN connections that were successful and I believe the intranet connections that were successful. There is no sign of my connections from across the Internet.

    The "options" for the Application Connector for my published application via the web include:

    Primary Server: METIS (the server name)
    Port: 80 (and 8080 - tried both)
    Domain: (domain all this is taking place in)
    Connection Mode: Regular Gateway
    Auto Logon is checked.

    Reveiwing your first post to me, you mention "Set your router to forward tcp requests from public IP port 80 to 2X Client Gateway Port 80". I have my webserver, 2X Client Gateway, Application Server and Load Balancer all on the same machine. How would I forward port 80 to the 2X Client Gateway Specifically, or would this be moot?

    Thanks -

  10. nixu

    nixu Guest

    Hi there,
    Usually administrators do not install the 2X Application Server directly on the Internet, they usually install a router with a public IP and forward it's requests from port 80 on the public ip to an internal IP when the 2X Application Server is found.

    From you post it seams that you have a firewall,
    If you have content filtering enabled on the fire wall your connections would be drooped. What I recommend is that clients connecting from the Internet set the Application connector to connect using SSL Mode, so that the connection would be secure and will be allowed through the firewall.


  11. kcrbikes

    kcrbikes Guest

    Got it - it was a TS problem


    Thanks for the help. Since it was working fine on the Intranet but I was getting a TS error on the Internet, I figured that the PIX firewall was blocking whatever ports TS needed for the conversation. I mimicked the ports for my Citrix Metaframe server on the same network and all was solved.

    Thanks again. Now to play with the printing...<g>


Share This Page