Error connecting to published application

Discussion in 'Parallels Client for Android' started by pcbs, Aug 29, 2012.

  1. pcbs

    pcbs

    Messages:
    3
    Hello,

    I'm currently testing 2x client on an android 4.0.4 and i'm experiencing a problem.
    First to know is that i already use 2x client with many laptops and it works perfectly fine.
    My android tablet is connected in the exact same LAN than the laptops.

    I installed the 2x client app whitout any problems and configured a new 2x connection. Until this point everything is ok and i can connect with my username/password and see the list of my published applications.
    The problem starts here, when i try to launch any of the applications i got the following error message :

    Code[1a/00000001]
    Network unrecheable. Check the IP adresse or computer name

    (Sorry i don't have the exact english message since mine is in french but it should be something close)


    I tried with another tablet which was an android 4.0.3 and the problem is the same. I tried with a windows tablet and it works fine...

    Anyone already experienced this problem ? or have a clue to find how to make it work ?


    Thanks for any help or advices.
     
  2. jpc

    jpc Kilo Poster

    Messages:
    297
    I would first check the basics:
    • checking that the tablet is properly connected to the network
    • ensuring that it is using the same network as the windows one?
    • double checking the Server IP and Port
    You said that you are using a published application. Does normal RDP work?
    Also what OS are you running on the target machine?

    PS: Please do not double post.
     
  3. pcbs

    pcbs

    Messages:
    3
    Thansk for reply and sorry for double post, it was a mistake.

    I checked what you asked : Tablet is properly connected and in the same network, ip server and port are ok.

    After many checks i found out that the problem is with the connection mode, i had to use "gateway mode" and it works fine now, i don't really understand why i have to use this mode only on android/ipad (i checked with ipad and it's the same thing) and not on laptop and windows tablet. If someone have an idea or a link to a documentation.

    Well, finally it works just a config problem.

    Thanks for your help.
     
  4. jpc

    jpc Kilo Poster

    Messages:
    297
    Documentation for 2X Products is at:
    http://www.2x.com/documentation/

    As for the '"Gateway Mode" issue', the only thing that comes to mind is that the machine on which you have the published application cannot be accessed on the same network (e.g. it is behind a firewall). However, this would have affected all machines on the same network.
     

Share This Page