Error ID: PRL_ERR_disk_read_failed (80021029)

Discussion in 'Windows Guest OS Discussion' started by QincyS, Jun 10, 2011.

  1. QincyS

    QincyS

    Messages:
    1
    Hello,

    I need help.

    I am using parallels desktop 6 for Mac. Two VM were installed, Win7 and WinXP. I just noticed that perhaps after updating to 10920 I cannot launch WinXP any longer. I got this message:

    An error occurred while accessing the hard disk 1 used by "winXp". Error ID: PRL_ERR_disk_read_failed (80021029), errno=34 (result to large).

    I did a google search, and tried to add "devices.sfilter.enable=0" in the configuration. It did not work.

    Please help. Thanks.
     
  2. Jammeaze

    Jammeaze

    Messages:
    9
    Same error all of a sudden

    I'm getting this same error and it's frustrating.
    On my iMac: running OSX 10.7.2 / 3.2GHz Intel i3 / 8GB 1333MHz DDR3
    Parallels 7.0.15050.707095 - and I've recently reinstalled it too.
    Windows XP SP3 on an external SATA drive mounted via a BlacX dual docking station (USB to SATA) running in a Parallels VM as a boot camp partition

    I've run a repair disk check on my Mac HDD after booting to my Install DVD and it found nothing wrong with my Mac hard drive.
    I noticed this error started happening after my system was idle and the screen saver kicked in (not sure if that had anything to do with it), but after investigating and trying to get Windows XP to just boot up after that, I got to the point where Windows XP found the volume dirty and wanted to run Chkdsk on it. This was understandable considering the OS was abruptly shut down (similar to powering off your computer without properly shutting down Windows). It would get to 29% and then pause for a while, then this error would come up.

    I've used the flag as well as tried bumping my CPU down to 1 (as suggested in another thread on a similar topic/error), but that did not fix anything.

    As a last ditch effort to see if maybe the hard drive that holds my Windows XP OS on it was having problems, I booted to the VM using the option to choose the boot device and booted to my Win XP DVD to run recovery console. It would get to the point where I can log into Windows, but it would stop at the same 29% using CHKDSK and then I would get the error again. This is perplexing. It's funny how this error seems to have history and is happening to many users of Parallels 6 and 7. I find it hard to believe that so many hard drives are failing and causing this error. I don't have a solution, but I'd like to find one soon (I hope this is being monitored also by the Parallels team:))

    I'm now currently not able to access my Windows XP OS without getting this error consistently.
     
  3. mmika

    mmika Kilo Poster

    Messages:
    488
    Hello Jammeaze.
    Please obtain problem report ID ( http://kb.parallels.com/en/9058 ) when you get an error message,
    and write its number here.
    Thank you.
     
  4. Jammeaze

    Jammeaze

    Messages:
    9
    Thanks for responding mmika. The report ID I obtained is 11181880. Hope that helps to shed some light on the issue.
     
  5. Jammeaze

    Jammeaze

    Messages:
    9
    Any progress on this issue?
     
  6. bjland4b

    bjland4b

    Messages:
    1
    Er..........YEs I agree this ! I have the same error! I'm getting this same error and it's frustrating.
    On my iMac: running OSX 10.7.2 / 3.2GHz Intel i3 / 8GB 1333MHz DDR3
    Parallels 7.0.15050.707095 - and I've recently reinstalled it too.
    Windows XP SP3 on an external SATA drive mounted via a BlacX dual docking station (USB to SATA) running in a Parallels VM as a boot camp partition
    Thanks!
     
    Last edited by a moderator: Nov 18, 2011
  7. mmika

    mmika Kilo Poster

    Messages:
    488
    I beg your pardon for some delay, but I needed to to think about issue.
    At first sight a problem with your external disk.
    Parallels warns about error after IO access to disk was fail.
    Your kernel log is flooded with
    disk1s1: I/O error
    disk2s1: I/O error
    disk3s1: I/O error

    But may be It was caused by Parallels somehow.

    First of all. Did you tried to start VM with "devices.sfilter.enable=0" flag?
    This can avoid a problem with USB->SATA bridge, that can not handle
    large transfers properly.

    And the second notice.
    You need to reconfigure your VM.
    A bootcamp configuration logic was changed and fixed a bit.
    Just delete virtual hardisks that represents your external disks from VM configuration.
    Press "-" button on selected hardisk within configuration editor's Hardware tab.
    This will not damage any data on your external disk.

    After that add all of your external disks back to VM configuration, by pressing "+" button
    within configuration editor's Hardware tab.

    Start VM again.
    If error will happen, please generate a problem report data again and share its ID.

    Also in terminal window you may run command like
    "sudo dd if=/dev/rdisk2 of=/dev/null bs=128k"
    This will read a whole disk 2.
    This command completes without any error if all data were read successfully.
    You need to unmount any mounted partitions from disk2 before issuing that command.
    Make sure that "of=/dev/null", to prevent any possible damages.

    Thank you.
     
  8. Jammeaze

    Jammeaze

    Messages:
    9
    Still getting the error. I generated report: 11242723

    I have yet to try the terminal command on the bootcamp disks. If I were having read/write issues, wouldn't I get an error when I open it up in Finder and access files that way? Nonetheless, I'll try that and post the results.

    Thanks.
     
    Last edited: Nov 18, 2011
  9. Jammeaze

    Jammeaze

    Messages:
    9
    I'm FIXED! Well, dang, at least further along...

    Ok, I ran the sudo command like you suggested from terminal and to my surprise it came back with a disk i/o error. I dug a little deeper and pulling from my experience in the days of older versions of Windows I thought, ok, since the volume is marked dirty and it's trying to clean it, it probably needs a little help to do that outside of the VM environment, so I looked around for a way to give Mac a way to read and write to NTFS, which is how both of these external drives are formatted. I found a trial program that loads a Mac native NTFS driver that allows you to read/write and even run disk utility to repair the drive... BINGO! Just the help I needed so I could bypass the Windows OS and the VM environment and work solely on the drive file structure.

    The program that I found is here: http://www.paragon-software.com/home/ntfs-mac/features.html. They have a 10 day trial - perfect!

    Once I installed it and restarted, the drives wouldn't mount; however, that wasn't a problem. They showed up in disk utility just fine and allowed me to run repair disk (I ran it on both just to be safe), which worked its magic on my main drive that was having issues. Sorry... don't see an option to insert a screenshot of that...

    After disabling the driver (it gives you that option in the system preferences applet), I restarted my iMac and they showed back up like before. I ensured Hard disk 1, 2, and 3 were pointing to the correct boot camp drives, let Parallels do its background configuration and booted up my Windows XP VM.

    It got me to the login screen of Windows, then the desktop started loading... It got to loading Parallels tools up to 40%... I let that go in the background while I was typing this up thinking I'm good... but ALAS! That error came up again... here's the report ID: 11244766

    I really thought I was back in business... I'm going to run a repair disk on my main drive again to see if there are other areas that maybe corrupted. It's a fairly new drive, so not sure what's going on. In the details of the drive repair there was mention in the section "verifying file security" that it could not read $SDS - not sure if that's a problem.

    I'm going to run another repair nonetheless and see what I come up with.
     
  10. Jammeaze

    Jammeaze

    Messages:
    9
    Ok, it seems to be stable now... here's what I did

    Summary: it appears between the VM files being from the pre-update and the misconfiguration going on and maybe even the addition of the NTFS for Mac drivers, there was some corruption to the point that the VM needed to be reset and freshly configured with the latest Parallels update.


    Major points that helped me fix this:

    1. With the NTFS for Mac drivers enabled, I repaired both external drives so they came back without error.
    2. I turned off the NTFS for Mac drivers and restarted my iMac with the external drives still turned on and plugged in
    3. I removed the WinXP VM and emptied the trash can
    4. I added a new VM from a bootcamp partition (my external drive) and it went through updating the configuration for about 10 minutes or so - waited for that process to finish
    5. It loaded parallel tools differently this time:
    - after it had me log in to Windows XP, it brought up a screen similar to the Lion log in screen to install the parallel tools and continue to configure the boot camp VM without showing my desktop or loading other startup items from Windows (which I think is a much cleaner process).
    6. Once all that was done, I was at the WinXP login screen > login successful
    7. Desktop came up > hard drive sounded healthy with the sounds it makes when searching for data... no errors, was able to bring up Internet explorer and start doing stuff again in Windows XP.

    I'm going to say for this, so far so good... I'll see how it fairs over the next week or so.

    Thanks for steering me in the right direction.
     
  11. mmika

    mmika Kilo Poster

    Messages:
    488
    I'm glad to hear that you were able to boot your Windows successfully.
    It's not clear for me how steps 1-2 might affect to repair process.
    But steps 3-4,5 is similar like I suggested when told about HDD removal and
    adding back. In other words bootcamp VM reconfiguration was needed.

    =) But I suggest to schedule disk checking within windows (on C: drive properties->tools or something like this)... and you can get this error again, if a problem with your disk still persist, but broken sectors had not been accessed yet.
    It's just for sure that problem will not arise later.
     
    Last edited: Nov 19, 2011
  12. YanaYana

    YanaYana

    Messages:
    1,666
    Such errors always indicates I/O errors and to find the reason you need to dig into the hardware on the Mac side - Parallels just shows the problem existence but doesn't cause it.

    We have KB for the similar article - it can be helpful :http://kb.parallels.com/en/112140
     
  13. Jammeaze

    Jammeaze

    Messages:
    9
    It's back...

    Alas, my success was short-lived. I'm getting the error again. I wanted to natively check the hard drive from within the WinXP's startup process to allow chkdsk to do it's 5 stage pass thing, but I keep getting to 29% and it sits for a while, then the error comes up in Parallels. Here's the problem report I've generated while the error was displayed: 11273399.

    I was able to get into Windows prior to that... so now it's stuck in a chkdsk loop in WinXP boot up and the only option I have is to stop the VM at this stage.

    On a side note to address the possible hardware issues with my Mac HDD, I'm running 10.7.2 that I upgraded from the App store, so I've rebooted into the recovery partition (Cmd + R) to run a repair disk on the main hard drive and it has consistently came up with no errors. Are there other utilities that you can steer me to that might help "dig a little deeper" beyond what Disk Utility can provide? I would think Disk Utility is a pretty solid app. I have access to Tech Tools Deluxe from Apple Care and have also run a surface scan on my internal Mac HDD without any incidents. I've even gone as far as thinking there might be a virus reeking havoc on my system somehow, so I ran McAfee full system scan with the latest virus signature updates, but came back clean.

    What else can I try?
     
  14. mmika

    mmika Kilo Poster

    Messages:
    488
    Same error again

    Nov 20 22:36:10: --- last message repeated 2 times ---
    Nov 20 22:36:12 Russ-Ws-iMac kernel[0]: disk1s1: I/O error.

    The problem is not with your main (internal) HDD.
    I suppose your internal HDD has disk0 label.

    You need to check NTFS and make a surface scan on WDC WD10 01FALS-00J7B1 drive.
     
  15. Jammeaze

    Jammeaze

    Messages:
    9
    Surface scan... bad sectors - can't repair though

    I'm still not able to get into my WinXP VM without getting stuck at 29% chkdsk failing with a hard disk I/O error, but I did happen to take advantage of the Windows 8 Developer Preview with SDK (installed that as another VM) and ran the Western Digital hard drive diagnostic program (extended test) they offer for my drive for 11 or so hours.

    I did this a couple times because it showed there are some bad sectors that it "may" be able to repair, but wouldn't ya know it, when I click repair soon after that, it came back saying there was an error in repairing... and leaves me right back where I started - dead in the water.

    Incidentally, with the NTFS driver for Mac that I have, I'm able to run repair disk on the drive as well and come back with this report from disk utility:

    Verify and Repair volume WD1TB
    Checking file systemChecking Volume /dev/disk1s1...
    Type of the filesystem is NTFS.
    Volume label is: WD1TB
    Verifying 339856 records ...
    Verifying Zu folders ...
    Verifying files security...
    Can't read $SDS
    $UpCase file is formatted for use in Windows NT/2K/XP
    388.64 GB in 302521 files
    118312 KB in 33534 directories
    4 KB in bad blocks in 1 fragments
    547300 KB in use by the system
    65536 KB occupied by the log file
    4096 bytes in each allocation unit
    244187992 total allocation units on volume
    136423381 allocation units available on volume
    The volume /dev/disk1s1 has been repaired successfully.
    Volume repair complete.Updating boot support partitions for the volume as required.

    I have a feeling (though can't be 100% certain) the $SDS that disk utility can't read and the 4KB bad block may be inter-related. I don't quite understand what the $SDS pertains to outside of security for NTFS, but I suspect that's the reason the disk utility can't read it and also why the repair from Western Digital is failing.

    I think I will probably need to write zeros to the drive, but dread the time that I know this is going to take to get back up and running - let alone the added cost to get another hard drive or something to back my stuff up first! The drive is still under warranty, so that's a saving grace I guess. I just don't want to have to set things up again. It's a pain in the assets:)

    Can't think of a better way to spend my time off from work (*sarcastic glance*) this coming holiday season.

    Anywho, thanks for your input and taking the time to help me come to this point.
     
  16. mmika

    mmika Kilo Poster

    Messages:
    488
    I suggest to find a native windows machine or true bootcamp and check your disk from there.
    And may be to disable NTFS driver for MAC after that...
     
  17. Jammeaze

    Jammeaze

    Messages:
    9
    It's been a while, but getting same error again in different VM/hard drive this time

    Ok, I've spent much time trying to get my Win XP drive cleaned up; so much so that I decided to purchase Windows 7 Pro to install into a VM through Parallels. All that went well for a little bit until today. I captured the report and here is the number: 11533516

    Please investigate this further! This is frustrating to say the least.
     
  18. YanaYana

    YanaYana

    Messages:
    1,666
    Guys,

    I was telling you this error is not connected with Virtual Machine files, Windows OS of whatever.
    It shows your Mac HD may be dying - please keep it serious and check your HD with Apple technical specialist - mention this I/O erre message you see.
    You has new Windows running fine until it's files were finally affected by corrupted Mac OS system as all Windows files ae actually stored on Mac HD - so, one more time - check your Mac HD in order to prevent data loss
     
  19. pallabp

    pallabp

    Messages:
    5

Share This Page