Error: PRL_ERR_DISK_INVALID_BLOCKSIZE (0x80021009)

Discussion in 'Installation and Configuration' started by ViktorR, Dec 14, 2017.

  1. ViktorR

    ViktorR Bit Poster

    Messages:
    10
    Hi,

    I have installed second sata ssd and then installed windos 10 on it. Now I'd like to add it to the parallels and parallels found it said it is bootcamp, started to add it via "Instsllation Assistant", then gave me the following message:
    Error: PRL_ERR_DISK_INVALID_BLOCKSIZE (0x80021009)
    Path: '/Users/viktor/Parallels/My Boot Camp.pvm/M4-CT512M4SSD2 (disk2).hdd'

    Anyone have an idea what could it mean? Please help.

    viktor@Viks-iMac:~ $ sudo diskutil list
    Password:
    /dev/disk0 (internal):
    #: TYPE NAME SIZE IDENTIFIER
    0: GUID_partition_scheme 1.0 TB disk0
    1: EFI EFI 209.7 MB disk0s1
    2: Apple_APFS Container disk1 1.0 TB disk0s2

    /dev/disk1 (synthesized):
    #: TYPE NAME SIZE IDENTIFIER
    0: APFS Container Scheme - +1.0 TB disk1
    Physical Store disk0s2
    1: APFS Volume Mac HD 138.0 GB disk1s1
    2: APFS Volume Preboot 21.8 MB disk1s2
    3: APFS Volume Recovery 506.6 MB disk1s3
    4: APFS Volume VM 20.5 KB disk1s4

    /dev/disk2 (internal, physical):
    #: TYPE NAME SIZE IDENTIFIER
    0: FDisk_partition_scheme *512.1 GB disk2
    1: Windows_NTFS System Reserved 524.3 MB disk2s1
    2: Windows_NTFS Win10 511.1 GB disk2s2
    3: 0x27 490.7 MB disk2s3

     
  2. Meenakshi@Parallels

    Meenakshi@Parallels Kilo Poster

    Messages:
    450
    Hello ViktorR, please remove the existing Bootcamp based virtual machine by following this article and go to Disk Utility and run the first aid. Then add the virtual machine by following as suggested in this article and see if this works. Thanks!
     
  3. ViktorR

    ViktorR Bit Poster

    Messages:
    10
    I cannot run "First Aid" on the both windos drives because it's grayed in the Disk Utility. Although, I ran it on the system "Mac HD" drive, dunno how could it help. It completed without errors and parallels "Use windows from bootcamp" still gives me the same error:
    Error: PRL_ERR_DISK_INVALID_BLOCKSIZE (0x80021009)

    Path: '/Users/viktor/Parallels/My Boot Camp.pvm/M4-CT512M4SSD2 (disk2).hdd'
    But there's everything ok with the ntfs partitions, no need to fsck them, I just booted win and did a clean shutdown, they also were mounted by paragon ntfs driver and I did try to create with paragon enabled and without it, as well as with both mounted and not mounted partitions - the result is the same. It's windos 10 x64, if it's important... With all latest updates installed.
    Please help...
     
  4. Meenakshi@Parallels

    Meenakshi@Parallels Kilo Poster

    Messages:
    450
    Please let us know the version of Mac OS X running on your Mac (Apple icon -> About This Mac) and the version of Parallels Desktop (see http://bit.ly/1mE3Gpf for assistance) installed on your machine.Thanks!
     
  5. ViktorR

    ViktorR Bit Poster

    Messages:
    10
    I have the latest versions with all updates installed, parallels got updated a few hours ago - macOS 10.13.2 darvin kernel 17.3.0 and Parallels Version 13.2.0 (43213). I installed windos using msdn installation disk with all default settings - just pressed "install windows" onto the empty drive.
    I'll reboot to Win and will send ssd and fs parameters in a coupe of minutes, maybe it could help
     
  6. ViktorR

    ViktorR Bit Poster

    Messages:
    10
    Here it is:

    C:\>fsutil fsinfo volumeinfo c:
    Volume Name : Win10
    Volume Serial Number : 0xecf59dee
    Max Component Length : 255
    File System Name : NTFS
    Is ReadWrite
    Supports Case-sensitive filenames
    Preserves Case of filenames
    Supports Unicode in filenames
    Preserves & Enforces ACL's
    Supports file-based Compression
    Supports Disk Quotas
    Supports Sparse files
    Supports Reparse Points
    Returns Handle Close Result Information
    Supports POSIX-style Unlink and Rename
    Supports Object Identifiers
    Supports Encrypted File System
    Supports Named Streams
    Supports Transactions
    Supports Hard Links
    Supports Extended Attributes
    Supports Open By FileID
    Supports USN Journal


    C:\>fsutil fsinfo sectorinfo c:
    LogicalBytesPerSector : 512
    PhysicalBytesPerSectorForAtomicity : 512
    PhysicalBytesPerSectorForPerformance : 512
    FileSystemEffectivePhysicalBytesPerSectorForAtomicity : 512
    Device Alignment : Aligned (0x000)
    Partition alignment on device : Aligned (0x000)
    No Seek Penalty
    Trim Supported
    Not DAX capable
    C:\>fsutil fsinfo ntfsinfo c:
    NTFS Volume Serial Number : 0x28ecf5d6ecf59dee
    NTFS Version : 3.1
    LFS Version : 2.0
    Number Sectors : 0x000000003b7fb498
    Total Clusters : 0x00000000076ff693
    Free Clusters : 0x000000000673ac04
    Total Reserved : 0x000000000000113d
    Bytes Per Sector : 512
    Bytes Per Physical Sector : 512
    Bytes Per Cluster : 4096
    Bytes Per FileRecord Segment : 1024
    Clusters Per FileRecord Segment : 0
    Mft Valid Data Length : 0x000000000f580000
    Mft Start Lcn : 0x00000000000c0000
    Mft2 Start Lcn : 0x0000000000000002
    Mft Zone Start : 0x0000000000ce7c80
    Mft Zone End : 0x0000000000cf1e80
    Max Device Trim Extent Count : 512
    Max Device Trim Byte Count : 0xffffffff
    Max Volume Trim Extent Count : 62
    Max Volume Trim Byte Count : 0x40000000
    Resource Manager Identifier : C19D33FE-E151-11E7-B44C-B3B140152622
     
  7. ViktorR

    ViktorR Bit Poster

    Messages:
    10
    Here's the log file
     

    Attached Files:

  8. FabioB1

    FabioB1

    Messages:
    1
    Hello,
    Did you get solution for this ? I have the same setup with Windows 7 and it does not work. Same error.
    Parallels has definitely a problem with that and they should try to help people to solve it !
     
  9. ViktorR

    ViktorR Bit Poster

    Messages:
    10
    No solution yet
     
  10. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi @FabioB1, can you please send us a problem report collected right after the error and a splash screen (Help menu > Send Technical Data...)? This will help us significantly, please reply me back with the report ID number.
     
  11. ViktorR

    ViktorR Bit Poster

    Messages:
    10
    Why, I sent you these data 1.5 month ago but still have no answer. I've got 3 or 4 licenses, I am your customer for about 5 years, why don't you fix that, I wonder?
     
  12. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    526
    Hi @ViktorR, I am truly sorry for the delay in the investigation. Can you please tell me if your Boot Camp installation was performed via Apple's Boot Camp assistant, or by using a 3rd-party tool?
     
  13. ChristianP8

    ChristianP8 Bit Poster

    Messages:
    1
    Hi I have the same issue and in both cases (see the beginning of the post) the Windows installation is done on an external drive, so to answer your question I think we use bootcamp assistant for the drivers, but the installation is different than the one using bootcamp for the complete installation.
    Thank you in advance for a solution to this issue.
     
  14. ArthurC3

    ArthurC3 Bit Poster

    Messages:
    2
    Hello
    I have the same issue and in both cases (see the beginning of the post) the Windows installation is done on an external drive.
    Thank you in advance for a solution to this issue.
     
  15. ViktorR

    ViktorR Bit Poster

    Messages:
    10
    Dunno how, but now it's working. I left all my attempts to install 4.5 months ago, but a few weeks ago I suddenly found 1tb ssd drive in the desk drawer and installed it. Then installed windows 10 on it and after reboot to macOs, parallels found this installation, installed itself there (tools and so on) and now it works!I am able either to boot windows10 or to use it as a parallels vm. Amazing! ;) No, really, it's cool. The only problem now is that my drive is ntfs-formatted and when windows is running in the parallels vm, I cannot mount drive as a drive, only as a Parallels shared. Will be really nice to have an option for parallels to automount such a drive with the predefined configurable path, so the relative path will remain the same (to /Volumes directory) and all apps relying to the data on the windows ntfs drive would work.
    Have no idea what was the reason, why it works now. Maybe some high sierra updates or parallels update or the new ssd.
    My current versions are:
    Parallels Version 13.3.0 (43321)
    macOS High Sierra Version 10.13.4 (17E199)
     
  16. HALACs

    HALACs Bit Poster

    Messages:
    1
    HEllo, I am trying to enjoy support from Parallels team... here is the message I got when trying to launch my win10 VM. Just back from 10 days holidays, no new SW installed, only the last update available from Apple for 10.13.4... and got the message :
    PRL_ERR_DISK_READ_FAILED (80021029), errno=35 (Resource temporarily unavailable)
    Could you please help ?
     
  17. ArthurC3

    ArthurC3 Bit Poster

    Messages:
    2

Share This Page