Error when trying to print in Version 5.0 (Build 247)

Discussion in 'Parallels Remote Application Server' started by mkaishar, May 2, 2007.

  1. nixu

    nixu Guest

    Hi Guys,

    For those that have the following error "PDF: connection to IpiPDFDocument3 failed", try to uninstall the 2X Terminal Server Agent and reinstall it.

    Please keep me updated if you mange to solve the issue.

  2. mj23449

    mj23449 Guest

    I've tried this morning uninstalling and reinstalling several times via several different methods and nothing works. If I run the installer directly on the terminal services server and install the agent, when I try to print it tells me that its unable to print due to the PDF Universal Printer printer agent not being installed, please reboot or re-install. The publishing/gateway server also says there is no agent installed. The agent service is running and the application does show up in add/remove programs. However if I install the agent from the 2x console, the console says the agent is running, but the program does not show up in add/remove programs. When I try to print I get the same error message as before "PDF: connection to IpiPDFDocument3 failed". Also when I install directly from the terminal services server it puts the 2x files in "Program Files (x86)". When I install from the 2x console it put the 2x files in "Program Files". Its as if, one way the 32bit agent gets installed on the 64bit server, but another way the 64bit agent gets installed. Heres my setup again:

    2x Publishing/Gateway/Loadbalance Server: Windows Server 2003 R2 32bit /w SP2
    2x Terminal Services Agents: Windows Server 2003 R2 64bit /w SP2
    2x Clients: Windows XP 32bit /w SP2

    Using the following Appserver version:
    2x Application Server v5.0 build 261
    2x Application Clients v5.0 build 261

    All clients also have Adobe Reader v8 or v8.1 installed if this even matters. Thanks in advance for all the help!!!!!
  3. mj23449

    mj23449 Guest

    Also, now one of my 3 terminal services servers no matter how many times I reboot the server or uninstall and reinstall the 2x agent I get the following error when trying to print:

    "2x Universal PDF Printer printer agent is not installed. Please reboot or reinstall the application."

    What can I do to fix this problem? I don't want to blow away the server and have to reinstall everything. Both problems definitely seem to be from trying to install to a 64bit Windows server???????????? I'm going to test this theory by installing the agent to a 32bit Term Server this afternoon. If my theory is correct then universal printing should work just fine on a 32bit OS Server.

    Update: Just as I thought, when I install the agent on a 32bit Server OS and launch my applications and try to print, then the universal printing functionality works perfect. The only explanation can be that the 2x terminal services agent and Universal Printer agent still has bugs on Windows Server 2003 x64.
  4. nixu

    nixu Guest

    Hi mj23449

    When you get the error "PDF: connection to IpiPDFDocument3 failed", can you please do the following:

    Open a command prompt
    run regsvr32.exe "C:\Program Files\2X\ApplicationServer\VirtualPrinter\x64\PDFCreatorPilot3.dll"

    Change the x64 to x32 if you are using a 32 bit machine.

    This should solve your problem.

    Please keep us updated.

  5. mj23449

    mj23449 Guest

    Thank you Nixu!!!

    On the 64bit servers that have the following error:

    "PDF: connection to IpiPDFDocument3 failed"

    Your above solution works perfectly. I'm now able to print successfully!

    Any ideas to how I can fix the issue of the server saying the Universal PDF Printer printer agent is not installed on my one 64bit server. Thanks again for the help. Now I have at least 2 of my 3 terminal services servers working perfectly.
  6. Anonymous

    Anonymous Guest

    Universal Printer problem

    Hi nixu
    I have got the same problem as mj23449 in the 64 bits terminal server, I have exactly the same configuration.
    What should we do ???
    Do You have any solutions in sight because this would help me a lot if this could work
  7. nixu

    nixu Guest

    Could you please confirm that when a user logs on the following processes are running:

    2xPrnAgent.exe & 2XPrinterRedirector.exe

    Also could you confirm the paths of the following registry keys:
    Server\AddIns\2X Virtual Printer Redirector]

    and this:


  8. Anonymous

    Anonymous Guest

    Hi Nixu,

    Thats correct they are missing.

    Do I have to reinstall ?
    I is their a other solution
  9. Anonymous

    Anonymous Guest

    Sorry the registry keys are their I looked at the wrong server,
    Il will try to restart the server to se if that helps
  10. nixu

    nixu Guest

    Can you confirm that the path set in the StartupPrograms is correct...
    eg c:\\Program Files\\2X\\ApplicationServer\\VirtualPrinter\\2XPrinterRedirector.exe
  11. Anonymous

    Anonymous Guest

    Hi Nixu

    Now I got the process as You described above.
    But now I get following error message "cannot find converter executable"
  12. Anonymous

    Anonymous Guest

    We got the following path.
    C:\Program Files (x86)\2X\ApplicationServer\VirtualPrinter\2XPrinterRedirector.exe
  13. mj23449

    mj23449 Guest

    I looked on the server that kept giving me the following error:

    "The Universal PDF Printer printer agent is not installed"

    The registry entries that you mentioned were missing. I manually added the entries back in and registered the dll you mentioned in a previous post as well, rebooted the server and I am now able to print successfully. All 3 of my terminal services servers are now functioning correctly and perform as expected. Thank you alot for all the help. It is greatly appreciated :D
  14. Anonymous

    Anonymous Guest

    Hi mj23449

    If I understand this right you have got the Universalprinterdriver to work on a 64bit Windows.

    What nice :)
    When I try to print it just disappear from the queue and nothing happens
    or the print job stays in the print queue as status printed and does not disappear.
    Did you reinstall the 2x agent and printerdriver ?
  15. mj23449

    mj23449 Guest

    Hi jorwie,
    How did you install the terminal services agent? I found that the only way I could get printing to work was when I used the 2x console to install the terminal services agent and not directly running the executable on the server. I also had to add in the registry entries that nixu mentioned in a previous post and manually register the .dll file that he also mentions in a previous post. Make sure when you register the .dll file that you register the 64bit one and not the 32bit one. If the 2x terminal services agent is installed correctly, everything should be installed under Program files and not Program Files (x86). I would uninstall what you have and reinstall via the 2x console. Keep me posted and I will try to help you out as much as possible.
  16. francorg

    francorg Guest

    I had the error: "PDF: Connection to IPiPDFDocument3 Failed"
    then I launched on the server (win2003 x64) the following command:
    regsvr32.exe "C:\Program Files (x86)\2X\ApplicationServer\VirtualPrinter\x64\PDFCreatorPilot3.dll"
    Now it doesn't show the error but it doesn't print...
    but if I check on the server event viewer it states that the document has been correctly printed... "Document 12, schecli.wrm owned by administrator was printed on 2X Universal PDF Printer via port XX. Size in bytes: 181072; pages printed: 1"

    Any help appreciated.

    Thank you
  17. nixu

    nixu Guest

  18. spjohnson

    spjohnson Guest

    This new beta release fixes all of my printing issues. I no longer have the problem where the print job appears to go through on the server but nothing happens on the client. I am now able to print just fine.

  19. jstefani

    jstefani Guest

    Works for me now too

    The new beta works for me now too on 32-bit Windows 2003 R2. I haven't tried it on the 64-bit version of R2 yet.
  20. francorg

    francorg Guest

    To install a beta version over the release, do I have to uninstall first or it is possible to do an "in place upgrade"?

    Does beta have some sort of limitations?

    Thank you,

Share This Page