External Windows Keyboard, Change Alt and Windows Key Back to Windows Configuration

Discussion in 'Windows Guest OS Discussion' started by TimothyL, Mar 9, 2012.

  1. TimothyL

    TimothyL

    Messages:
    5
    Hi all

    Platform:
    Lion on MBA
    Windows 7 on Parallels as Guest

    Issue:
    Plugged in an external keyboard: Microsoft Ergonomic 4000.
    When running in Windows applications and in coherence or non-coherence, the 2 keys I want to be themselves (i.e. Alt = Alt on the label) are remapped to Mac commands.

    So my Windows key has become Alt.
    My Alt key has become Command.
    My right Alt key doesn't appear to have a function.

    I would like the Alt key to just stay as Alt and the Windows key to stay as Windows.
    I would also like the right Alt key to actually just be the right Alt key.

    Attempted solutions:
    1. Uninstall the Intellipoint driver based on Mac: didn't work, keys still remapped.
    2. Tried to configure the keymap settings on both Mac and Guest-Windows and there's no option to set these keys to what their normal Windows functions are.

    Thanks.
     
  2. rdlsmith

    rdlsmith Bit Poster

    Messages:
    14
    Change the Windows Selected Keyboard

    I submitted a support request for a similar if not the same issue. Maybe their response will help you too.

    - Go to Start->Computer->Control Panel->Region and Language
    - Switch to the 'Keyboards and Languages' tab, click on 'Change keyboards..'
    - Add 'English(United States)'->'US' keyboard (by default you should have 'United Stated (Apple) - Parallels'), click Apply
    - Switch to the US keyboard layout
     
  3. WilliamPaul

    WilliamPaul

    Messages:
    45
    I too have the same problem and overcome it. This really worked for me.


    __________________
    Macbook Pro 17 2.8Ghz; Host OS: Snow Leopard 10.6.2, 32-bit;Guest OS: Windows 7 Ultimate x64... Proud [​IMG]
     
  4. Seannn

    Seannn

    Messages:
    2
    Hello, I have Parallels 8 and the Microsoft Ergonomic Keyboard 7000 and I wanted to do this exact same thing. First, to disable an "auto keyboard" feature that is new with Parallels 8 I followed the steps posted here. Then I tried your solution with high hopes. Unfortunately, nothing happened. I even went as far as removing the 'United States (Apple)' keyboard in the Windows Keyboard settings. (Mine had 'US (Apple)' activated and selected, not 'US (Apple) - Parallels', which was on the list.) Alt key still acts like Win key, Win key still acts like Alt. Also, the Context Menu key has never done anything.

    I am going to try something involving Input Sources that is covered in the Parallels 8 user's guide, p. 83. I am not trying to change input languages, but I noticed there is a 'US International - PC' option available.

    Hopefully, I'm not messing up my configuration up beyond recognition. I will update this thread if I figure anything out, but if somebody else has some knowledge, it would be much appreciated.
     
  5. Seannn

    Seannn

    Messages:
    2
    Okay, I think I got this pretty much set up how I want it. FYI, for me, when I am in Mac OS X, I like the following mappings because the resulting layout matches the Mac keyboard: Alt -> Command, Windows key -> Alt/Option. But when I am in Windows, I want my keyboard to behave just as if I were on a PC.

    Part of this solution is specific to the Microsoft Ergonomic 7000 Keyboard. That may make some of this info irrelevant to people who have other keyboards because the 7000 has software that can be installed on a Mac, which is actually pretty nice. But the other stuff might help guide you nonetheless. If you're keyboard is just being used generically (i.e. Alt -> alt/option and Win key -> Command), then skipping right to the next step might work just fine for you.

    These are the other pieces of my setup: MBP with Retina, OS X 10.8.3, Parallels 8, and Windows 7 (Ultimate) imported from Boot Camp.

    So here goes. I have the software for the 7000 installed which I had to download. It's called IntelliType Pro (version 8.2.0). Once it's installed it integrates into the System Preferences in the "Other" section. Open it. You see the "Global Settings" profile is selected. I don't remember what the default options were, but click Options, and make sure 'Swap Windows and Alt keys' and 'Reassign application key' (the context menu key) are checked. Now I've got my Mac keyboard layout.
    Note: there is also a 'Swap Control and Caps Lock keys' option, but I honestly have no idea why you would want that checked.​

    Now, for setting up Parallels.

    Still in the IntelliType Pro settings, we need a separate profile for Parallels. Click 'Add' near the top, and find Parallels Desktop to create a new profile for it. Click the Options tab and clear those two checkboxes.
    Note about this: This will affect all of Paralllels Desktop, even when you're not "in" a VM. But when it's all said n done, being in Parallels probably means being in Windows. The minor drawback is that Parallels Desktop doesn't act like a regular OS X app in regards to keyboard shortcuts.​

    Next, in the Parallels Desktop Preferences, click the Keyboard tab.
    In 'System Shortcuts', change the 'Send system shortcuts' setting to Always.
    Explanation: This may not be necessary for everybody but if you use certain keys or shortcuts, Parallels might interpret that press as an OS X command, when you wanted it to be sent to and interpreted by Windows. For example, an app I use in Windows uses F12, which Parallels interprets to 'Show me the Dashboard'. This also has the drawback that you won't be able to 'Alt/Command Tab' out of Windows to OS X apps. I found a way to deal with this by using the Parallels Application shortcut (which is listed in the 'Application Shortcuts' section), Command + H. When you're in Windows, even in full screen mode, this will hide Windows and put you on whatever the last OSX app was that you were using. Then, to get back to Windows via the keyboard, you just Alt/Command + Tab back to Parallels Desktop (not a specific Windows app. That doesn't work, perhaps because we used Hide).​

    Still in Parallels Keyboard Preferences, click the particular VM that you're trying to "fix". Click in the Profile drop-down and click 'Edit profile list...'. Select the Windows profile, click the gear icon, and click Duplicate. Select the new 'Windows 1' profile as the profile for your Windows VM. Clear all the checkboxes for the key mappings "from Mac OS X to Windows".

    The next two steps had already been done when I had my "viola, it works" moment. However, I'm pretty sure they are necessary for it to work.

    We need to make one more Parallels config change to turn off an "auto keyboard swapping" "feature", but it's not available in the Preferences menu. Don't worry, it's pretty quick. Follow these instructions, which I found here:

    Now, boot up your Windows VM. And follow rdlsmith's instructions which are posted above.


    That's it. Hope that helps some people.
     
  6. BradBamford

    BradBamford

    Messages:
    2
    This ^^^ is brilliant. Thanks!
    Only issue now if trying to get copy and paste working again between osx and windows.
     
  7. Heo_Luoi

    Heo_Luoi Bit Poster

    Messages:
    1
    It works for me!
     
  8. easy4tutoring

    easy4tutoring Bit Poster

    Messages:
    7
    Hi, I have Parallels 8 and the Microsoft Ergonomic Keyboard 7000 and I needed to do this literally the same thing. To begin with, to handicap an "auto console" emphasize that is new with Parallels 8 I took after the steps posted here. At that point I attempted your answer with high trusts. Lamentably, nothing happened. I even went the extent that evacuating the 'United States (Apple)' console in the Windows Keyboard settings. (Mine had 'US (Apple)' initiated and chose, not 'US (Apple) - Parallels', which was on the rundown.) Alt key still acts like Win key, Win key still acts like Alt. Additionally, the Context Menu key has never done anything.

    I am going to have a go at something including Input Sources that is secured in the Parallels 8 client's aide, p. 83. I am not attempting to change data dialects, yet I perceived there is a 'US International - PC' alternative accessible.

    Assuredly, I'm not derailing my arrangement up to the point of being indistinguishable. I will overhaul this string in the event that I make sense of anything, however in the event that another person has some learning, it would be highly increased in value.
     
  9. SusanH1

    SusanH1 Bit Poster

    Messages:
    1
    I have windows 8.1 and this worked for me. Go to SETTINGS, then click on the ICON at the bottom right which says on my computer Eng (New Zealand) United States International Settings, and then choose Eng (New Zealand) US Settings. There is a solution above which does the same thing, but it might have been a different operating system as the suggested path came to a dead end when I tried it.
     

Share This Page