Extremely Slow

Discussion in 'Installation and Configuration' started by EricG12, Nov 18, 2020.

Tags:
  1. EricG12

    EricG12 Bit Poster

    Messages:
    2
    I've installed Parallels about a month ago and it is just so slow, to the point where it's unusable. How can I fix this ASAP as I need it for my thesis. And I don't want a generic answer.
    Feel like this was a huge waste of money.
     
  2. EricG12

    EricG12 Bit Poster

    Messages:
    2
    I've even tried allocated 8GB of Ram to the VM and it did nothing.
     
  3. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,670
    Hello, did you check it with 2GB?
     
  4. ParshantS

    ParshantS Bit Poster

    Messages:
    6
    I have the same issue. Can hardly use Windows and it almost freezes MacOS too.
     
  5. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,670
    Hello, how much CPU did you give to your Windows VM?
     
  6. ParshantS

    ParshantS Bit Poster

    Messages:
    6
    I have assigned 4 CPU and 8G RAM.
    My laptop configuration is
    2,8 GHz Quad-Core Intel Core i7
    16 GB 2133 MHz LPDDR3
     
  7. TheodK

    TheodK Bit Poster

    Messages:
    28
    Hello ParsantS end EricG,
    I recovered most of speed of the Windows VM by doing two things:
    1. I don not use Microsoft Teams or Skype (for Business) anymore. This halts and sometimes crashes my Windows VM's. This is an unresolved issue. I now use the OSX apps for Microsoft Teams or Skype (for Business) instead although they will not work together with other Windows apps.
    2. I fully disabled Microsoft Store and its apps. This is a Microsoft issue. It tends to use at least 50% of the CPU for quite some time every day for background updates and other activity. Combined with other software like PowerPoint, Outlook, Excel, Word, etc. Windows will eventually slow down to a crawl. Changing RAM or number of CPU cores does not help.
    If you don't use Store apps at all, then do this:
    • Click the Windows Start button and type gpedit.msc.
    • Right-click this program and run as the administrator (password might be required).
    • Now go to Computer Configuration -> Administrative Templates -> Windows Components -> Store and activate "Turn off the Store application" and also activate "Turn off all applications from the Store".
    • Close the Group Policy Editor and restart Windows.
    If you don't see any progress, then turn everything back to ""Not configured" and restart Windows.
    Theo
     

Share This Page