Fail to build kernel modules on Linux kernel v4.15+

Discussion in 'Linux Guest OS Discussion' started by LegendT, Feb 8, 2018.

Tags:
  1. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    123
    Sure enough:
    1. Made the code changes in /usr/src/parallels-tools-13.3.0.43321/prl_fs_freeze/Snapshot/Guest/Linux/prl_freeze/prl_fs_freeze.c
    2. Gzipped a new prl_mods.tar.gz
    3. Carefully updated to kernel 4.16.7 (so as not to lose the grub entry for 4.14.x)
    4. Rebooted into 4.16.7 and it works.
    I cannot believe that for a few short lines of workaround code, we've not had a Tools update to fix this since February 21st... exactly 3 months ago.
    #AbjectFail
     
  2. rlhamil

    rlhamil Bit Poster

    Messages:
    9
    Just did this after upgrading the distro to 18.04 LTS (kernel 4.15.0-22-lowlatency, e.g. Ubuntu Studio) and it worked great.
    Thanks to the poster that supplied the workaround!
    Parallels, now that someone did your research for you (or most of it - how to get the module built despite the license issue is yours to solve, I gather, although this can't be the first case where that came up), I really see little excuse for further delay.
     
  3. Sathiya@Parallels

    Sathiya@Parallels Staff Member

    Messages:
    710
    Best Answer
    Hi Everyone,
    Parallels Desktop 13 for Mac Update 3 Hotfix 1 (13.3.1-43365) is released and it supports Ubuntu 18.04. Use this direct link to download and install the latest build.
     
    HakanK2 likes this.
  4. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    123
    What a coincidence...
     
  5. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    123
    Given the kernel fix I attempted to try an upgrade from Fedora 26 to 27. All packages downloaded, and installs began without a hitch after rebooting.
    However, because of hotfixing the install re-rebooted somewhere around package 575 of 2730: after several critical packages were updated, and before 4.16.9-200 kernel was fully installed. The re-reboot gets to a point where the incompatibilities fail (ABRT, etc.), finally waiting for a Parallels Tools reinstall that either fails or never occurs.
    As a result, there's no way to Cmd-F2 into anything to fix it, and I've just wasted 2.7GB downloading a failed install.

    Yes, before a mod says it, Fedora 27 is not yet supported in Parallels Tools 13.3.1.
    I know this. Just putting it out as a warning to anyone else that tries that you may be wasting your time, even though 26 will be EOL soon (if not already), and 28 was released on 1 May. Note that Fedora only currently supports 27 and 28, as stated on their release schedule.
    Given that Fedora releases are every May and Oct, this is now an untenable situation trying to keep up with Parallels.
     
    Last edited: May 25, 2018
  6. LegendT

    LegendT Bit Poster

    Messages:
    5
  7. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    123
    Was unable to upgrade F26 using dnf system-update or doing a direct update using the packages downloaded from that using dnf or rpm. Each time it create a kernel oops at some random mid-point during the package loading phase. Although, I did manage to get near package# 1450 of 2610 once.

    Gave up that process and tried a Fedora 28 LiveCD clean install, which worked. After getting the root password changed was also able to install Parallels Tools (on kernel 4.16.11-300), get internet working, and update the minimally installed baseline. Now just have to go through the suboptimal process of moving settings/data over, and install packages and repositories for apps I had been updating since F21. #joy
     
  8. SiNaPsE

    SiNaPsE Bit Poster

    Messages:
    3
    with 4.17 kernel and parallels 13.3.1 not work anymore :(
     
  9. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    123
    Just DNF'd to 4.17.11 using Parallels 13.3.2 (43368) with no issues.
     

Share This Page