Failed to allocate specified amount of memory

Discussion in 'Windows Guest OS Discussion' started by wellesgoodrich@mac.com, Jul 8, 2007.

  1. (I posted this message in the wrong forum already so I'm reposting it here as it is a Mac question.)

    When I try to launch Windows XP Pro via Parallels Desktop 3.0 (build 4128) on a Mac Pro 266, 4GB RAM, 4 internal HDs, NVIDIA GeForce 7300 GT I get the following error message...

    "Parallels Desktop failed to allocate the specified amount of memory.
    Please restart Parallels Desktop and try again.
    To avoid this problem in the future choose from the menu: Parallels Desktop > Preferences. On the Memory tab select the "Enable virtual memory preallocation" option."

    This error just started for no apparent reason. If I restart my computer Windows launches and runs just fine (except for the failure when dragging single files from Windows to the Mac desktop.) I believe it is the case that this failure to launch occurs after my computer is put in sleep mode and then 'awaken.'

    Has anyone else seen this issue? Should my next troubleshooting step be a reinstall of Parallels? Thanks for any advice.
     
  2. Ankou

    Ankou Guest

    Hello wellesgoodrich
    What amount of RAM are you trying to allocate to your VM?
     
  3. Hi Ankou,

    I have the Main memory allocation set to 1500MB, the maximum recommended in the Configuration Editor. In the preferences memory window, Adjust memory limit Automatically is selected and Enable virtual memory preallocation is checked.
     
  4. Ankou

    Ankou Guest

    Thank you for for the information.
    We are aware of this problem in current version of Parallels Desktop and there is update coming soon that should solve this issue.
     
  5. Thank you for the information. I'm rather relieved that it isn't just my computer.
     
  6. jwendolo

    jwendolo

    Messages:
    2
    Memory error may be disk

    I was getting this error too. In my case the disk partition where the VM file was stored was almost out of space. I freed up some space and the problem was solved
     
  7. drewfreyman

    drewfreyman

    Messages:
    3
    Solving Sudden Occurrence of Failure to Allocate Memory Problem

    After a lot of grief I think I have the solution to this problem. At least this method worked for me:
    1. Reinstall OS X from the original install disks being sure to choose the "archive" type of reinstallation.
    2. Reboot.
    3. Try Parallels. If the error message comes up again, try uninstalling Parallels, restarting OS X, and reinstalling Parallels. Reboot.

    At least in my case, the root cause of the problem seemed to be a software update from Apple to OS X on 7/4/07. So, I needed to roll back the updates. I called Apple and the phone rep described the method above.
     
    Last edited: Jul 16, 2007
  8. Thanks for that tip, drewfreyman. My Parallels 3.0 won't even let me launch Windows at all any more. Unfortuately, an archive and install just isn't a desirable solution for me as I have such a complicated system with some 200 licensed applications and everything is working on OS 10.4.10 except Parallels. I'll wait for a new build to be released, I guess. In the meantime, I'm giving Fusion a try. It works well but I do prefer Coherence over Unity.
     
  9. drewfreyman

    drewfreyman

    Messages:
    3
    Ability to Preserve State of OS X on Re-install

    Believe it or not, this method of re-installation PRESERVED all my apps, settings, etc. from the current OS X. Even my wallpaper. The only thing that it didn't seem to preserve was the password to my home wLAN. Also, it preserves the "previous" OS X configuration, completely, in a new multi folder (its big--like 20GB) on your drive. I believe there is a method to re-instate from this folder if you don't like the re-install. It could be risk free for you to try. This might work out for you after all...
     
  10. tshealy

    tshealy

    Messages:
    2
    ETA for Fix?

    I am experiencing the same problem. Can anyone provide an explanation of why the issue occurs? Also, would it be possible to get a rough ETA for the fix (beta or production-ready).

    Thanks.
    -Tom
     
  11. emgould

    emgould

    Messages:
    1
    ETA ON Fix PLEASE

    I was working fine and then I installed quicktime, audio and iTunes update and then installed the new parallels 3.0 version and now I can no longer run parallels. I get the same error message about failure to allocate memory. HELP PLEASE!
     
  12. zumwalt

    zumwalt

    Messages:
    27
    Just reboot. This is because Parallels is not releasing the allocated memory when it quits. I ran across this problem also, and its pretty consistant. Easiest fix is just to reboot.
     
  13. Hi zumwalt,

    In my case rebooting worked for a while and then ceased to work. I'm presently completely unable to use Parallels 3.0 at all, including multiple reinstallations, trying to use a backup Windows image which was working when it was cloned to archive, upgrading to the latest version with a new install etc. I've spent more time trying to get Parallels to work than I really have time to spare so I've purchased VMware's Fusion. It works.

    I've beta tested a lot of software over the last ten years, including some Adobe products, and Parallels distinctly acts like a beta version to me. I didn't buy it and then purchase the upgrade to be a beta tester. I'm a little annoyed and yet I believe the engineers are doing the best they can.
     
  14. kel

    kel

    Messages:
    2
    i configured 1024mb for windows xp, it seemed to work with the following "workaround"

    i m using build 4560. i had that memory allocation error when trying to set 1024gb memory
    for my windows xp home. here is what i did to make that mem err goes away. my macbook pro has 4gb of mem.

    1) close all apps, esp. those that take lot of memory, eg. firefox.
    2) install iFreeMem from apple download site, this is a shareware??
    but there is a trial period you can test it out.
    3) Run iFreeMem, and hit that "Optimize Memory" button.
    4) BEFORE starting any other, launch your parallel desktop, and run
    the VM.

    this works for me. i dont know enuf technical details but I suspect this may
    be related to memory management. that tool kind of freed up the Inactive
    memory and made it available for Parallel. so launching it first before
    others help.

    Pls send a reply if this works for you, I want to know if this even depends on
    the type of Host OS ?? 'cos I plan to install different favor of linux on it.

    Regards,

    -kel
     
  15. Kel,

    I was impressed enough by your logic and solution to try it out myself. However, first I should add that I've added 8GB more RAM to my system so I'm now running with 12GB total.

    I did download and install iFreeMem. After running it I had more than 11GB RAM free. I also eliminated all traces of any old Parallels installations (including the VMs) via the uninstaller followed up by a search for any Parallels related files. I performed a new install of Parallels 4560 and Windows XP SP2. That went OK. However the first time I tried to start Windows from the Parallels desktop window I got the old memory allocation warning and no launch. I was able to use the Windows XP.pvs file as a launcher successfully for about a half a dozen launches and then the dreaded memory allocation warning reared it's ugly head and Parallels became totally useless.

    Thanks for the suggestion. It seemed like a good idea.
     
  16. This is my last post. I tried one more time to get Parallels 3.0 to work by doing a completely new installation of the latest build 4560. The first launch, to install Windows XP resulted in the dreaded 'Failed to allocate specified amount of memory' warning. I quit and will try to get my upgrade payment refunded as I've never gotten 3.0 to work, there has been no response or solution provided, the problem hasn't been addressed in three public releases of 3.0, and I've wasted a huge amount of time. VMware Fusion works.

    Bye.
     
    Last edited: Jul 22, 2007
  17. rjonna

    rjonna

    Messages:
    1
    a fix that seems to work, though this issue still needs resolved

    I simply lowered the VM memory to around 684 and the machine powered up fine. I will report back with any further failure.

    I then installed parallel tools (again) as this popped up (after the 4560 update). I shut down and got an error, as before, when i tried to ramp up the VM memory any higher than 684. So, I changed the program memory (in Parallels preferences) to as high as it could go (around 2.5gb on my macbook pro) and the error i was getting in my VM memory disappeared. I set the VM memory at 1gb and it seems to work fine. I will report back with any further failure.
     
    Last edited: Jul 24, 2007
  18. kel

    kel

    Messages:
    2
    In my preferences, i checked the "Enable virtual memory preallocation" option, i left
    the "Adjust memory limit" as Automatically.
     
  19. Ribozyme

    Ribozyme

    Messages:
    4
    Failed to allocate problem - Again, ETA for the FIX!!

    There are several threads reporting this problem and some report mysterious recipes to try to fix it, from rebooting, selecting the preallocating the memory option in preferences, reducing the allocated memory to less than 1 GB, and others, none of which works consistently neither resolve the problem fro once and for all. This appears to happen mostly on the MacPros with multi cores (mine is 8 cores) even when fully loaded of memory (mine 16 Gb).

    Someone from the Parelles team said they were aware of "the problem" in this thread and that a fix is coming. I installed the latest build 4560 with the hope that this is fixed, and nada, still there - Can someone from Parallels tell us when is this badly needed fix coming?? Is this in place in the new beta?? Please, don't force us to go to VMware Fusion!
     
  20. hEADcRASH

    hEADcRASH

    Messages:
    5
    Yet again...

    This is STILL not working (5060b). Y'all get one more shot an update (I've already installed one today), and if it doesn't work, I will be asking for my money back.

    ::Glenn

    (System Profile send separately)
     

Share This Page