Failed to configure the boot camp partitions hard disk

Discussion in 'Installation and Configuration' started by peterock, Nov 11, 2008.

  1. peterock

    peterock

    Messages:
    7
    Trying in vain to get parallels working with a vista boot camp partition. Keeps on coming up with this...

    A disk configuration error has occurred. Make sure that you have read/write permissions for the disk.

    I am running a Late 2008 Macbook Pro running 10.5.5

    Reinstalled Parallels and rebooted many times to no avail :(
     
  2. beta_dszczepa

    beta_dszczepa

    Messages:
    1
    I'm having the same trouble but I'm using Windows XP.
     
  3. daveDM

    daveDM

    Messages:
    2
    same error message, in my case with Linux

    I upgraded from 3 to 4 yesterday. I was able to configure my XP boot partition to work under parallels, but I have not yet had any luck configuring my Linux partition. My partitions are:
    /dev/disk0s1 EFI
    /dev/disk0s2 Mac
    /dev/disk0s3 Ubuntu Linux
    /dev/disk0s4 XP
    The specific error message in the dialog is "A disk configuration error has occured. Make sure that you have read/write permissions for the disk.
    I suppose this means I need an ext fs module for Mac OS.
     
  4. Parallelogram

    Parallelogram

    Messages:
    45
    I'm having this problem too. I'm trying to use a Windows XP Boot Camp partition with Parallels 4, and I keep getting "A disk configuration error has occurred. Make sure that you have read/write permissions for the disk." I have tried upgrading the VM from Parallels 3, and I have tried creating a new Boot Camp VM in Parallels 4, and they both generate the same error.

    After reading all these posts, I'm getting discouraged. VM Ware, which was once notoriously buggy, works great now, but Parallels almost never works (I had problems with v3 as well). The claim of an included iPhone client was pretty much blatant false advertising. At this point, I must say that I'm getting close to demanding a refund.
     
  5. peterock

    peterock

    Messages:
    7
    I have all but given up now, going back to vmware which detects and works with my bootcamp fine.... come on parallels what gives.... this is a pretty horrific bug and if I paid for this software I would be demanding a refund!
     
  6. DHKaplan@mac.com

    DHKaplan@mac.com

    Messages:
    9
    I dunno, I upgraded a version 3 Win XP bootcamp partition Parallels to version 4, and after a few false starts it does work... EXTREMELY slow booting and it keeps telling me that PTools aren't installed, altho they were, but it is usable... altho I think I'll wait a bit to upgrade my 2nd machine...

    DHK
     
  7. thehercman

    thehercman

    Messages:
    2
    STOP Error after upgrading on bootcamp partition

    So...

    Parallels 4.0 upgrade has completely hosed my bootcamp partition.

    I now get the following bluescreen when trying to boot

    Stop c000021a {Fatal System Error}
    The session manager initialization system process terminated unexpectedly

    This is a Windows XP with SP3 bootcamp partition.

    Anybody got any ideas on how to recover from this?
     
  8. thehercman

    thehercman

    Messages:
    2
    update.

    I just found a simple fix for this.

    Uninstall Parallels 4
    Reinstall Parallels 3
    Edit Virtual Machine Settings
    Under Harddisk / Advanced
    Click the button that removes parallels information from the bootcamp partition MBR.
    Restart the bootcamp virtual machine
    Your up and running again.
    Parallels 3 will re-create the necessary boot record information and allow the system to start.
     
  9. moox

    moox

    Messages:
    2
    I just experienced the same problems as described above. In my case I found out that the problem was caused by renaming the virtual machine from "My Boot Camp" as it was before to another name e.g. "Windows (Boot Camp)". After setting the new name I got the message "A disk configuration error has occurred. Make sure that you have read/write permissions for the disk."

    Renaming the VM back to its initial name as it was before the upgrade from V3 to V4 solved the problem for me.
     
  10. otoc

    otoc

    Messages:
    50
    I had the same issue with the upgrade...

    What I did was remove the virtual machine (file/remove)
    And create a custom one for the boot camp partition.
     
  11. joemz

    joemz

    Messages:
    3
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  12. joemz

    joemz

    Messages:
    3
    Which is worse, product or support?

    I've been getting the same message and this is the email response I got from support

    Please try to check if you have correct VM configuration in Hard Disk section. Please ensure that the path to .hdd file is correct. Try to remove the .hdd file from the configuration and the readd it again, applying changes between these operations. If this would not help - please contact us again.

    Thank you.

    Not very detailed, and it didn't work

    However, I did go into Config Hard Drive, Advanced options, removed the HD (-). Then I went to add a HD back, and it didn't acept any of the disks. So I added an IMAGE back, and it pointed me to an image file, and it seems to work

    I didn't remove Parallels 4 or anything else that is time consuming

    Of course, still have no clue why this was necessary
     
  13. que

    que

    Messages:
    11
    hi all,

    same problem Different scenario

    mac os x 10.5.5
    macbook

    i install parallels 3 & i could not make it work with boot camp windows xp sp2 & sp3
    so i delete windows boot camp then delete parallels
    & reinstall parallels 3 & try to install windows xp sp2
    & got the death bluescreen in parallels !!!
    so i try to install windows xp sp2 in boot camp again & it worked fine

    i had problems before with boot camp
    but i could not make parallels work in my macbook ( with or without ) boot camp

    any help please
     
  14. joemz

    joemz

    Messages:
    3
    Que

    I'm not sure if this makes a difference, but I did boot camp, then installed XP sp2, then installed an Apple upgrade that's necessary prior to upgrading to SP3. Then I installed sp3 in the boot camp machine and it worked ok

    then, after getting the xp side of the world working, did i install parallels.

    from your post it sounds like you're installing parallels first. That may be fine, but since it's not working for you, maybe try installing parallels only after getting the boot camp virtual machine working right
     
  15. talyric

    talyric

    Messages:
    1
    I was having the same issue.

    After reading this thread I checked the name of the the boot camp partition and it was "Untitled".
    I changed the name in Parallels (Options/General/VM name) to "Untitled", and now it all seems to work fine.

    I don't know why it worked, but I'm sure happy it did. Hope that helps someone else.
     
  16. que

    que

    Messages:
    11
    hi again
    thanks for your reply in my problem

    same here

    what Apple upgrade you talking about ???
    I installed sp3 in the boot camp machine and it worked ok in boot camp with me
    without that Apple upgrade

    same here i make sure that win xp sp2 working fine in boot camp
    and thene i try parallels before sp3 and after nothing worked

    [/QUOTE]

    no i did just like you
    i install win xp sp2 then boot camp drivers.... work fine in boot camp
    then parallels .......parallels did not work with boot camp
    i assume that boot camp is the problem from old problems so i try delete win xp from boot camp
    but boot camp did not view options to delete win xp
    so i try to erase the disk with win xp & then i delete parallels

    i install parallels alone again then try to install win xp sp2 in parallels
    then i got death bluescreen in parallels during installation win xp sp2
    i assume the problem from cd

    so i try to install win xp sp2 in boot camp
    it installed with out any problems

    i can't see the problem here
    is it mac os x or boot camp or parallels
    now every thing is working mac os x & boot camp win xp sp2
    except parallels it does not work & when i try it with boot camp or alone it gave me false error
     
  17. Parallelogram

    Parallelogram

    Messages:
    45
    Normally, I'm opposed to just bumping a thread, so I apologize for doing this, but in this case, even just this single issue is clearly an enormous problem. Parallels, please fix this problem immediately.
     
  18. que

    que

    Messages:
    11
    any help for me !
     
  19. woeldiche

    woeldiche

    Messages:
    2
    Unable to upgrade too

    I have the same problems as outlined above (Danish Language 10.5.5 / Win XP SP2). Same error message as the others. I tried the solutions described, but it didn't work.

    Parallels actually acted a little different after I used the disc tool to activate the Boot Camp Partion and renamed the virtual machine to WINXP (same as the drive). Parallels 4 got at little further in the process, and removed and mounted the boot camp drive a couple of times, but in the end I got the same error message.

    I can see from the post, that the problem has been known for quite some time know - why no answer from Parallels? Not even a 'we acknowledge the problem and we're working on it. Will get back to you when we got a fix' - just silence. Come on, you can do better than this ... or have you all bought shares in VMWare?

    /Jesper
     
  20. Parallelogram

    Parallelogram

    Messages:
    45
    This problem is still not fixed in build 3540.

    Element5 denied my refund request, and Parallels is starting to censor forum posts along those lines.

    I'm getting close to disputing the charge with my credit card company. I know that creates a huge hassle for everybody (including me), but I'm running out of options.
     

Share This Page