Fallout New Vegas with Parallels 6 and Windows XP

Discussion in 'Windows Guest OS Discussion' started by smiley2billion, Oct 27, 2010.

  1. smiley2billion

    smiley2billion

    Messages:
    1
    I bought Fallout New Vegas the day it came out and thought sure it would work fine with Parallels since Fallout 3 already does so.. This is NOT the case.

    I finally got it to work after installing the D3D "fix" that is supposed to help Windows users get better performance from the game, it also apparently helps Parallels work. After I installed the fix I was able to start a new game and create a character, however, I couldn't leave the house you start out in because it would crash. To fix this I had to drop the settings to "low" on the Fallout launcher, I'm certain there's something in the advanced settings that causing the crash but haven't had the time to narrow it down yet. As for performance the game runs perfect. I've seen no graphics or sound glitches after getting it to run, aside from the glitches that were caused by the game engine itself and would be normal to see on a native Windows platform.

    I'm running an iMac 27" mid 2010 with an i7 2.93GHz 8GB RAM and a Radeon HD 5750.

    After installing the fix the game launcher will rescan your hardware and will report that you're using an Nvidia 8800 GS, this is normal.

    http://www.newvegasnexus.com/downloads/file.php?id=34778

    That's the link to the D3Dfix. Hope this helps some folks.
     
  2. atheos

    atheos

    Messages:
    1
    I also needed that file to run the game at all, without it the game just crashes to desktop when loading the 3D engine. Using XP Home and Parallels 6 with latest updates, MacBook Pro 13" 2,4GHz (mid-2010). Settings on low @ 1280x800, minor glitches (occasional flickering "ghost frames" from a few seconds back), performance is otherwise fairly good. Haven't tested on higher details yet but it already runs better than expected. Not amazing but still completely playable.
     
  3. Jfro

    Jfro Bit Poster

    Messages:
    2
    I can't even run it, when i try to load a new game it crashes, just installed version 1.1.1 and still no luck.

    Event Viewer shows me this

    Faulting application name: FalloutNV.exe, version: 1.2.0.285, time stamp: 0x4cd9d70b
    Faulting module name: FalloutNV.exe, version: 1.2.0.285, time stamp: 0x4cd9d70b
    Exception code: 0xc0000005
    Fault offset: 0x00751a49
    Faulting process id: 0xf48
    Faulting application start time: 0x01cb808e82797526
    Faulting application path: c:\program files (x86)\steam\steamapps\common\fallout new vegas\FalloutNV.exe
    Faulting module path: c:\program files (x86)\steam\steamapps\common\fallout new vegas\FalloutNV.exe
    Report Id: e7e627e9-ec81-11df-8723-001c42d1b639

    Details shows this

    - System

    - Provider

    [ Name] Application Error

    - EventID 1000

    [ Qualifiers] 0

    Level 2

    Task 100

    Keywords 0x80000000000000

    - TimeCreated

    [ SystemTime] 2010-11-10T04:20:53.000000000Z

    EventRecordID 3265

    Channel Application

    Computer JASON655B

    Security


    - EventData

    FalloutNV.exe
    1.2.0.285
    4cd9d70b
    FalloutNV.exe
    1.2.0.285
    4cd9d70b
    c0000005
    00751a49
    f48
    01cb808e82797526
    c:\program files (x86)\steam\steamapps\common\fallout new vegas\FalloutNV.exe
    c:\program files (x86)\steam\steamapps\common\fallout new vegas\FalloutNV.exe
    e7e627e9-ec81-11df-8723-001c42d1b639
     
  4. RandomMarius

    RandomMarius

    Messages:
    5
    Solved for me.

    I'm Running Fallout New Vegas on a iMac 2011 in a Windows 7 VM.

    After copying the NVidia D3D fix file I could at least start the game, but it would crash on exiting the house as well.

    It works if I use all low detail, so I started looking for the offending settings.

    YMMV but for me I can play it all on Ultra, except for

    Water -> Water Multisampling: Low

    is what I need so that it does not crash.

    On Ultra at 2560 x 1440 running in a VM smoothly is not bad at all... kudus to Parallels.

    But I'll probably drop my detail a bit since I prefer loads of speed.
     
  5. RandomMarius

    RandomMarius

    Messages:
    5
    Parallels 7 just killed Fallout

    Ho-hum... it seems the newly released Parallels 7 just killed my Fallout 3 New Vegas... the game does not run at all now...

    :(
     
  6. RandomMarius

    RandomMarius

    Messages:
    5
    Fixed.

    Well it seems deleting the previous D3D DLL 'fix' fixed all our problems.

    Fallout 3 works fine now standardly with Parallels 3 with all settings on Ultra.

    Bravo!
     

Share This Page