Fedora Core 9 Parallels Tools Install Failure

Discussion in 'Linux Guest OS Discussion' started by Bruce Graham, Mar 1, 2008.

  1. Bruce Graham

    Bruce Graham

    Messages:
    1
    On MBP 15" Core Two Duo 2.33 and Parallels 5584 running Fedora Core 9 with all latest updates as of 1 March 2008, when attempting to install Parallels Tools, the following error message is generated:

    Found xorg version .
    Installation for xorg.. not found.


    Then the installation appears to terminate with no other message. If uninstall script is then run, the following error message is generated:

    Parallels Tools installation not found.

    Dynamic screen resolution doesn't work, but I've edited xorg.conf for 1280x800 and that's OK. Everything else seems to work great including sound, except for USB mass storage. of course. If only I could get Tools installed so USB mass storage would hopefully work properly. Any tips? This would be greatly appreciated. Thanks.
     
  2. MaximS

    MaximS

    Messages:
    716
  3. scsjason

    scsjason

    Messages:
    2
    Any news on when it will be supported ? I too have had the problem with being unable to install the parallel tools. Presumably its just a re-compile of whatever is in tools to recognise the new version xorg . . . ?
     
  4. James O'Dell

    James O'Dell

    Messages:
    5
    I haven't even been able to make an xorg.conf file that allows FC 9 to work. Can you post what you did to get it to work?

    Thanks,
    Jim
     
  5. VinceSkahan

    VinceSkahan

    Messages:
    10
    On my MacBook, I can't get Parallel Tools to install either, but Xwindows looks ok at 1024x768 if you do a little manual tweaking in xorg.conf

    In the Screen section:
    set your DefaultDepth and Depth to 16 (was 24)
    set the Modes to "1024x768"
     
  6. felixm

    felixm

    Messages:
    1
    Vince-
    What were your other settings? I tried the tweeks you said xorg.conf and I still can't get X11 go start.
     
  7. James O'Dell

    James O'Dell

    Messages:
    5
    I was surprised to find that just changing the depth and defaultdepth to 16 worked like a charm. No other changes.
     
  8. tommetge

    tommetge

    Messages:
    2
    what a remarkable answer, MaximS. It would be slightly more helpful if you could at least post a *reason* why it isn't supported. One of the nice things about linux is the community of people willing to put effort into making things work... I would love a chance to work around this. If you, or any of the other parallels team could give us a few details, I'm sure we can work something up.
     
  9. tommetge

    tommetge

    Messages:
    2
    i've patched up the installer tools to work on fedora 9, but the modules (obviously, version mismatch) will not load, so it's a moot point. for those curious, fedora 9 runs Xorg 1.5.0 RC1 (actual version is 1.4.x). the mouse and video drivers will not work. best bet (and this is why setting your configs to use 16 bit works) is not to use the tools themselves, use the standard vesa driver that fedora 9 preconfigures your system for.

    if you (like me) have upgraded your vm from 8 to 9, the tools installer is nice enough to leave your old config in the /etc/X11/ dir- called xorg.conf.prl-backup. just move that to /etc/X11/xorg.conf and you should be good to go (you may need to reduce from 24 to 16, as mentioned in this thread).

    for the parallels team: would you consider releasing the source for the tools so that we can compile the necessary modules for fedora 9? or would you be able to release a precompiled binary for Xorg 1.4?
     
  10. John@Parallels

    John@Parallels

    Messages:
    6,450
    Please wait for June's planning build
     
  11. pcgalen

    pcgalen

    Messages:
    3
    I am curious as to how you got FC9 to install. The VM crashes upon the installer boot on windows XP guest trying to install FC9. I tried all of the common kernel parameters and still no go
     
  12. pcgalen

    pcgalen

    Messages:
    3
    I mean Windows XP host.... Sorry.
     
  13. John@Parallels

    John@Parallels

    Messages:
    6,450
    try agp=off , this should help
     
  14. pcgalen

    pcgalen

    Messages:
    3
    Thanks, but no help

    Thanks for the tip... Still crashes after it says SMP not available switching to UP

    I tried NOSMP=yes and that did not help either.
     
  15. John@Parallels

    John@Parallels

    Messages:
    6,450
    is it possible to provide /var/log/messages file?
    Yo can retrieve file using Parallels Explorer
     
  16. sapidus

    sapidus

    Messages:
    1
    June build (5608) still fails to install

    Hi John,

    On 5/25/2008, John@parallels wrote:

    "Please wait for June's planning build"


    I'm running the June build (5608 - June 9, 2008) which gives the following message:

    "Found xorg version 1.4.99
    Installation for xorg.1.4 not found.
    "

    Any idea when a fixed version will be made available?
     
  17. John@Parallels

    John@Parallels

    Messages:
    6,450
    I am not able to provide exact ETA, right now, I will try in 2-4 days
     
  18. RodM

    RodM

    Messages:
    5
    How did you get FC 9 installed with X working?

    I got fc 9 installed, but nothing I did would get x/kde working.

    I've deleted it for now, but can reinstall this weekend, if I can get x working
     
  19. John@Parallels

    John@Parallels

    Messages:
    6,450
    Situation for now is following, Parallels Tools are included in Parallels Server and working, but they are a bit different version and we are working to compile Parallels Desktop compatible version
     
  20. ptrourke

    ptrourke Bit Poster

    Messages:
    8
    Thanks for work on this

    Being able to install Fedora 9 in Parallels would be very useful to me.
     

Share This Page