File saving issues when using Mapped Network Drive on Windows 10 guest OS

Discussion in 'Windows Guest OS Discussion' started by ariestav, Feb 28, 2018.

  1. ariestav

    ariestav Bit Poster

    Messages:
    6
    Hello,
    I have successfully mapped two network drives to my Windows 10 Creators Update guest OS that I'm running on Parallels 13 hosted on macOS High Sierra 10.3.3. However, the problem is that some applications running on guest Windows 10 OS report errors when they write files to those mapped drives. To be sure the applications ARE writing to the files to the drive, but some, like Adobe After Effects, are reporting "Error with file: myfile.aep" when saving the file to the mapped drive.
    I have another machine that is nearly the EXACT same setup, and no error is being reported. I'm not sure what the deal is. I've tried adding a DWORD for EnableLinkedConnections via the Registry with the regedit. I've also tried mapping the drives as both an Administrator (via the cmd.exe as Administrator) and as a regular user -- same issue. I've tried pretty much all of the suggestion found in this Microsoft support article:

    https://support.microsoft.com/en-us...ed-drive-to-a-local-directory-fails-with-erro

    I'm not sure if this is a parallels issue or what, but I thought I would post here to see if anybody had any idea if parallels could be the culprit. Also, I've turned off any "Sharing" from the VM's configuration, and am mapping solely based on the WINS NetBIOS Name that I've entered in my macOS Advanced config for the Network I'm running.

    Any other troubleshooting I could try?

    Thanks!
     
  2. ariestav

    ariestav Bit Poster

    Messages:
    6
    Wow, almost a month and no response. Seriously?
     
  3. ariestav

    ariestav Bit Poster

    Messages:
    6
    Alright, I thought I would post here since nobody did, and if anybody runs into an issue, this might solve your problem. Apparently the issue is not with Parallels, but with clients connecting with SMBv3 to volumes that are formatted in APFS (the default for macOS HIgh Sierra). The work-around for now, is to completely disable SMBv2 and SMBv3 from the Windows guest OS which will force the Windows OS to use SMBv1 which you must have enabled in Windows 10.

    Use this Microsoft support article to see the commands under heading that reads: "How to detect status, enable, and disable SMB protocols on the SMB Client"

    I also documented the solution in this thread hosted on Adobe's After Effects forum for more details and in case that support article vanishes.

    Hope this helps!
     

Share This Page