Files copied from Linux to Mac don't open

Discussion in 'Linux Guest OS Discussion' started by GregorW1, Mar 3, 2021.

  1. GregorW1

    GregorW1 Bit Poster

    Messages:
    6
    Hi
    I have upgraded to Big Sur just recently, current version. Parallels current versions of all tools and so on. I pressed update before verification.
    The problems described here did not happen on Catalina.
    I used Ubuntu 20.04 and Debian (current version) to verify this.
    I download a pdf from the web. It downloads fine. I open it on Linux, fine. I copy it to macOS. File format not recognised.
    Tried again. Same story. Created a new VM with Debian, same story.
    So I zipped the PDF and copied it to macOS, zip format not recognised
    I gzipped the PDF and then copied it to macOS: gzip format not recognised.
    No matter what format the file has, I copy from Linux to mac, they are not recognised. For Debian and Ubuntu. Have not tried windows yet.
    I have done this 100 times in the past without any issues. So it appears to me something in Big Sur has changed. But when will parallels reflect this?
     
  2. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    264
    Double-check to see if Mac is disk shared under the VM settings. That said, there used to be a problem saving from Linux to Mac where it basically did a 'touch' to create an empty file. Always thought it was a privileges issue and which OS had control of the drive - may have been back in Mojave, but can't remember. Sounds like this is back in Big Sur.

    I used to get around it by saving to a small USB thumb drive in the Linux VM. Then, while in macOS then copying it from the thumb drive. It's a pain, but then you don't have to guess.
     
  3. (GalaxyMaster)

    (GalaxyMaster) Kilo Poster

    Messages:
    54
    Most likely, you are stumbling on the extended attribute assigned to the file from unknown source. Just run
    Code:
    xattr -r -d com.apple.quarantine the_file_or_dir_you_copied_over
    and try to open it again :)
     

Share This Page