Firefox display corrupted

Discussion in 'Windows Virtual Machine' started by briggsey71, Mar 27, 2023.

  1. briggsey71

    briggsey71 Bit poster

    Messages:
    8
    Firefox display is corrupted now on Parallels Destop 17 running Windows 10, 21H2 on Macbook Pro 8,2 running High Sierra (OSX 10.13.6. Can't change any settings for Firefox because of corrupted display. Worked fine in the past. See attached screenshot.
    upload_2023-3-27_22-32-54.png

    Can't change graphics display settings in Parallels. Discrete AMD chip was disabled because it failed and was able to be replaced. Running Parallels on system memory using Intel graphics. See attached screenshot.

    upload_2023-3-27_22-28-30.png
     
  2. briggsey71

    briggsey71 Bit poster

    Messages:
    8
    Best Answer
    Fix from Parallels Support resolved issue, as follows.

    Since it's not possible to disable this feature with conventional means, as described on the forum due to disabled graphics card, you can try to disable it using profile settings.
    To do that, please perform the following steps:
    1. Start your virtual machine.
    2. Open "File Explorer" -> type %appdata% in the address bar and press "Enter".
    3. Locate "Mozilla" folder and double-click it.
    4. In the search bar of the "File Explorer", enter prefs.js, and it will locate your profile preferences file.
    5. Take a backup copy of it, and place elsewhere, for instance Desktop, before proceeding.
    6. Right-click the original prefs.js file and select "Open with.." -> select "Notepad".
    Note: When there is a single profile, only one file will be found. However, if there are several, please perform the following steps for each of them.
    7. Add the following line to the list of preferences:
    user_pref("layers.acceleration.disabled", true);
    8. Press "Cmd+S" and close the file.
    9. Start Firefox and check if the issue persists with the hardware acceleration disabled.


    Thanks to Parallels Support for their persistence in helping me fix this.
     
  3. Pramesh Boodadoo

    Pramesh Boodadoo Staff Member

    Messages:
    542
    Hello
    If you are facing an issue with Mozilla Firefox, for us to further investigate the technical issue, kindly provide us with the following information:

    1. Since when has the display issue with Mozilla started?
    2. Collect a technical report (right-click Parallels icon in Dock > Help > Send technical data > check "Attach screenshots..." > press Send Report) and provide us with the report's 9-digit ID in reply to this post.

    Thanks
     
  4. briggsey71

    briggsey71 Bit poster

    Messages:
    8
    Thanks for the response.
    1 I last used Parallels and Firefox about 3/1/2023. Current date is 4/1/2023. Uninstalled it, reinstalled, same issue. Other browsers, Chrome & Edge work ok. I also cannot update Windows 10 to 22H2 because of disabled discrete graphics chip noted in original post. Any workarounds to that? I discoverd somewhere that I could install it to an external drive but not really keen on doing that.
    2 Tech data report # is 421971397. See attached screenshot. Screen Shot 2023-04-01 at 22.47.00.jpg Screen Shot 2023-04-01 at 22.47.00.jpg
     
  5. paydaya

    paydaya Bit poster

    Messages:
    3
    It looks like the display issue you are experiencing with Firefox on Parallels Desktop 17 running Windows 10 could be related to a graphics driver issue. Here are some steps you can take to troubleshoot the issue:

    1. Try updating the graphics driver for your virtual machine. You can do this by going to the device manager in Windows 10 and right-clicking on the display adapter. Then, select "Update driver" and follow the prompts.

    2. If updating the graphics driver doesn't work, try disabling hardware acceleration in Firefox. To do this, open Firefox and go to Options > General > Performance. Then, uncheck the box next to "Use recommended performance settings" and uncheck the box next to "Use hardware acceleration when available". Restart Firefox and see if the issue is resolved.

    3. If the above steps don't work, try resetting Firefox to its default settings. To do this, go to Options > Help > Troubleshooting Information. Then, click on "Refresh Firefox" and follow the prompts. Note that this will remove all your Firefox settings and add-ons, so make sure to back up any important data before proceeding.

    4. If none of the above steps work, try reinstalling Parallels Desktop 17 or upgrading to the latest version of Parallels Desktop. It's possible that the issue could be related to a compatibility issue between Parallels Desktop and your macOS version.
    If none of these steps resolve the issue, you may want to contact Parallels support for further assistance.
     
  6. briggsey71

    briggsey71 Bit poster

    Messages:
    8
    Thanks for the response but none of the methods you suggested will work.
    1 As I wrote previously, the discrete graphics chip in the computer has been disabled and the laptop is running only with the onboard Intel graphics, using system memory. That is the reason I'm running Parallels, because otherwise Windows will not run since it defaults to the discrete graphics adapter which is no longer present. Consequently there is no option to update the display driver.
    2 Cannot disable graphics acceleration or reset in Firefox because Firefox will not load a readable display screen. Fonts are just blobs in the display. See the previous screenshots that I uploaded.
    I will try to contact Parallels support.
     
  7. Maxim Rasulov

    Maxim Rasulov Staff Member

    Messages:
    80
    Hello.

    To check if hardware acceleration of Firefox is related, you can try starting Firefox in safe mode, by holding down "Shift" when opening an application.

    If that still cannot work, you can also try booting into Bootcamp partition directly, following the steps in this article: https://support.apple.com/en-us/HT208123

    Then launching Firefox, disabling hardware acceleration as mentioned earlier (To do this, open Firefox and go to Options > General > Performance. Then, uncheck the box next to "Use recommended performance settings" and uncheck the box next to "Use hardware acceleration when available".) and checking if it persists in the virtual machine.
     
  8. briggsey71

    briggsey71 Bit poster

    Messages:
    8
    Thanks for the response.
    1 Started Firefox in safe mode and did get display of dialog box warning I was using an old Firefox version & asking me to create new profile. Responded yes and then Firefox loaded, but with same no display issues.
    2 I am unable to boot into Windows directly from Boot Camp. My laptop is a 2011 Macbook Pro which has the defective AMD/ATI graphics chip which has been manually hardware-disabled and runs its graphics solely on the onboard Intel graphics. Since Windows needs the discrete graphics chip to run it will not run from Boot Camp. That was the reason for my purchase and using Parallels; it would enable me to run Windows without the discrete graphics chip.
    Thanks again.
     
  9. Maxim Rasulov

    Maxim Rasulov Staff Member

    Messages:
    80
    Hello.

    Thank you for the update.

    The investigation will continue in the recently opened support ticket.

    Please check your e-mail.
     
  10. briggsey71

    briggsey71 Bit poster

    Messages:
    8
    Best Answer
    Fix from Parallels Support resolved issue, as follows.

    Since it's not possible to disable this feature with conventional means, as described on the forum due to disabled graphics card, you can try to disable it using profile settings.
    To do that, please perform the following steps:
    1. Start your virtual machine.
    2. Open "File Explorer" -> type %appdata% in the address bar and press "Enter".
    3. Locate "Mozilla" folder and double-click it.
    4. In the search bar of the "File Explorer", enter prefs.js, and it will locate your profile preferences file.
    5. Take a backup copy of it, and place elsewhere, for instance Desktop, before proceeding.
    6. Right-click the original prefs.js file and select "Open with.." -> select "Notepad".
    Note: When there is a single profile, only one file will be found. However, if there are several, please perform the following steps for each of them.
    7. Add the following line to the list of preferences:
    user_pref("layers.acceleration.disabled", true);
    8. Press "Cmd+S" and close the file.
    9. Start Firefox and check if the issue persists with the hardware acceleration disabled.


    Thanks to Parallels Support for their persistence in helping me fix this.
     

Share This Page