Fix for Black Screen/Blue Screen Boot Loop Error - Build 3188

Discussion in 'Parallels Desktop for Mac' started by music_para_user, Mar 9, 2007.

  1. music_para_user

    music_para_user Bit Poster

    This worked for me in both cases:


    Fix for Parallels "black-screen" bug

    March 8, 2007

    Several readers have sent in a procedure that fixes the black-screen bug in the recent new version of Parallels Desktop. The freeze occurs when installing Windows in a new virtual machine as you install Parallels Tools.

    Jose Goncalves described the fix:

    F8 on windows startup_>VGA mode_>install Parallels Tools_>reboot

    Laszlo Kardos describes it with a bit more detail:

    I too had this occur on several different Parallels installs. The solution:

    Restart Parallels
    Hold down the F8 key (FN-F8 on MacBooks) and boot Windows into Safe Mode
    Install Parallels Tools
    Reboot Windows
    It should work fine.

    Sunil Punjabi has a slight variation:

    There is a quick fix that worked for me.

    Restart the XP instance
    During the "BIOS" click on the window to activate it.
    Hold down the F8 key, this will bring up a Windows boot menu.
    Boot to "VGA" Mode.
    Ignore all the errors about screen size, etc.
    Install Parallels tools.
    Reboot XP
    Readers Paul Happ Jaap van den Dries of the Netherlands also said that the procedure works.

    Jim Adrig warned how not to get into the problem:

    I had this problem after the Hardware Wizard asked me to install a new Video driver, and I selected a Parallels driver (I forget which one; there were two; but it does not matter); and I was hosed.

    DO NOT continue the 'New Hardware' wizard! Cancel immediately and just install Parallels Tools the regular way! The wizard does not come up again.

    I never did get the bad VM running again, but I did not need it; I had a backup and used this method when the Wizard appeared again.
  2. alkinet


    Can't Boot XP in to Safe Mode

    Any tricks on booting the new Paralles Build 3118 Windows XP in Safe Mode? I have tried both Fn F8 and just plain old F8. Any alternative ideas would be helpful.

    Jonathan French
    Seattle, WA
    MacBook Pro 2g/120g
  3. rockaday



    This trick worked like a charm. I was upgrading a friend's MacBook and thought I'd ruined everything. This forum is great.:)
  4. machaon



    Thanks. Worked for me too.

    alkinet, If you're in a window (not bootcamp) are you sure the VM's captured the keyboard input before holding down F8? You have to be pretty quick (turn on VM, click in window to capture input, and hold down F8 all within a second or so)
  5. darkone


    that solution has been posted here many times, tho it seems most people cant do a search here ?!?!

    Probably best it had its own topic..
  6. doceddi


    ok, really glad i found this thread, but:

    i boot into safe mode, select "Install Parallels Tools..."
    from the "Actions" menu, the screen flickers briefly,
    and then nothing happens ..

    Parallels thinks the installation is in progress
    (Action menu now says "Cancel Parallels Tools Installation ..")
    but nothing ensues.

    what can you do?



    update: in my backup copy of the VM (windows 2000, C: drive NTFS)
    the Parallels tools installer starts up, but then there is an OS error:

    Error Code: -5009 : 0x80040702
    Error Information:
    >Ctor\ObjectWrapper.cpp (163)
    >Ctor\ObjectWrapper.cpp (391)
    >Kernel\Component.cpp (1161)
    >Kernel\CABFile.cpp (384)
    >SetupDLL\SetupDLL.cpp (1708)
    PAPP:parallels Tools
    PVENDOR: (
    @Windows 2000 Service Pack 4 (2195) IE 6.0.2800.1106

    and then nothing happens any more.

    --- update #2:

    evidently NTFS is the culprit.

    at least, i dug up an old backup where the C: drive is still FAT,
    and the Tools installer seems to have worked.

    Is this a known issue? it seems a very strong restriction;
    i need NTFS for work -- is it true that 3188 is incompatible
    with NTFS? 1970 worked fine under NTFS for months ..

    Last edited: Mar 15, 2007
  7. Parabola


    To doceddi: NTFS might be a specific problem for you, but I have no problems w/ 3188. Also, I've been lazy and used the same VM through every one of the Betas and GM releases.

Share This Page