FIX: Permissions / Corrupted .HDD under different account

Discussion in 'General Questions' started by Gryzor, Jul 3, 2007.

  1. Gryzor

    Gryzor

    Messages:
    16
    Hello,

    I have had a strange problem this week. I have my VMs on an external firewire drive. "suddently" all my VMs started to fail saying that I was unable to "lock" the configuration. I realized that I needed to set the permissions to Read/Write for "Others". After I did that, I still was having a problem; the VM won't start saying that the HDD file is corrupted or in use. I rebooted, repaired permissions, etc. I read the forums and did all that I considered appropiate to no avail.

    I Tried to run the VM on another user and It worked. So it was definitely something with MY user account. After a few minutes of investigation, I found a "Paralells" folder on my /user/<me>/Library which was "Read/Write" for me, ReadOnly for the group (mine) and ReadOnly for Others. I moved the folder to the thrash, and it all started to work. A new one has been created (empty) with the same permissions. But all my VMs started to work again.

    After a closer inspection of the "offending" original folder, all I could say is that I had an "Explorer" folder in it. Same permissions. Dunno what was wrong with it.

    So in summary, if you are experiencing strange problems, fix the permissions, and delete all stuff that might be "causing troubles" (backup first!).

    Hope this helps somebody out there.

    Yours,

    Martín Marconcini
    MacBook Pro 15'' - 2.0Ghz - 2GB RAM - OS X 10.4.10
     

Share This Page