FIXED: VM does not start after Big Sur to Monterey upgrade.

Discussion in 'macOS Virtual Machine' started by VolkerS10, May 19, 2022.

  1. VolkerS10

    VolkerS10 Bit poster

    I upgraded a Big Sur VM to Monterey and the upgrade goes well (no errors).
    Upon finished, the VM reboots automatically into Monterey (if I open "About this Mac" I get macOS Monterey Version 12.4).

    But if I try to restart that machine again, it never ever comes back. It stays on the apple logo with no progress bar forever.

    Luckily, I did a snapshot in the state directly after the VM rebooted into Monterey after upgrade, so I can run the snapshot of the fresh installed Monterey as many times as I like.

    I already tried several things with Parallels support:
    1. Boot to recovery with devices.mac.boot_args="-x -v". Here, the screen stays black forever with nothing to see at all.
    2. Connect a serial console to a file and boot with devices.mac.boot_args="keepsyms=1 -v debug=0x54a nvram_paniclog=1".
      It returns only this:
      #[EB|LOG:EXITBS:END] _
      ======== End of efiboot serial output. ========
    3. Use boot menu and try to run recovery partition. But it behaves the same. No boot at all.
    4. Disk Utility is happy with all partitions and volumes. First Aid function does not find any problem.
    5. Calling sudo bless --setBoot --device /dev/disk1s2 in the machine is the only device that does not return an error. But it did not help.
    The thing is that this machine was configured as a build-machine for many developers. It would take days to restore a similar setup. I can't stay on Big Sur because we need most recent Xamarin which needs VS2022 which needs current XCode which wants me to update to Monterey. So I cannot work any more... I would try with a fresh Monterey installation, but the host is Mojave and so the new VM is not Monterey at all and a fresh Monterey is not available from Apple.

    As the Monterey machine is running directly after the upgrade and the VM reboot, I can work on this machine (until I need a reboot). Is there anything I can do to rewrite or re-establish all boot relevant things? Maybe using bless or systemsetup? I'm not afraid of the console...
  2. VolkerS10

    VolkerS10 Bit poster

    The following call is interesting:
    $ sudo systemsetup -getstartupdisk

    So maybe this is missing? I tried...
    $ sudo systemsetup -liststartupdisks
    $ sudo systemsetup -setstartupdisk /System/Library/CoreServices
    Setting startup disk not allowed while System Integrity Protection is enabled.
    $ sudo csrutil disable
    csrutil: This tool needs to be executed from Recovery OS.

    I can not disable System Integrity Protection without recovery mode. And recovery mode is not available. I'm getting crazy here :-(
  3. VolkerS10

    VolkerS10 Bit poster

    Maybe worth to mention that I'm able to boot into the EFI console. But I found no useful functionality yet :-(
  4. VolkerS10

    VolkerS10 Bit poster

    I fixed it by generating a bootable USB stick from another Monterey machine. I then booted my VM with this USB stick and selected to install Montery (again). This fixed my boot issue and the data and users seem to be kept. Just the network stack configuration was gone (fixed IP, DNS server etc).
  5. Asish

    Asish Staff Member

    Hello, Thank you for your suggestions and helping our customer to fix the issue.

Share This Page