Folders suddenly not sharing

Discussion in 'Windows Virtual Machine' started by RamonC, Jun 22, 2018.

  1. RamonC

    RamonC Bit poster


    I'm using the following HW and SW: Mac 21'' late 2013, updated to 16 GB of RAM and SSD disk of 1 TB (yes, it goes like a rocket!), Parallels 13.3.2, host OS is High Sierra 10.13.5 and guest is Windows 10 Pro 64 bits updated to its last version, all three in Spanish language.

    I'm experiencing a sudden and unexpected problem after months of trouble-free running of the same configuration. The problem is that my shared Desktop and Download user folders don't appear to be shared anymore. The host desktop is different to the guest desktop and the host download folder is different to the guest download folder... but they were the same until this morning and I'm not aware of having changed anything.

    However, I still can access all folders in the Mac (including desktop and download folder) through the network connections in Windows.

    My sharing settings are (and, as I said earlier, I'm not aware of having changed anything):

    Mac sharing:
    • share folders: share home folders
    • Personalised folders: Documents, Images and a folder in the local network server
    • share profile: on
    • configure: desktop and download on, all others off; recycle bin on
    • share cloud folders: on
    • Map Mac volumes to Windows: off
    • Advanced settings: assign letter: on --- allow executables: off --- permit file names DOS 8.3: on

    Windows sharing:
    • Access Windows folders from Mac: on
    • Share OneDrive with Mac: on
    • Advanced settings: share Windows network with Mac: off --- share Windows connected units with Mac: on
    (not sure the names of the settings in English are correct, but I imagine you can understand)

    I have uninstalled and reinstalled Parallels, reinstalled Parallels tools in Windows and restored Windows to a point before the problem, to no avail. I have not, though, uninstalled and reinstalled Windows and I'd prefer to avoid it, since I'd have plenty of SW to uninstall and reinstall.

    Could someone be so kind to tell me what could be happening?

    Thanks a lot for your help.
    Last edited: Jun 22, 2018
  2. AJ@Parallels


    Hello RamonC, Kindly start the virtual machine and go to the top menu bar, click on Actions--> Configure--> Hardware--> Network1--> Change the source to Bridge network ( Default adapter ). Also go to Options--> Sharing--> Shared folders --> change to All Disks and check if it helps.
  3. RamonC

    RamonC Bit poster

    Hi, AJ

    Thanks a lot for your answer.,

    I did it, no difference.

    I don't know (I'm no techie), but my impression is that Windows, for some reason, has stopped considering the folders \\Mac\Home\Desktop and \\Mac\Home\Downloads as the suitable Desktop and Download system folders. I don't think there is a problem with the host-guest network, because I can access all Mac folders from Windows through the file browser (and also all Windows files from the Mac Finder) and also I can perfectly access the internet and e-mail from the VM. It's just that the Mac system network folders don't act as Windows system folders, as they should and as they did until yesterday. Otherwise, everything is fine. It's as if the "Share user folders with Windows" option was not checked at Configure --> Options --> Sharing. But it is.

    Just guessing, but maybe there is a problem in identifying that the equivalent to "Escritorio" in Mac is "Escritorio" in Windows? Maybe something language-related? But on the other hand, everything was fine until yesterday...

    I don't know if it could be related, but the problem happened when I was trying to open a PDF file with Acrobat (the full program, not just Reader) in Windows. Acrobat was and is the default program for PDF files and the system continuously started to ask for "a default program to open PDF files", again and again despite me choosing every time Acrobat and marking "use this program as default PDF opener". For whatever reason, MS Edge (which I never use) stuck as default PDF handler. Then, the problem with PDF files has disappeared (they open normally with Acrobat), but my system files don't merge anymore between Mac and Windows. I suspect both problems could be related (they happened simultaneously), but I have no idea if one is consequence of the other.

    I've also tried stopping for 10 minutes my ESET Internet Security 11 firewall in Windows, to no avail.

    Thanks for your valuable help.
  4. lesm2

    lesm2 Bit poster

    RamonC, any luck on this? I feel like this is 13.2.2 related, but I could be wrong. Regardless, I'm in the same boat as you.
  5. TirthankarB

    TirthankarB Junior Member

    Have the issue solved?
  6. RamonC

    RamonC Bit poster


    Well, I removed the Windows 10 virtual machine and reinstalled it. Annoying process if you have lots of programs in Windows, but it worked.

    That said, I noticed after the reinstallation that there is a "Restore" option at Parallels (double bar icon on right top of Mac screen) --> Actions menu. May be it could solve the problem, but I'm just guessing.

    One tip: be sure that you uninstall your Windows key before removing the virtual machine, so that you have the key free to be used again after reinstallation. If not, Windows thinks the key is still in use and will refuse to activate your reinstallation.

Share This Page