Free Memory and Beach Ball of Death

Discussion in 'Parallels Toolbox for Mac' started by TD2, Apr 5, 2020.

Tags:
  1. TD2

    TD2 Bit Poster

    Messages:
    3
    Hello,
    Can anyone help with how to deactivate the Free Memory option in the Toolbox. It is not functioning properly and hangs up 99% of the time by not responding to the click in the toolbar. The cursor also turns to the Mac beach ball when hovering over its icon in the toolbar. I have tried uninstalling Toolbox, then reinstalling, but the Free Memory app is persistent and automatically shows up. I've gone to system preferences and removed it from the startup auto login, but when I restart my Mac, It's back in the toolbar.
    Any help to remove this would be appreciated. I like the Toolbox, but this particular item is very frustrating and I can't find any reference for it anywhere on the web.
    Thank you.
    MacBook Pro (Retina, 15-inch, Early 2013)
    2.7 GHz Quad-Core Intel Core i7
    RAM 16 GB 1600 MHz DDR3
    Intel HD Graphics 4000 1536 MB
    OS: 10.15.4 (Catalina)
    ToolBox v: 3.9.0 (3037)
     
  2. sergk

    sergk Parallels Developers

    Messages:
    449
    Hello,
    all you need is turn OFF option 'Show Free Memory in menu bar'.
    To do this:
    - open Activity Monitor, find "Free Memory" process and stop it.
    - open Toolbox, find "Free Memory" tool and press on cogwheel button to open preferences of "Free Memory" tool
    - uncheck 'Show Free Memory in menu bar', press done, close Free Memory tool.
     
  3. TD2

    TD2 Bit Poster

    Messages:
    3
    Hello,
    I followed your actions to the letter and once my machine boots up, it's right back in the menu bar (I think I called the menu bar a toolbar in the original post) and running (not responding). Any additional suggestions aside from napalm?
    Much appreciated.
     
  4. sergk

    sergk Parallels Developers

    Messages:
    449
    Please check that "Free Memory Launcher" is not in Login Items:
    - Open Activity Monitor, find "Free Memory" process and stop it.
    - Open "System Preferences application" -> Users & Groups -> choose current user in the left list -> switch to "Login Items" tab
    - Find "Free Memory Launcher" in the list (if exists) and remove it. Note that you have to unlock changes by pressing on 'lock' icons and entering admin password.
     
  5. TD2

    TD2 Bit Poster

    Messages:
    3
    Hello again, the users and groups thing was the first thing I did before posting on this forum, and I attempted again, and again, and again. I've been trying to vary the sequence for your second suggestion while also repeating the first suggestion. Nothing works to kill the free memory from starting up with my mac every single iteration. Would (could) there be any other ideas of what could be done? This thing is very persistent and a resource suck. Thank you.
     
  6. sergk

    sergk Parallels Developers

    Messages:
    449
    Hello, I will ask support engineers to contact with you and try to work it out.
     
  7. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,429
    Hello, please check your inbox for the further issue investigation.
     
  8. Alper Tunç

    Alper Tunç Bit Poster

    Messages:
    1
    Hello,
    I'm having the same problem. I cannot get rid of the Free Memory application of Parallels Toolbox. It starts again in each restart. Did you figure out how to do it?
    Thank you.
     
  9. George16

    George16

    Messages:
    1
    Hello,
    I'm having the same problem with Free Memory. It launches in every restart.
    thanks
     
  10. CharlieH1

    CharlieH1 Bit Poster

    Messages:
    3
    +1 here. Same issue with Free Memory. Very much unwanted but keeps popping up, using resources and hard to get rid of. Like my Mother-in-Law. Pls resolve.
     
  11. Mike Verzella

    Mike Verzella Bit Poster

    Messages:
    1
    i am having the same issue with Free Memory as everyone else describes it here. The app is not listed in Users & Groups, starts with each boot and hangs at 100%+ CPU usage.
     
  12. PatrickS26

    PatrickS26 Bit Poster

    Messages:
    1
    Yeah - Parallels Free Memory tool in Parallels Toolbox is rotten, I have same problem on 2012 MBP. You'd think that company would test their Toolbox components better. This has been a problem for more than a year. FIX IT
     
  13. ClintE

    ClintE Bit Poster

    Messages:
    1
    I am also having this problem, I have tried all the above fixes but it turns back on with every reboot. Is there a fix coming for this?
    I am using a MacBook Pro 15inch 2017
    2.9GHz QC I7
    16GB Memory
    macOS Big Sur 11.1
     
  14. MarcusH

    MarcusH Bit Poster

    Messages:
    15
    Same problem here. Why would Parallels even release such a crapy software component? OMG!!
     
  15. ShazronA

    ShazronA Bit Poster

    Messages:
    4
    I don't even have Parallels Toolbox running at startup and Free Memory is running somehow taking up almost 100% CPU (and not responding) for some reason. I'm sure I unchecked that option in the Preferences too.

    No worries, just delete (or rename) "/Applications/Parallels\ Toolbox.app/Contents/Applications/Free\ Memory.app" (you'll have to restore the app if you really want to use it later, although I'm not sure why - reminds me of those similar apps during the Windows 95 days).
     
  16. ShazronA

    ShazronA Bit Poster

    Messages:
    4
    Right click on "Parallels Toolbox.app" in your Applications folder, and choose "Show Package Contents" if you want to do it via the GUI.
     
  17. sergk

    sergk Parallels Developers

    Messages:
    449
    Hello,
    To remove Free Memory tool from autostart you need:
    - Kill "Free Memory" application using Activity Monitor application;
    - Open Free Memory tool again and go to it's preferences (cogwheel in right top corner);
    - Uncheck 'Show Free Memory in menu bar' option;
    - In Terminal application run this command and make sure that output of this command doesn't contain 'com.parallels.toolbox.FreeMemory' string:
    Code:
    defaults read com.parallels.toolbox LaunchAtLoginTools
    - Restart your mac and check that Free Memory tool is not started;
     

Share This Page